Прошу проверить скрипт

О том о сем
Аватара пользователя

Автор темы
BadBird
Сообщения: 1329
Зарегистрирован: 09 сен 2016, 18:08
Решено: 2
Благодарил (а): 63 раза
Поблагодарили: 116 раз

Прошу проверить скрипт

Сообщение BadBird » 02 май 2017, 11:41

wanoska писал(а): мне кажется разницы не будет
Тогда оставим как есть..
wanoska писал(а): какую ошибку говорит?
Вот:

Код: Выделить всё

'/home/xubuntu/Настройка системы1.sh'
--2017-05-02 11:24:43--  http://archive.ubuntu.com/ubuntu/pool/main/l/lsb/lsb-invalid-mta_4.1+Debian11ubuntu8_all.deb
Resolving archive.ubuntu.com (archive.ubuntu.com)... 91.189.88.152, 91.189.88.161, 91.189.88.149, ...
Connecting to archive.ubuntu.com (archive.ubuntu.com)|91.189.88.152|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 5238 (5,1K) [application/x-debian-package]
Saving to: ‘lsb-invalid-mta_4.1+Debian11ubuntu8_all.deb’

lsb-invalid-mta_4.1 100%[===================>]   5,12K  --.-KB/s    in 0s      

2017-05-02 11:24:43 (176 MB/s) - ‘lsb-invalid-mta_4.1+Debian11ubuntu8_all.deb’ saved [5238/5238]

--2017-05-02 11:24:43--  http://archive.ubuntu.com/ubuntu/pool/main/l/lsb/lsb-security_4.1+Debian11ubuntu8_amd64.deb
Resolving archive.ubuntu.com (archive.ubuntu.com)... 91.189.88.161, 91.189.88.149, 91.189.88.162, ...
Connecting to archive.ubuntu.com (archive.ubuntu.com)|91.189.88.161|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 4884 (4,8K) [application/x-debian-package]
Saving to: ‘lsb-security_4.1+Debian11ubuntu8_amd64.deb’

lsb-security_4.1+De 100%[===================>]   4,77K  --.-KB/s    in 0s      

2017-05-02 11:24:44 (185 MB/s) - ‘lsb-security_4.1+Debian11ubuntu8_amd64.deb’ saved [4884/4884]

--2017-05-02 11:24:44--  http://archive.ubuntu.com/ubuntu/pool/main/l/lsb/lsb-core_4.1+Debian11ubuntu8_amd64.deb
Resolving archive.ubuntu.com (archive.ubuntu.com)... 91.189.88.149, 91.189.88.162, 91.189.88.152, ...
Connecting to archive.ubuntu.com (archive.ubuntu.com)|91.189.88.149|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 27382 (27K) [application/x-debian-package]
Saving to: ‘lsb-core_4.1+Debian11ubuntu8_amd64.deb’

lsb-core_4.1+Debian 100%[===================>]  26,74K  --.-KB/s    in 0,09s   

2017-05-02 11:24:44 (299 KB/s) - ‘lsb-core_4.1+Debian11ubuntu8_amd64.deb’ saved [27382/27382]

Выбор ранее не выбранного пакета lsb-core.
(Чтение базы данных … на данный момент установлен 171371 файл и каталог.)
Подготовка к распаковке lsb-core_4.1+Debian11ubuntu8_amd64.deb …
Распаковывается lsb-core (4.1+Debian11ubuntu8) …
Выбор ранее не выбранного пакета lsb-invalid-mta.
Подготовка к распаковке lsb-invalid-mta_4.1+Debian11ubuntu8_all.deb …
Распаковывается lsb-invalid-mta (4.1+Debian11ubuntu8) …
Выбор ранее не выбранного пакета lsb-security.
Подготовка к распаковке lsb-security_4.1+Debian11ubuntu8_amd64.deb …
Распаковывается lsb-security (4.1+Debian11ubuntu8) …
dpkg: зависимости пакетов не позволяют настроить пакет lsb-core:
 lsb-core зависит от at, однако:
  Пакет at не установлен.
 lsb-core зависит от m4, однако:
  Пакет m4 не установлен.
 lsb-core зависит от mailx | mailutils, однако:
  Пакет mailx не установлен.
  Пакет mailutils не установлен.
 lsb-core зависит от ncurses-term, однако:
  Пакет ncurses-term не установлен.
 lsb-core зависит от pax, однако:
  Пакет pax не установлен.
 lsb-core зависит от alien (>= 8.36), однако:
  Пакет alien не установлен.
 lsb-core зависит от libc6-i386, однако:
  Пакет libc6-i386 не установлен.
 lsb-core зависит от lib32z1, однако:
  Пакет lib32z1 не установлен.

dpkg: ошибка при обработке пакета lsb-core (--install):
 проблемы зависимостей — оставляем не настроенным
Настраивается пакет lsb-invalid-mta (4.1+Debian11ubuntu8) …
Настраивается пакет lsb-security (4.1+Debian11ubuntu8) …
Обрабатываются триггеры для man-db (2.7.5-1) …
При обработке следующих пакетов произошли ошибки:
 lsb-core
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
  alien at autotools-dev build-essential debhelper debugedit
  dh-strip-nondeterminism dpkg-dev fakeroot g++ g++-5 lib32z1
  libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl
  libc6-i386 libfakeroot libfile-stripnondeterminism-perl liblua5.2-0
  libmail-sendmail-perl librpm3 librpmbuild3 librpmio3 librpmsign3
  libstdc++-5-dev libsys-hostname-long-perl m4 ncurses-term pax po-debconf rpm
  rpm-common rpm2cpio s-nail
Предлагаемые пакеты:
  dh-make rpm-i18n debian-keyring g++-multilib g++-5-multilib gcc-5-doc
  libstdc++6-5-dbg libstdc++-5-doc libmail-box-perl elfutils rpmlint rpm2html
НОВЫЕ пакеты, которые будут установлены:
  alien at autotools-dev build-essential debhelper debugedit
  dh-strip-nondeterminism dpkg-dev fakeroot g++ g++-5 lib32z1
  libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl
  libc6-i386 libfakeroot libfile-stripnondeterminism-perl liblua5.2-0
  libmail-sendmail-perl librpm3 librpmbuild3 librpmio3 librpmsign3
  libstdc++-5-dev libsys-hostname-long-perl m4 ncurses-term pax po-debconf rpm
  rpm-common rpm2cpio s-nail
обновлено 0, установлено 34 новых пакетов, для удаления отмечено 0 пакетов, и 3 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 13,0 MB/15,4 MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 62,1 MB.
Пол:1 cdrom://Xubuntu 16.04.2 LTS _Xenial Xerus_ - Release amd64 (20170215) xenial/main amd64 libc6-i386 amd64 2.23-0ubuntu5 [2 329 kB]
Пол:2 cdrom://Xubuntu 16.04.2 LTS _Xenial Xerus_ - Release amd64 (20170215) xenial/main amd64 libfakeroot amd64 1.20.2-1ubuntu1 [25,5 kB]
Пол:3 cdrom://Xubuntu 16.04.2 LTS _Xenial Xerus_ - Release amd64 (20170215) xenial/main amd64 fakeroot amd64 1.20.2-1ubuntu1 [61,8 kB]
Пол:4 http://archive.ubuntu.com/ubuntu xenial/main amd64 at amd64 3.1.18-2ubuntu1 [37,8 kB]
Пол:5 http://archive.ubuntu.com/ubuntu xenial/main amd64 m4 amd64 1.4.17-5 [195 kB]
Пол:6 http://security.ubuntu.com/ubuntu xenial-security/main amd64 libstdc++-5-dev amd64 5.4.0-6ubuntu1~16.04.4 [1 426 kB]
Пол:7 http://archive.ubuntu.com/ubuntu xenial/universe amd64 s-nail amd64 14.8.6-1 [353 kB]
Пол:8 http://archive.ubuntu.com/ubuntu xenial/main amd64 ncurses-term all 6.0+20160213-1ubuntu1 [249 kB]
Пол:9 http://archive.ubuntu.com/ubuntu xenial/main amd64 pax amd64 1:20151013-1 [78,8 kB]
Ошк:10 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 dpkg-dev all 1.18.4ubuntu1.1
  404  Not Found [IP: 91.189.88.162 80]
Пол:11 http://archive.ubuntu.com/ubuntu xenial/main amd64 po-debconf all 1.0.19 [234 kB]
Пол:12 http://archive.ubuntu.com/ubuntu xenial/main amd64 libfile-stripnondeterminism-perl all 0.015-1 [10,3 kB]
Пол:13 http://archive.ubuntu.com/ubuntu xenial/main amd64 dh-strip-nondeterminism all 0.015-1 [4 864 B]
Пол:14 http://archive.ubuntu.com/ubuntu xenial/main amd64 autotools-dev all 20150820.1 [39,8 kB]
Пол:15 http://archive.ubuntu.com/ubuntu xenial/main amd64 debhelper all 9.20160115ubuntu3 [739 kB]
Пол:16 http://archive.ubuntu.com/ubuntu xenial/main amd64 liblua5.2-0 amd64 5.2.4-1ubuntu1 [106 kB]
Пол:17 http://archive.ubuntu.com/ubuntu xenial/universe amd64 librpmio3 amd64 4.12.0.1+dfsg1-3build3 [68,7 kB]
Пол:18 http://archive.ubuntu.com/ubuntu xenial/universe amd64 librpm3 amd64 4.12.0.1+dfsg1-3build3 [155 kB]
Пол:19 http://archive.ubuntu.com/ubuntu xenial/universe amd64 librpmbuild3 amd64 4.12.0.1+dfsg1-3build3 [58,0 kB]
Пол:20 http://archive.ubuntu.com/ubuntu xenial/universe amd64 librpmsign3 amd64 4.12.0.1+dfsg1-3build3 [8 192 B]
Пол:21 http://archive.ubuntu.com/ubuntu xenial/universe amd64 rpm-common amd64 4.12.0.1+dfsg1-3build3 [25,7 kB]
Пол:22 http://archive.ubuntu.com/ubuntu xenial/universe amd64 rpm2cpio amd64 4.12.0.1+dfsg1-3build3 [7 756 B]
Пол:23 http://archive.ubuntu.com/ubuntu xenial/universe amd64 debugedit amd64 4.12.0.1+dfsg1-3build3 [15,5 kB]
Пол:24 http://archive.ubuntu.com/ubuntu xenial/universe amd64 rpm amd64 4.12.0.1+dfsg1-3build3 [114 kB]
Пол:25 http://archive.ubuntu.com/ubuntu xenial/universe amd64 alien all 8.95 [54,5 kB]
Пол:26 http://archive.ubuntu.com/ubuntu xenial/main amd64 lib32z1 amd64 1:1.2.8.dfsg-2ubuntu4 [52,2 kB]
Пол:27 http://archive.ubuntu.com/ubuntu xenial/main amd64 g++ amd64 4:5.3.1-1ubuntu1 [1 504 B]
Пол:28 http://archive.ubuntu.com/ubuntu xenial/main amd64 build-essential amd64 12.1ubuntu2 [4 758 B]
Пол:29 http://archive.ubuntu.com/ubuntu xenial/main amd64 libalgorithm-diff-perl all 1.19.03-1 [47,6 kB]
Пол:30 http://archive.ubuntu.com/ubuntu xenial/main amd64 libalgorithm-diff-xs-perl amd64 0.04-4build1 [11,0 kB]
Пол:31 http://archive.ubuntu.com/ubuntu xenial/main amd64 libalgorithm-merge-perl all 0.08-3 [12,0 kB]
Пол:32 http://archive.ubuntu.com/ubuntu xenial/main amd64 libsys-hostname-long-perl all 1.5-1 [11,7 kB]
Пол:33 http://archive.ubuntu.com/ubuntu xenial/main amd64 libmail-sendmail-perl all 0.79.16-1 [26,5 kB]
Пол:34 http://security.ubuntu.com/ubuntu xenial-security/main amd64 g++-5 amd64 5.4.0-6ubuntu1~16.04.4 [8 300 kB]
Получено 12,4 MБ за 52с (235 kБ/c)                                             
E: Не удалось получить http://archive.ubuntu.com/ubuntu/pool/main/d/dpkg/dpkg-dev_1.18.4ubuntu1.1_all.deb  404  Not Found [IP: 91.189.88.162 80]

E: Невозможно получить некоторые архивы, вероятно надо запустить apt-get update или попытаться повторить запуск с ключом --fix-missing
--2017-05-02 11:25:42--  https://dl.google.com/dl/earth/client/current/google-earth-stable_current_amd64.deb
Resolving dl.google.com (dl.google.com)... 188.0.185.18, 188.0.185.59, 188.0.185.31, ...
Connecting to dl.google.com (dl.google.com)|188.0.185.18|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 45349754 (43M) [application/vnd.debian.binary-package]
Saving to: ‘google-earth-stable_current_amd64.deb’

google-earth-stable 100%[===================>]  43,25M   226KB/s    in 5m 37s  

2017-05-02 11:31:19 (131 KB/s) - ‘google-earth-stable_current_amd64.deb’ saved [45349754/45349754]

Выбор ранее не выбранного пакета google-earth-stable.
(Чтение базы данных … на данный момент установлено 171396 файлов и каталогов.)
Подготовка к распаковке google-earth-stable_current_amd64.deb …
Распаковывается google-earth-stable (7.1.8.3036-r0) …
dpkg: зависимости пакетов не позволяют настроить пакет google-earth-stable:
 google-earth-stable зависит от lsb-core (>= 3.2), однако:
  Пакет lsb-core пока не настроен.

dpkg: ошибка при обработке пакета google-earth-stable (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для gnome-menus (3.13.3-6ubuntu3.1) …
Обрабатываются триггеры для desktop-file-utils (0.22-1ubuntu5) …
Обрабатываются триггеры для mime-support (3.59ubuntu1) …
Обрабатываются триггеры для man-db (2.7.5-1) …
При обработке следующих пакетов произошли ошибки:
 google-earth-stable
 ! Сообщение из: symon2014
Уволю!
wanoska писал(а): Если вот так попробывать?
Неее, легче через терминал, таким вот способом:

Код: Выделить всё

sudo cd /tmp;mkdir google-earth && cd google-earth;wget http://archive.ubuntu.com/ubuntu/pool/main/l/lsb/lsb-invalid-mta_4.1+Debian11ubuntu8_all.deb;wget http://archive.ubuntu.com/ubuntu/pool/main/l/lsb/lsb-security_4.1+Debian11ubuntu8_amd64.deb;wget http://archive.ubuntu.com/ubuntu/pool/main/l/lsb/lsb-core_4.1+Debian11ubuntu8_amd64.deb;sudo dpkg -i *.deb;sudo apt -f install;wget https://dl.google.com/dl/earth/client/current/google-earth-stable_current_amd64.deb;sudo dpkg -i google-earth-stable*.deb
Так ставиться без проблем, а через скрипт почему то не хочет...
Всё о тайлинге окон...ну, или почти всё: Тыц!!!

Аватара пользователя

Автор темы
BadBird
Сообщения: 1329
Зарегистрирован: 09 сен 2016, 18:08
Решено: 2
Благодарил (а): 63 раза
Поблагодарили: 116 раз

Прошу проверить скрипт

Сообщение BadBird » 02 май 2017, 11:47

Сообщение из: symon2014
:зло:

????

В чем проблема, не понял?
Всё о тайлинге окон...ну, или почти всё: Тыц!!!

Аватара пользователя

symon2014
Сообщения: 1578
Зарегистрирован: 29 авг 2016, 02:17
Решено: 19
Откуда: Феодосия
Благодарил (а): 47 раз
Поблагодарили: 427 раз

Прошу проверить скрипт

Сообщение symon2014 » 02 май 2017, 11:50

BadBird, Простыни под спойлер за тобой прятать? :aggressive:
:sry:
Debian (9.1) , LMDE2 , LM 18.2 Mate . Благодарности складываем сюда ---> R320161344462

Аватара пользователя

Автор темы
BadBird
Сообщения: 1329
Зарегистрирован: 09 сен 2016, 18:08
Решено: 2
Благодарил (а): 63 раза
Поблагодарили: 116 раз

Прошу проверить скрипт

Сообщение BadBird » 02 май 2017, 11:52

symon2014, вообще то простыню под спойлер спрятал я после нескольких секунд как был написан пост!!!
Ошибся тегом, сперва выбрал оффтоповский но спойлер я вставил...так что это банальные придирки, более схожие показать кто тут начальника - дворник а кто просто пользователь....
Всё о тайлинге окон...ну, или почти всё: Тыц!!!

Аватара пользователя

symon2014
Сообщения: 1578
Зарегистрирован: 29 авг 2016, 02:17
Решено: 19
Откуда: Феодосия
Благодарил (а): 47 раз
Поблагодарили: 427 раз

Прошу проверить скрипт

Сообщение symon2014 » 02 май 2017, 12:03

BadBird, Под спойлер убрал я. А под тэг <mod> не втавился смайл :smile: . Ещё один аргумент в пользу болталки.
:sry:
Debian (9.1) , LMDE2 , LM 18.2 Mate . Благодарности складываем сюда ---> R320161344462

Аватара пользователя

wanoska
Сообщения: 161
Зарегистрирован: 17 окт 2016, 12:36
Решено: 4
Откуда: Кинешма
Благодарил (а): 30 раз
Поблагодарили: 41 раз

Прошу проверить скрипт

Сообщение wanoska » 02 май 2017, 12:03

BadBird, а если попробывать lsb-core установить руками, sudo apt-get install lsb-core, а потом попробовать запустить проблемный огрызок скрипта.
P.S. тема навеяла идею сделать что то похожее на это, но вот не могу разобраться с самим скриптом, может есть у кого что то типа то кого только с комментариями
123.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.
LM18.2 Cinnamon 3.2.7 Kernel: 4.12.0-041200-generic

Аватара пользователя

Автор темы
BadBird
Сообщения: 1329
Зарегистрирован: 09 сен 2016, 18:08
Решено: 2
Благодарил (а): 63 раза
Поблагодарили: 116 раз

Прошу проверить скрипт

Сообщение BadBird » 02 май 2017, 12:08

symon2014 писал(а): Под спойлер убрал я.
Неее, свою простыню я сам лично спрятал под спойлер!
wanoska, я думаю, если делать какие то лишние движения (скрипт то ведь создается для автоматизма рутинной работы), то уж лучше как я и говорил выше, через терминал...
wanoska писал(а): P.S. тема навеяла идею сделать что то похожее на это
Было бы отлично!!!
Всё о тайлинге окон...ну, или почти всё: Тыц!!!

Аватара пользователя

wanoska
Сообщения: 161
Зарегистрирован: 17 окт 2016, 12:36
Решено: 4
Откуда: Кинешма
Благодарил (а): 30 раз
Поблагодарили: 41 раз

Прошу проверить скрипт

Сообщение wanoska » 02 май 2017, 12:15

BadBird писал(а): я думаю, если делать какие то лишние движения (скрипт то ведь создается для автоматизма рутинной работы), то уж лучше как я и говорил выше, через терминал...
потом просто дописать этот пакет в скрипт и всё, если поставится конечно.
LM18.2 Cinnamon 3.2.7 Kernel: 4.12.0-041200-generic

Аватара пользователя

Автор темы
BadBird
Сообщения: 1329
Зарегистрирован: 09 сен 2016, 18:08
Решено: 2
Благодарил (а): 63 раза
Поблагодарили: 116 раз

Прошу проверить скрипт

Сообщение BadBird » 02 май 2017, 12:21

wanoska, есть у меня версия, ставил на лайв режим, возможно это и играет роль, но опять же, в том же режиме через терминал глобус ставиться без проблем.
Ставить на реальное железо возможностей нет, по причине того что глобус уже установлен в ос и полностью его искоренить вряд ли удастся...какие то пакеты от него в любом случае останутся в ос.
Всё о тайлинге окон...ну, или почти всё: Тыц!!!

Аватара пользователя

wanoska
Сообщения: 161
Зарегистрирован: 17 окт 2016, 12:36
Решено: 4
Откуда: Кинешма
Благодарил (а): 30 раз
Поблагодарили: 41 раз

Прошу проверить скрипт

Сообщение wanoska » 02 май 2017, 13:11

BadBird, я уже сума начал сходить) там какие то круговые зависимости)))
wanoska@wanoska:~$ sudo dpkg -i ./deb/lsb-core_4.1+Debian8+deb7u1_amd64.deb
Выбор ранее не выбранного пакета lsb-core.
(Чтение базы данных … на данный момент установлено 120232 файла и каталога.)
Подготовка к распаковке …/lsb-core_4.1+Debian8+deb7u1_amd64.deb …
Распаковывается lsb-core (4.1+Debian8+deb7u1) …
dpkg: зависимости пакетов не позволяют настроить пакет lsb-core:
lsb-core зависит от pax, однако:
Пакет pax не установлен.
lsb-core зависит от rsync, однако:
Пакет rsync не установлен.
lsb-core зависит от libc6-i386, однако:
Пакет libc6-i386 не установлен.
lsb-core зависит от lib32z1, однако:
Пакет lib32z1 не установлен.

dpkg: ошибка при обработке пакета lsb-core (--install):
проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для man-db (2.7.0.2-5) …
При обработке следующих пакетов произошли ошибки:
lsb-core
wanoska@wanoska:~$ sudo apt-get install pa
Display all 144 possibilities? (y or n)
wanoska@wanoska:~$ sudo apt-get install pax
pax pax-britannica-data paxtest
pax-britannica paxctl pax-utils
wanoska@wanoska:~$ sudo apt-get install pax
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
lsb-core : Зависит: rsync
Зависит: libc6-i386 но он не будет установлен
Зависит: lib32z1 но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение).
wanoska@wanoska:~$ sudo apt-get install run
runawk rungetty runit runlim runsnakerun
wanoska@wanoska:~$ sudo apt-get install rsy
rsync rsyslog-elasticsearch rsyslog-mysql
rsyncrypto rsyslog-gnutls rsyslog-pgsql
rsyslog rsyslog-gssapi rsyslog-relp
rsyslog-doc rsyslog-mongodb
wanoska@wanoska:~$ sudo apt-get install rsync
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
lsb-core : Зависит: pax
Зависит: libc6-i386 но он не будет установлен
Зависит: lib32z1 но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение).
wanoska@wanoska:~$ sudo apt-get install libc6
libc6 libc6-dev-amd64 libc6-i386 libc6-x32
libc6-dbg libc6-dev-i386 libc6-i686 libc6-xen
libc6-dev libc6-dev-x32 libc6-pic
wanoska@wanoska:~$ sudo apt-get install libc6-i386
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
libc6-i386 : Зависит: libc6 (= 2.19-18+deb8u7) но 2.24-10 будет установлен
lsb-core : Зависит: pax
Зависит: rsync
Зависит: lib32z1 но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение).
wanoska@wanoska:~$ sudo apt-get install lib32z1
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
lib32z1 : Зависит: libc6-i386 (>= 2.4) но он не будет установлен
lsb-core : Зависит: pax
Зависит: rsync
Зависит: libc6-i386 но он не будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета, (или найдите другое решение).
видимо ему не хватает пакета lsb-core он только на него у меня ругается на железе, какая у тебя os 32 или 64?
LM18.2 Cinnamon 3.2.7 Kernel: 4.12.0-041200-generic

Аватара пользователя

Автор темы
BadBird
Сообщения: 1329
Зарегистрирован: 09 сен 2016, 18:08
Решено: 2
Благодарил (а): 63 раза
Поблагодарили: 116 раз

Прошу проверить скрипт

Сообщение BadBird » 02 май 2017, 13:15

wanoska писал(а): какая у тебя os 32 или 64?
х64
Всё о тайлинге окон...ну, или почти всё: Тыц!!!

Аватара пользователя

wanoska
Сообщения: 161
Зарегистрирован: 17 окт 2016, 12:36
Решено: 4
Откуда: Кинешма
Благодарил (а): 30 раз
Поблагодарили: 41 раз

Прошу проверить скрипт

Сообщение wanoska » 02 май 2017, 14:08

BadBird, что то у меня больше нет идей, надо взывать к высшим силам :help: :help: :help:
LM18.2 Cinnamon 3.2.7 Kernel: 4.12.0-041200-generic

Аватара пользователя

Chocobo
Сообщения: 5509
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1430 раз

Прошу проверить скрипт

Сообщение Chocobo » 02 май 2017, 14:33

А нафига вам вообще lsb-core, lsb-security тянуть дебками?
После установки lsb-core из реп - все зависимости гуглоземли были в норме
lsb-coregearth.png
Убрать wget'ы на lsb* пакеты и добавить строчку на установку lsb-core аптом.
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Аватара пользователя

Автор темы
BadBird
Сообщения: 1329
Зарегистрирован: 09 сен 2016, 18:08
Решено: 2
Благодарил (а): 63 раза
Поблагодарили: 116 раз

Прошу проверить скрипт

Сообщение BadBird » 02 май 2017, 14:50

wanoska писал(а): что то у меня больше нет идей,
Фигня, прорвемся )))
Chocobo писал(а): После установки lsb-core из реп - все зависимости гуглоземли были в норме
И этот пакет в моем случае нифига не установился....
Всё о тайлинге окон...ну, или почти всё: Тыц!!!

Аватара пользователя

Chocobo
Сообщения: 5509
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1430 раз

Прошу проверить скрипт

Сообщение Chocobo » 02 май 2017, 14:51

Ну и можно обработку зависимостей оставить самому апту, дабы строчки не плодить
sudo apt deb google-earth-stable*.deb сам все сделает :smile:

dpkg -i не разруливает зависимости сам, apt deb сделает норм, только стоит проверить как оно обстоит в целевой системе, если она отлична от минта

Аватара пользователя

Автор темы
BadBird
Сообщения: 1329
Зарегистрирован: 09 сен 2016, 18:08
Решено: 2
Благодарил (а): 63 раза
Поблагодарили: 116 раз

Прошу проверить скрипт

Сообщение BadBird » 02 май 2017, 15:07

Chocobo, так?

Код: Выделить всё

cd /tmp
mkdir google-earth && cd google-earth
wget http://archive.ubuntu.com/ubuntu/pool/main/l/lsb/lsb-invalid-mta_4.1+Debian11ubuntu8_all.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/l/lsb/lsb-security_4.1+Debian11ubuntu8_amd64.deb
wget http://archive.ubuntu.com/ubuntu/pool/main/l/lsb/lsb-core_4.1+Debian11ubuntu8_amd64.deb
dpkg -i *.deb
apt -f install -y
wget https://dl.google.com/dl/earth/client/current/google-earth-stable_current_amd64.deb
apt deb google-earth-stable*.deb -y
Последний раз редактировалось пользователем 1 BadBird; всего редактировалось раз: 2
Всё о тайлинге окон...ну, или почти всё: Тыц!!!

Аватара пользователя

Chocobo
Сообщения: 5509
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1430 раз

Прошу проверить скрипт

Сообщение Chocobo » 02 май 2017, 15:12

Каким образом подобрал версию 4.1 для установки? Из первого поста вижу что ксубунта, но не вижу какой версии дистрибутив.
Этот пакет собран в мае 14 года, за два года до релиза 16.04 - с репа xenial-updates он (lsb-core) 9.2 версии
Оно пойдет для trusty. Меня вот этот момент смущает больше.

А так, если не собирать пакеты по разным углам, то должно хваттить вот этой конструкции

Код: Выделить всё

cd /tmp
mkdir google-earth && cd google-earth
wget https://dl.google.com/dl/earth/client/c ... _amd64.deb
apt deb google-earth-stable*.deb -y
Скажи на чем мучаешь сей скрипт, чтоб можно было обсуждать ближе к реалиям :smile:

Аватара пользователя

Chocobo
Сообщения: 5509
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1430 раз

Прошу проверить скрипт

Сообщение Chocobo » 02 май 2017, 15:16

Не по теме
И да, для многострочных листингов когда - юзайте [code][/code] (пятая иконка на панели), icode только для инлайнов

Аватара пользователя

Автор темы
BadBird
Сообщения: 1329
Зарегистрирован: 09 сен 2016, 18:08
Решено: 2
Благодарил (а): 63 раза
Поблагодарили: 116 раз

Прошу проверить скрипт

Сообщение BadBird » 02 май 2017, 15:18

Chocobo писал(а): Каким образом подобрал версию 4.1 для установки?
Способ установки был взят отсюда: https://losst.ru/ustanovka-google-earth-v-ubuntu-16-04 (вариант Установка Google Earth в Ubuntu через терминал)
ОС хубунту 16.04.2 х64, на которую через терминал я без проблем установил данную программу.
Но а эксперименты провожу в лайв режиме той же ос.
Всё о тайлинге окон...ну, или почти всё: Тыц!!!

Аватара пользователя

Chocobo
Сообщения: 5509
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1430 раз

Прошу проверить скрипт

Сообщение Chocobo » 02 май 2017, 15:42

Странный выбор у того автора, ну да ладно, это их дела :smile:

BadBird, ну как-то вот так в условиях ксубунты

Код: Выделить всё

 apt update		# Необязательно, если давалось ранее по тексту
mkdir /tmp/google-earth && cd /tmp/google-earth
wget https://dl.google.com/dl/earth/client/current/google-earth-stable_current_amd64.deb
apt install ./google-earth-stable_current_amd64.deb
xub1.png
xub2.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Вернуться в «Болталка: Оффтоп, разбор полетов»