Bumblebee (Nvidia + Intel) в Linux Mint 18.X

Не знаете как установить драйвер? Возникли проблемы? Вам сюда!
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот
Аватара пользователя

Dja
Сообщения: 4761
Зарегистрирован: 27 авг 2016, 17:03
Решено: 15
Откуда: Voskresensk
Благодарил (а): 645 раз
Поблагодарили: 493 раза

Bumblebee (Nvidia + Intel) в Linux Mint 18.X

Сообщение Dja » 10 сен 2018, 03:53

darkfenix, не помогло :hoho:
dja-laptop ~ $ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT="nouveau.modeset=0 pcie_aspm=off"
GRUB_CMDLINE_LINUX="nogpumanager"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
dja-laptop ~ $ inxi -Fxz
System:    Host: dja-laptop Kernel: 4.15.0-33-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18.3 Sylvia
Machine:   System: ASUSTeK (portable) product: X541UVK v: 1.0
           Mobo: ASUSTeK model: X541UVK v: 1.0 Bios: American Megatrends v: X541UVK.308 date: 01/30/2018
CPU:       Dual core Intel Core i3-6006U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 7968
           clock speeds: max: 2000 MHz 1: 2000 MHz 2: 2000 MHz 3: 2000 MHz 4: 2000 MHz
Graphics:  Card-1: Intel Sky Lake Integrated Graphics bus-ID: 00:02.0
           Card-2: NVIDIA Device 134f bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1920x1080@60.05hz
           GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
           GLX Version: 3.0 Mesa 18.0.5 Direct Rendering: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.15.0-33-generic
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 02:00.2
           IF: enp2s0f2 state: down mac: <filter>
           Card-2: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be port: c000 bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 1000.2GB (40.4% used) ID-1: /dev/sda model: ST1000LM035 size: 1000.2GB
Partition: ID-1: / size: 48G used: 7.2G (16%) fs: ext4 dev: /dev/sda2
           ID-2: /home size: 193G used: 1.6G (1%) fs: ext4 dev: /dev/sda4
           ID-3: swap-1 size: 9.44GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 37.5C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 195 Uptime: 0 min Memory: 382.7/7858.7MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
dja-laptop ~ $ 

Аватара пользователя

AlexZ
Сообщения: 635
Зарегистрирован: 06 янв 2018, 18:06
Решено: 1
Благодарил (а): 87 раз
Поблагодарили: 46 раз

Bumblebee (Nvidia + Intel) в Linux Mint 18.X

Сообщение AlexZ » 10 сен 2018, 04:30

Dja писал(а):
09 сен 2018, 18:23
FAILED: nouveau
Ты ни разу не сказал про это. Хорошо хоть написал, в принципе для остальных.. :smile:
Dja писал(а):
09 сен 2018, 18:23
Что это?
И почему 390,87 когда драйвер-манагер показывает "рекомендуемый" у 384 ?
МО - Менеджер обновлений, в Менеджере драйверов штатные драйвера. А в данном случае дрова актуальные ставишь из PPA

Аватара пользователя

Dja
Сообщения: 4761
Зарегистрирован: 27 авг 2016, 17:03
Решено: 15
Откуда: Voskresensk
Благодарил (а): 645 раз
Поблагодарили: 493 раза

Bumblebee (Nvidia + Intel) в Linux Mint 18.X

Сообщение Dja » 10 сен 2018, 04:38

AlexZ, когда параметр прописал, то после перезагрузки оно исчезло. Но после всего сделанного снова появлилось :crazy:

Аватара пользователя

AlexZ
Сообщения: 635
Зарегистрирован: 06 янв 2018, 18:06
Решено: 1
Благодарил (а): 87 раз
Поблагодарили: 46 раз

Bumblebee (Nvidia + Intel) в Linux Mint 18.X

Сообщение AlexZ » 10 сен 2018, 08:20

Dja писал(а):
10 сен 2018, 04:38
когда параметр прописал, то после перезагрузки оно исчезло. Но после всего сделанного снова появлилось
Попробуй убрать его, у меня его нет (потому что однократно загрузился с nomodeset, настроил бамблби и всё)
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash scsi_mod.use_blk_mq=1"
GRUB_CMDLINE_LINUX="nogpumanager"

Аватара пользователя

Dja
Сообщения: 4761
Зарегистрирован: 27 авг 2016, 17:03
Решено: 15
Откуда: Voskresensk
Благодарил (а): 645 раз
Поблагодарили: 493 раза

Bumblebee (Nvidia + Intel) в Linux Mint 18.X

Сообщение Dja » 10 сен 2018, 08:34

AlexZ писал(а):
10 сен 2018, 08:20
quiet splash
всегда убираю. Не люблю картинку при загрузке.
AlexZ писал(а):
10 сен 2018, 08:20
scsi_mod.use_blk_mq=1
тоже прописать?

Аватара пользователя

darkfenix
Сообщения: 3472
Зарегистрирован: 27 июн 2017, 10:36
Решено: 40
Откуда: Нижний Тагил
Благодарил (а): 221 раз
Поблагодарили: 616 раз

Bumblebee (Nvidia + Intel) в Linux Mint 18.X

Сообщение darkfenix » 10 сен 2018, 08:58

Dja писал(а):
10 сен 2018, 08:34
тоже прописать?
Думаю тебе это не нужно. Он же показал что у него там.
Изображение

Аватара пользователя

Dja
Сообщения: 4761
Зарегистрирован: 27 авг 2016, 17:03
Решено: 15
Откуда: Voskresensk
Благодарил (а): 645 раз
Поблагодарили: 493 раза

Bumblebee (Nvidia + Intel) в Linux Mint 18.X

Сообщение Dja » 10 сен 2018, 09:21

AlexZ, да. Убрал. Ушло теперь.

Аватара пользователя

AlexZ
Сообщения: 635
Зарегистрирован: 06 янв 2018, 18:06
Решено: 1
Благодарил (а): 87 раз
Поблагодарили: 46 раз

Bumblebee (Nvidia + Intel) в Linux Mint 18.X

Сообщение AlexZ » 10 сен 2018, 10:39

Dja писал(а):
10 сен 2018, 08:34
тоже прописать?
Это планировщик bfq Mint 18 c ядром 4.13+ - переходим на bfq (улучшаем отзывчивость интерфейса при тяжелых дисковых операциях)
Dja писал(а):
10 сен 2018, 09:21
Убрал. Ушло теперь.
Все ноуты с дискреткой nvidia как бы разделились на 2 лагеря - на к-рых система норм загружается со свободным драйвером nouveau, и на к-рых не загружается. Количество вторых по-моему только увеличивается.. Так вот для вторых этот параметр и нужен: если пользуются только intel-картой - то на постоянку, а если настроена nvidia-карта (прайм или бамблби) - только для первичной загрузки.

Аватара пользователя

Dja
Сообщения: 4761
Зарегистрирован: 27 авг 2016, 17:03
Решено: 15
Откуда: Voskresensk
Благодарил (а): 645 раз
Поблагодарили: 493 раза

Bumblebee (Nvidia + Intel) в Linux Mint 18.X

Сообщение Dja » 11 сен 2018, 08:41

AlexZ писал(а):
09 сен 2018, 17:18
9. Переконфигурируем bbswitch-dkms и драйвер nvidia-390
Это надо делать после каждого обновления ядра, генерик линукс кернел хеадерс, линукс кернел хеадерс фор девелопмент?

Аватара пользователя

AlexZ
Сообщения: 635
Зарегистрирован: 06 янв 2018, 18:06
Решено: 1
Благодарил (а): 87 раз
Поблагодарили: 46 раз

Bumblebee (Nvidia + Intel) в Linux Mint 18.X

Сообщение AlexZ » 11 сен 2018, 09:16

Dja писал(а):
11 сен 2018, 08:41
Это надо делать после каждого обновления ядра, генерик линукс кернел хеадерс, линукс кернел хеадерс фор девелопмент?
Нет, ничего больше делать не надо. При обновлении ядра автоматом всё это. Потом и драйвер обновится из PPA до 396, когда перейдет в разряд рекомендуемых. Для подстраховки сделай снимок перед этим..

Аватара пользователя

Dja
Сообщения: 4761
Зарегистрирован: 27 авг 2016, 17:03
Решено: 15
Откуда: Voskresensk
Благодарил (а): 645 раз
Поблагодарили: 493 раза

Bumblebee (Nvidia + Intel) в Linux Mint 18.X

Сообщение Dja » 11 сен 2018, 09:17

AlexZ, понял :thumbs:

Аватара пользователя

AlexZ
Сообщения: 635
Зарегистрирован: 06 янв 2018, 18:06
Решено: 1
Благодарил (а): 87 раз
Поблагодарили: 46 раз

Bumblebee (Nvidia + Intel) в Linux Mint 18.X

Сообщение AlexZ » 28 сен 2018, 16:10

Dja писал(а):
09 сен 2018, 18:23
И что такое фирмваре?
В LMDE3 у меня..
W: Possible missing firmware /lib/firmware/i915/skl_dmc_ver1_27.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_dmc_ver1_04.bin for module i915
W: Possible missing firmware /lib/firmware/i915/cnl_dmc_ver1_07.bin for module i915
W: Possible missing firmware /lib/firmware/i915/glk_dmc_ver1_04.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_guc_ver9_39.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_guc_ver9_29.bin for module i915
W: Possible missing firmware /lib/firmware/i915/skl_guc_ver9_33.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_huc_ver02_00_1810.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_huc_ver01_07_1398.bin for module i915
W: Possible missing firmware /lib/firmware/i915/skl_huc_ver01_07_1398.bin for module i915
W: Possible missing firmware /lib/firmware/nvidia/gm20b/pmu/sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gm20b/pmu/image.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gm20b/pmu/desc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/sec2/sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/sec2/image.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/sec2/desc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/nvdec/scrubber.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/sw_method_init.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/sw_bundle_init.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/sw_nonctx.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/sw_ctx.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/gpccs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/gpccs_data.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/gpccs_inst.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/gpccs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/fecs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/fecs_data.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/fecs_inst.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/gr/fecs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/acr/ucode_unload.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/acr/ucode_load.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/acr/unload_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp107/acr/bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/sec2/sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/sec2/image.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/sec2/desc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/nvdec/scrubber.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/gr/sw_method_init.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/gr/sw_bundle_init.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/gr/sw_nonctx.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/gr/sw_ctx.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/gr/gpccs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/gr/gpccs_data.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/gr/gpccs_inst.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/gr/gpccs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/gr/fecs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/gr/fecs_data.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/gr/fecs_inst.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/gr/fecs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/acr/ucode_unload.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/acr/ucode_load.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/acr/unload_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp106/acr/bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/sec2/sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/sec2/image.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/sec2/desc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/nvdec/scrubber.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/gr/sw_method_init.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/gr/sw_bundle_init.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/gr/sw_nonctx.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/gr/sw_ctx.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/gr/gpccs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/gr/gpccs_data.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/gr/gpccs_inst.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/gr/gpccs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/gr/fecs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/gr/fecs_data.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/gr/fecs_inst.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/gr/fecs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/acr/ucode_unload.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/acr/ucode_load.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/acr/unload_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp104/acr/bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/sec2/sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/sec2/image.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/sec2/desc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/nvdec/scrubber.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/gr/sw_method_init.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/gr/sw_bundle_init.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/gr/sw_nonctx.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/gr/sw_ctx.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/gr/gpccs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/gr/gpccs_data.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/gr/gpccs_inst.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/gr/gpccs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/gr/fecs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/gr/fecs_data.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/gr/fecs_inst.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/gr/fecs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/acr/ucode_unload.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/acr/ucode_load.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/acr/unload_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp102/acr/bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/sec2/sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/sec2/image.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/sec2/desc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/nvdec/scrubber.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/gr/sw_method_init.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/gr/sw_bundle_init.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/gr/sw_nonctx.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/gr/sw_ctx.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/gr/gpccs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/gr/gpccs_data.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/gr/gpccs_inst.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/gr/gpccs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/gr/fecs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/gr/fecs_data.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/gr/fecs_inst.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/gr/fecs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/acr/ucode_unload.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/acr/ucode_load.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/acr/unload_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp108/acr/bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp10b/pmu/sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp10b/pmu/image.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp10b/pmu/desc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp10b/gr/sw_method_init.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp10b/gr/sw_bundle_init.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp10b/gr/sw_nonctx.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp10b/gr/sw_ctx.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp10b/gr/gpccs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp10b/gr/gpccs_data.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp10b/gr/gpccs_inst.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp10b/gr/gpccs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp10b/gr/fecs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp10b/gr/fecs_data.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp10b/gr/fecs_inst.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp10b/gr/fecs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp10b/acr/ucode_load.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gp10b/acr/bl.bin for module nouveau

alex@acer:~$ apt policy firmware*
firmware-iwlwifi:
Установлен: 20161130-3
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
*** 20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
100 /var/lib/dpkg/status
firmware-realtek:
Установлен: 20161130-3
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
*** 20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
100 /var/lib/dpkg/status
firmware-ivtv:
Установлен: 20161130-3
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
*** 20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
100 /var/lib/dpkg/status
firmware-ralink:
Установлен: (отсутствует)
Кандидат: 20180825+dfsg-1~bpo9+1
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
firmware-qcom-media:
Установлен: (отсутствует)
Кандидат: 20180825+dfsg-1~bpo9+1
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
firmware-ti-connectivity:
Установлен: (отсутствует)
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
firmware-amd-graphics:
Установлен: 20161130-3
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
*** 20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
100 /var/lib/dpkg/status
firmware-myricom:
Установлен: (отсутствует)
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
firmware-samsung:
Установлен: (отсутствует)
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
firmware-atheros:
Установлен: 20161130-3
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
*** 20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
100 /var/lib/dpkg/status
firmware-libertas:
Установлен: 20161130-3
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
*** 20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
100 /var/lib/dpkg/status
firmware-netxen:
Установлен: (отсутствует)
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
firmware-linux-free:
Установлен: 3.4
Кандидат: 3.4
Таблица версий:
*** 3.4 500
500 https://deb.debian.org/debian stretch/main amd64 Packages
500 https://deb.debian.org/debian stretch/main i386 Packages
100 /var/lib/dpkg/status
firmware-intelwimax:
Установлен: 20161130-3
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
*** 20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
100 /var/lib/dpkg/status
firmware-linux-nonfree:
Установлен: 20161130-3
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
*** 20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
100 /var/lib/dpkg/status
firmware-brcm80211:
Установлен: 20161130-3
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
*** 20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
100 /var/lib/dpkg/status
firmware-intel-sound:
Установлен: (отсутствует)
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
firmware-cavium:
Установлен: (отсутствует)
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
firmware-b43legacy-installer:
Установлен: (отсутствует)
Кандидат: 1:019-3
Таблица версий:
1:019-3 500
500 https://deb.debian.org/debian stretch/contrib amd64 Packages
500 https://deb.debian.org/debian stretch/contrib i386 Packages
firmware-qlogic:
Установлен: 20161130-3
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
*** 20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
100 /var/lib/dpkg/status
firmware-adi:
Установлен: (отсутствует)
Кандидат: 20180825+dfsg-1~bpo9+1
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
firmware-zd1211:
Установлен: 1:1.5-4
Кандидат: 1:1.5-4
Таблица версий:
*** 1:1.5-4 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
100 /var/lib/dpkg/status
firmware-misc-nonfree:
Установлен: 20161130-3
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
*** 20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
100 /var/lib/dpkg/status
firmware-crystalhd:
Установлен: (отсутствует)
Кандидат: 0.0~git20120110.fdd2f19-1
Таблица версий:
0.0~git20120110.fdd2f19-1 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
firmware-netronome:
Установлен: (отсутствует)
Кандидат: 20180825+dfsg-1~bpo9+1
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
firmware-b43-installer:
Установлен: (отсутствует)
Кандидат: 1:019-3
Таблица версий:
1:019-3 500
500 https://deb.debian.org/debian stretch/contrib amd64 Packages
500 https://deb.debian.org/debian stretch/contrib i386 Packages
firmware-bnx2x:
Установлен: 20161130-3
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
*** 20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
100 /var/lib/dpkg/status
firmware-b43-lpphy-installer:
Установлен: (отсутствует)
Кандидат: (отсутствует)
Таблица версий:
firmware-linux:
Установлен: 20161130-3
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
*** 20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
100 /var/lib/dpkg/status
firmware-bnx2:
Установлен: 20161130-3
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
*** 20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
100 /var/lib/dpkg/status
firmware-ipw2x00:
Установлен: 20161130-3
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
*** 20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages
100 /var/lib/dpkg/status
firmware-siano:
Установлен: (отсутствует)
Кандидат: 20161130-3
Таблица версий:
20180825+dfsg-1~bpo9+1 100
100 https://deb.debian.org/debian stretch-backports/non-free amd64 Packages
100 https://deb.debian.org/debian stretch-backports/non-free i386 Packages
20161130-3 500
500 https://deb.debian.org/debian stretch/non-free amd64 Packages
500 https://deb.debian.org/debian stretch/non-free i386 Packages

alex@acer:~$ apt install -t stretch-backports firmware-linux
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Будут установлены следующие дополнительные пакеты:
firmware-amd-graphics firmware-linux-nonfree firmware-misc-nonfree
Рекомендуемые пакеты:
amd64-microcode
Пакеты, которые будут обновлены:
firmware-amd-graphics firmware-linux firmware-linux-nonfree firmware-misc-nonfree
А intel-microcode отсутствует..
alex@acer:~$ sudo apt install intel-microcode
[sudo] пароль для alex:
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Будут установлены следующие дополнительные пакеты:
iucode-tool
НОВЫЕ пакеты, которые будут установлены:
intel-microcode iucode-tool
обновлено 0, установлено 2 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Необходимо скачать 1 348 kБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 1 744 kB.

Аватара пользователя

darkfenix
Сообщения: 3472
Зарегистрирован: 27 июн 2017, 10:36
Решено: 40
Откуда: Нижний Тагил
Благодарил (а): 221 раз
Поблагодарили: 616 раз

Bumblebee (Nvidia + Intel) в Linux Mint 18.X

Сообщение darkfenix » 28 сен 2018, 16:15

AlexZ писал(а):
28 сен 2018, 16:10
А intel-microcode отсутствует.
Это да. В LMDE3(ну и в debian9, вероятнее всего) надо ставить ручками микрокод.
Изображение

Аватара пользователя

AlexZ
Сообщения: 635
Зарегистрирован: 06 янв 2018, 18:06
Решено: 1
Благодарил (а): 87 раз
Поблагодарили: 46 раз

Bumblebee (Nvidia + Intel) в Linux Mint 18.X

Сообщение AlexZ » 20 окт 2018, 20:15

Ну вот, Нвидиа для моей карточки рекомендует уже 410.66 (манджарик уже обновил до этой версии)
https://www.nvidia.ru/Download/driverRe ... /139010/ru
А в LM на этот раз обновился только один пакет nvidia-settings. Надо разбираться..

Аватара пользователя

darkfenix
Сообщения: 3472
Зарегистрирован: 27 июн 2017, 10:36
Решено: 40
Откуда: Нижний Тагил
Благодарил (а): 221 раз
Поблагодарили: 616 раз

Bumblebee (Nvidia + Intel) в Linux Mint 18.X

Сообщение darkfenix » 21 окт 2018, 07:29

AlexZ, в репах арча просто уже собрали новый пакет, а для ubuntu еще нет
Изображение

Аватара пользователя

AlexZ
Сообщения: 635
Зарегистрирован: 06 янв 2018, 18:06
Решено: 1
Благодарил (а): 87 раз
Поблагодарили: 46 раз

Bumblebee (Nvidia + Intel) в Linux Mint 18.X

Сообщение AlexZ » 21 окт 2018, 16:51

darkfenix писал(а):
21 окт 2018, 07:29
а для ubuntu еще нет
так у меня из PPA драйвер..
deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial main
зачем тогда nvidia-settings обновили (он и не запускается кстати..)
~ $ apt policy nvidia-settings
nvidia-settings:
Установлен: 410.66-0ubuntu0~gpu16.04.1
Кандидат: 410.66-0ubuntu0~gpu16.04.1
Таблица версий:
*** 410.66-0ubuntu0~gpu16.04.1 500
500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial/main amd64 Packages
100 /var/lib/dpkg/status
361.42-0ubuntu1 500
500 http://mirror.timeweb.ru/ubuntu xenial/main amd64 Packages

~ $ sudo nvidia-settings

ERROR: Unable to load info from any available system

Аватара пользователя

darkfenix
Сообщения: 3472
Зарегистрирован: 27 июн 2017, 10:36
Решено: 40
Откуда: Нижний Тагил
Благодарил (а): 221 раз
Поблагодарили: 616 раз

Bumblebee (Nvidia + Intel) в Linux Mint 18.X

Сообщение darkfenix » 21 окт 2018, 16:58

AlexZ, а в ппа кто собирает пакеты - такие же люди как ты и я, и у них есть работа, семья и они не обязаны никому собирать свежий пакет для драйвера, как только оный вышел. А nvidia-settings мог обновиться из убунтовых реп.
Изображение

Аватара пользователя

AlexZ
Сообщения: 635
Зарегистрирован: 06 янв 2018, 18:06
Решено: 1
Благодарил (а): 87 раз
Поблагодарили: 46 раз

Bumblebee (Nvidia + Intel) в Linux Mint 18.X

Сообщение AlexZ » 21 окт 2018, 17:09

darkfenix писал(а):
21 окт 2018, 16:58
А nvidia-settings мог обновиться из убунтовых реп
Он его из PPA тянул. Предлагаешь подождать, лады. Все равно не актуально уже :poh: , 19.1 на подходе..

Вернуться в «Видеокарты»