Qt Creator 4.3.1

Правила форума
Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа.
Аватара пользователя
Grombixalo
Сообщения: 30
Зарегистрирован: 22 мар 2017, 07:29
Благодарил (а): 13 раз

Qt Creator 4.3.1

Сообщение Grombixalo » 16 июл 2017, 17:07

Доброго времени суток.

Установил фреймворк Qt 5.9.1. До этого устанавливал более ранние версии и проблем не возникало, но теперь имею вот такой "казус бели".
► Показать


Я так понимаю, что проблема в линуксе, но я вообще такой папки по данному пути не нахожу. Подскажите в какую сторону копать, дабы решить проблему.

З.Ы.
► Показать

Аватара пользователя
Grombixalo
Сообщения: 30
Зарегистрирован: 22 мар 2017, 07:29
Благодарил (а): 13 раз

Qt Creator 4.3.1

Сообщение Grombixalo » 16 июл 2017, 17:53

Мдя. Сам пою. Сам играю.

Упорными ударами головой "АП" поисковик нашел вот такое неполное решение проблемы. Но хотелось бы все таки выяснить, что за ерунда такая?
https://forum.qt.io/topic/78552/qt-creator-community-5-8-on-ubuntu-16-04/6

Аватара пользователя
Chocobo
Сообщения: 4605
Зарегистрирован: 27 авг 2016, 19:57
Решено: 110
Откуда: НН
Благодарил (а): 375 раз
Поблагодарили: 1236 раз

Qt Creator 4.3.1

Сообщение Chocobo » 16 июл 2017, 18:06

Grombixalo писал(а):Источник цитаты вообще такой папки по данному пути не нахожу.

У меня этот файл притянут месой, точней пакетом libgl1-mesa-dev, попробуй доставить.

Код: Выделить всё

chocobo@desktop ~> ls -l /usr/lib/x86_64-linux-gnu/libGL.so
lrwxrwxrwx 1 root root 13 янв 26 03:17 /usr/lib/x86_64-linux-gnu/libGL.so -> mesa/libGL.so
chocobo@desktop ~> dpkg -S /usr/lib/x86_64-linux-gnu/libGL.so
libgl1-mesa-dev:amd64: /usr/lib/x86_64-linux-gnu/libGL.so
Изображение

Аватара пользователя
Grombixalo
Сообщения: 30
Зарегистрирован: 22 мар 2017, 07:29
Благодарил (а): 13 раз

Qt Creator 4.3.1

Сообщение Grombixalo » 16 июл 2017, 18:26

Попробовал. Получил такой же результат, как и у Вас, но не заработало. Выдает ту же ошибку.

З.Ы. Работает только по примеру приведенному мною во втором посте.
З.Ы.Ы. Самое интересное, что когда надо компилировать не под десктоп, а под андроид изменения в файле проекта надо убирать. И пишет, что работает под OpenGL, но я же установил проприетарные драйвера видеокарты. Или нет? (Display Server: X.Org 1.18.4 drivers: ati,amdgpu (unloaded: fbdev,vesa,radeon)) В общем у меня есть подозрение, что проблема в драйверах. Завтра попробую обновить ядро до 4.8.5, которое у меня точно работало с amdgpu-pro и повторно установить проприетарные драйвера.

Аватара пользователя
Grombixalo
Сообщения: 30
Зарегистрирован: 22 мар 2017, 07:29
Благодарил (а): 13 раз

Qt Creator 4.3.1

Сообщение Grombixalo » 17 июл 2017, 17:37

Update.

Сегодня прошло обновление 'mesa-va-drivers" в менеджере обновлений. Установив данное обновление решил проблему полностью. Теперь для правильной компиляции "костыль" из второго поста не нужен.

Аватара пользователя
FliXis
Сообщения: 209
Зарегистрирован: 31 авг 2016, 11:01
Решено: 5
Благодарил (а): 56 раз
Поблагодарили: 13 раз

Qt Creator 4.3.1

Сообщение FliXis » 17 июл 2017, 20:19

Раньше тоже были какие-то проблемы, но решал их установкой данных пакетов:
sudo apt-get install build-essential
sudo apt-get install libfontconfig1
sudo apt-get install mesa-common-dev
sudo apt-get install libglu1-mesa-dev -y

А у меня вот такое сообщение появилось в свежей версии креатора. Было еще на 18.1 до обновления на 18.2
Какая-то несовместимость с корицей, видимо.
QApplication: invalid style override passed, ignoring it.
Даже не знаю как это исправить.

Аватара пользователя
symon2014
Сообщения: 1523
Зарегистрирован: 29 авг 2016, 02:17
Решено: 18
Откуда: Феодосия
Благодарил (а): 46 раз
Поблагодарили: 408 раз

Qt Creator 4.3.1

Сообщение symon2014 » 17 июл 2017, 20:28

FliXis, Почитай здесь.
:sry:
Debian (8.8) , LMDE2 , LM 18.2 Mate .


Вернуться в «Иное программное обеспечение»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость