Qucs

Правила форума
Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа.
Аватара пользователя
Cahes
Сообщения: 55
Зарегистрирован: 28 мар 2017, 06:31
Благодарил (а): 1 раз

Qucs

Сообщение Cahes » 11 авг 2017, 19:31

Устанавливаю Qucs. В пояснении сказано:


► Показать


Лог:

► Показать


Чикинг, ошибка - что дальше? Как решать?

В сети
Аватара пользователя
Chocobo
Сообщения: 4556
Зарегистрирован: 27 авг 2016, 19:57
Решено: 107
Откуда: НН
Благодарил (а): 372 раза
Поблагодарили: 1221 раз

Qucs

Сообщение Chocobo » 11 авг 2017, 20:16

Cahes писал(а):Источник цитаты checking for Qt headers... configure: error: not found

apt install libqt4-dev
Изображение

Аватара пользователя
Cahes
Сообщения: 55
Зарегистрирован: 28 мар 2017, 06:31
Благодарил (а): 1 раз

Qucs

Сообщение Cahes » 12 авг 2017, 17:54

Chocobo писал(а):Источник цитаты apt install libqt4-dev


Не получилось.

Как я понял - речь идёт об установке "Qt SDK". Пройдя по инфам я наткнулся на предложение установить будучи скачаный пакет, который на соответствующем сайте предлагается как:

"Qt for Device Creation for free 30-day offer available"

Как поступить?

Аватара пользователя
Bill Williamson
Сообщения: 433
Зарегистрирован: 31 авг 2016, 10:38
Решено: 16
Благодарил (а): 161 раз
Поблагодарили: 85 раз

Qucs

Сообщение Bill Williamson » 12 авг 2017, 19:18

Cahes писал(а):Источник цитаты Пройдя по инфам я наткнулся на предложение установить будучи скачаный пакет

По ссылке github.com/ra3xdh/qucs/releases/tag/0.0.19S-rc6 есть инструкция, где написано:
Refer to README.md to install all necessary dependencies.
Вот его содержимое:
► Показать

У Вас установлены все указанные в этом файле зависимости?
Изображение

Аватара пользователя
Cahes
Сообщения: 55
Зарегистрирован: 28 мар 2017, 06:31
Благодарил (а): 1 раз

Qucs

Сообщение Cahes » 02 сен 2017, 18:42

Bill Williamson писал(а):Источник цитаты У Вас установлены все указанные в этом файле зависимости?


Простите - мне, как новичку, не понять - что за "зависимости" должен я увидеть в этом файле. Не могли бы вы конкретней выразиться?

В сети
Аватара пользователя
symon2014
Сообщения: 1509
Зарегистрирован: 29 авг 2016, 02:17
Решено: 18
Откуда: Феодосия
Благодарил (а): 46 раз
Поблагодарили: 398 раз

Qucs

Сообщение symon2014 » 02 сен 2017, 18:48

Вот это .
First make sure you have all dependencies installed:

Сначала убедитесь, что у вас установлены все зависимости:

sudo apt-get install build-essential
sudo apt-get install libqt4-dev libqt4-qt3support
sudo apt-get install automake libtool gperf flex bison
:sry:
Debian (8.8) , LMDE2 , LM 18.2 Mate .

Аватара пользователя
Cahes
Сообщения: 55
Зарегистрирован: 28 мар 2017, 06:31
Благодарил (а): 1 раз

Qucs

Сообщение Cahes » 05 сен 2017, 09:52

Добавил пять пакетов, хотя мне кажется - это обновлённые верии того - что я уже делал.

Запустил (через su):
cd qucs
./configure

На что получил:
...
checking Checking if admsXml is working... no
configure: error: need admsXml, but not found. consider --with-mkadms=<alternative admsXml>
configure: error: ./configure failed for qucs-core
...
Скачал пакет, разархивировал, сконфигурировал, собрал, инсталлировал через "make" и "make install", вроде всё прошло хорошо, но сконфигурировать Qucs так и не получилось - всё равно требует "admsXml". Что делать?

В сети
Аватара пользователя
darkfenix
Сообщения: 310
Зарегистрирован: 27 июн 2017, 10:36
Решено: 3
Благодарил (а): 25 раз
Поблагодарили: 48 раз

Qucs

Сообщение darkfenix » 05 сен 2017, 10:16

./configure не нужно запускать от sudo, make аналогично. А вот make install запускается от sudo
Cahes писал(а):Источник цитаты checking Checking if admsXml is working... no

Посмотреть тут

В сети
Аватара пользователя
Chocobo
Сообщения: 4556
Зарегистрирован: 27 авг 2016, 19:57
Решено: 107
Откуда: НН
Благодарил (а): 372 раза
Поблагодарили: 1221 раз

Qucs

Сообщение Chocobo » 05 сен 2017, 10:42

https://launchpad.net/~fransschreuder1/ ... ter=xenial :magic:
This is the official PPA qucs (http://qucs.sourceforge.net), until ubuntu will take qucs back in their repository.

Снимок экрана от 2017-09-05 13-40-10.png

Снимок экрана от 2017-09-05 13-41-01.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Изображение


Вернуться в «Иное программное обеспечение»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей