Базовая установка видеодрайвера в Linux Mint

Не знаете как установить драйвер? Возникли проблемы? Вам сюда!
Правила форума
Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа.
Аватара пользователя

adargeos
Сообщения: 180
Зарегистрирован: 09 окт 2016, 11:40
Решено: 8
Откуда: Москва
Благодарил (а): 21 раз
Поблагодарили: 45 раз

Re: Базовая установка видеодрайвера в Linux Mint

Сообщение adargeos » 23 дек 2016, 19:23

Код: Выделить всё

grep -R "radeon" /etc/modprobe.d/
grep -R "fbdev" /etc/modprobe.d/
grep -R "ati" /etc/modprobe.d/
grep -R "fglrx" /etc/modprobe.d/
if you do this - you know what you are doing


Unborn
Сообщения: 789
Зарегистрирован: 03 сен 2016, 10:36
Решено: 15
Благодарил (а): 2 раза
Поблагодарили: 119 раз

Re: Базовая установка видеодрайвера в Linux Mint

Сообщение Unborn » 23 дек 2016, 20:23

rel, у тебя для встроенной карты нужен Каталист 13.1, а для дискретки 15.9, но может оказаться так, что всегда должны работать обе карты. Дискретка считает, а встроенная выводит.
Пробуй установить проприетарь на встроенную карту.


rel
Сообщения: 13
Зарегистрирован: 18 дек 2016, 12:33
Благодарил (а): 2 раза

Re: Базовая установка видеодрайвера в Linux Mint

Сообщение rel » 24 дек 2016, 16:15

Наверное, на моём компьютере после установки драйвера нужно его настраивать через консольную программу aticonfig, чтобы он начал работать. Целое дело.
На свободном драйвере Linux просмотр видео в интернете загружает процессор на 90% с температурой 73-75 градуса. В Windows смотрим на низких оборотах - загрузка <30% температура 56-62. Правильно ли я понимаю, что такая нагрузка возникает потому, что драйвер Linux не задействует полностью мощности видеокарты?

Unborn, у меня в Менеджере драйверов только дискретная видеокарта отображается. В Windows встроенная видеокарта включается только при переходе ноута на питание от аккумулятора.


skymasterbb
Сообщения: 4
Зарегистрирован: 10 янв 2017, 18:14

Базовая установка видеодрайвера в Linux Mint

Сообщение skymasterbb » 10 янв 2017, 18:20

Прошу помочь с утсановкой драйвера на Radeon HD5450 на Linux Mint 18.1 Mate 32 бит ядро 4.4.0
skymasterbb@SkyNix ~/Загрузки $ sudo dpkg -i xserver*.deb
(Чтение базы данных … на данный момент установлено 339576 файлов и каталогов.)
Подготовка к распаковке xserver-common_1.17.3-2ubuntu4_all.deb …
Распаковывается xserver-common (2:1.17.3-2ubuntu4) на замену (2:1.17.3-2ubuntu4) …
Подготовка к распаковке xserver-xorg_7.7+13ubuntu3_i386.deb …
Распаковывается xserver-xorg (1:7.7+13ubuntu3) на замену (1:7.7+13ubuntu3) …
Подготовка к распаковке xserver-xorg-core-dbg_1.17.3-2ubuntu4_i386.deb …
Распаковывается xserver-xorg-core-dbg (2:1.17.3-2ubuntu4) на замену (2:1.17.3-2ubuntu4) …
Подготовка к распаковке xserver-xorg-input-evdev_2.9.2-1ubuntu1_i386.deb …
Распаковывается xserver-xorg-input-evdev (1:2.9.2-1ubuntu1) на замену (1:2.9.2-1ubuntu1) …
Подготовка к распаковке xserver-xorg-input-synaptics_1.8.2-1ubuntu2_i386.deb …
Распаковывается xserver-xorg-input-synaptics (1.8.2-1ubuntu2) на замену (1.8.2-1ubuntu2) …
Подготовка к распаковке xserver-xorg-input-vmmouse_12.6.4-1ubuntu1_i386.deb …
Распаковывается xserver-xorg-input-vmmouse (1:12.6.4-1ubuntu1) на замену (1:12.6.4-1ubuntu1) …
Подготовка к распаковке xserver-xorg-input-wacom_0.32.0-0ubuntu2_i386.deb …
Распаковывается xserver-xorg-input-wacom (1:0.32.0-0ubuntu2) на замену (1:0.32.0-0ubuntu2) …
Подготовка к распаковке xserver-xorg-video-intel_2.99.917+git20160325-1ubuntu1.2_i386.deb …
Распаковывается xserver-xorg-video-intel (2:2.99.917+git20160325-1ubuntu1.2) на замену (2:2.99.917+git20160325-1ubuntu1.2) …
Подготовка к распаковке xserver-xorg-video-radeon_7.6.1-1ubuntu1_i386.deb …
Распаковывается xserver-xorg-video-radeon (1:7.6.1-1ubuntu1) на замену (1:7.6.1-1ubuntu1) …
Настраивается пакет xserver-common (2:1.17.3-2ubuntu4) …
dpkg: зависимости пакетов не позволяют настроить пакет xserver-xorg:
xserver-xorg зависит от xserver-xorg-core (>= 2:1.17.2-2), однако:
Пакет xserver-xorg-core не установлен.

dpkg: ошибка при обработке пакета xserver-xorg (--install):
проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет xserver-xorg-core-dbg:
xserver-xorg-core-dbg зависит от xserver-xorg-core (= 2:1.17.3-2ubuntu4), однако:
Пакет xserver-xorg-core не установлен.

dpkg: ошибка при обработке пакета xserver-xorg-core-dbg (--install):
проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет xserver-xorg-input-evdev:
xserver-xorg-input-evdev зависит от xorg-input-abi-21, однако:
Пакет xorg-input-abi-21 не установлен.
xserver-xorg-input-evdev зависит от xserver-xorg-core (>= 2:1.16.99.901), однако:
Пакет xserver-xorg-core не установлен.

dpkg: ошибка при обработке пакета xserver-xorg-input-evdev (--install):
проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет xserver-xorg-input-synaptics:
xserver-xorg-input-synaptics зависит от xorg-input-abi-21, однако:
Пакет xorg-input-abi-21 не установлен.
xserver-xorg-input-synaptics зависит от xserver-xorg-core (>= 2:1.16.99.901), однако:
Пакет xserver-xorg-core не установлен.

dpkg: ошибка при обработке пакета xserver-xorg-input-synaptics (--install):
проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет xserver-xorg-input-vmmouse:
xserver-xorg-input-vmmouse зависит от xserver-xorg-core (>= 2:1.5.99.901), однако:
Пакет xserver-xorg-core не установлен.
xserver-xorg-input-vmmouse зависит от xserver-xorg-input-mouse, однако:
Пакет xserver-xorg-input-mouse не установлен.

dpkg: ошибка при обработке пакета xserver-xorg-input-vmmouse (--install):
проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет xserver-xorg-input-wacom:
xserver-xorg-input-wacom зависит от xorg-input-abi-22, однако:
Пакет xorg-input-abi-22 не установлен.
xserver-xorg-input-wacom зависит от xserver-xorg-core (>= 2:1.17.99.902), однако:
Пакет xserver-xorg-core не установлен.

dpkg: ошибка при обработке пакета xserver-xorg-input-wacom (--install):
проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет xserver-xorg-video-intel:
xserver-xorg-video-intel зависит от xorg-video-abi-20, однако:
Пакет xorg-video-abi-20 не установлен.
xserver-xorg-video-intel зависит от xserver-xorg-core (>= 2:1.17.99.902), однако:
Пакет xserver-xorg-core не установлен.

dpkg: ошибка при обработке пакета xserver-xorg-video-intel (--install):
проблемы зависимостей — оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет xserver-xorg-video-radeon:
xserver-xorg-video-radeon зависит от xorg-video-abi-19, однако:
Пакет xorg-video-abi-19 не установлен.
xserver-xorg-video-radeon зависит от xserver-xorg-core (>= 2:1.16.99.901), однако:
Пакет xserver-xorg-core не установлен.

dpkg: ошибка при обработке пакета xserver-xorg-video-radeon (--install):
проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для man-db (2.7.5-1) …
Обрабатываются триггеры для libc-bin (2.23-0ubuntu5) …
При обработке следующих пакетов произошли ошибки:
xserver-xorg
xserver-xorg-core-dbg
xserver-xorg-input-evdev
xserver-xorg-input-synaptics
xserver-xorg-input-vmmouse
xserver-xorg-input-wacom
xserver-xorg-video-intel
xserver-xorg-video-radeon

Аватара пользователя

di_mok
Сообщения: 2217
Зарегистрирован: 27 авг 2016, 16:06
Решено: 15
Откуда: Арзамас
Благодарил (а): 575 раз
Поблагодарили: 339 раз

Базовая установка видеодрайвера в Linux Mint

Сообщение di_mok » 10 янв 2017, 18:30

Настоящая водка — это не пьянство, а ключ к своей совести, с нее-то и начинается настоящая мудрость. (c)


skymasterbb
Сообщения: 4
Зарегистрирован: 10 янв 2017, 18:14

Базовая установка видеодрайвера в Linux Mint

Сообщение skymasterbb » 10 янв 2017, 18:36

я там был...
там предлагают скачать файлы для архитектуры АМД64 а у меня ай386

Аватара пользователя

Автор темы
Chocobo
Сообщения: 5526
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1434 раза

Базовая установка видеодрайвера в Linux Mint

Сообщение Chocobo » 10 янв 2017, 18:44

skymasterbb, а в чем, если не секрет, необходимость в 32-х битной архитектуре и проприетарных драйверах? :scratch:
не могу выстроить логическую цепочку...


skymasterbb
Сообщения: 4
Зарегистрирован: 10 янв 2017, 18:14

Базовая установка видеодрайвера в Linux Mint

Сообщение skymasterbb » 10 янв 2017, 19:11

У меня слабая машина с 2 ГБ ОЗУ, смотрю на ней киношки онлайн, а все, что выше чем 480 - тормозит :-(
Я недавно с окон слез, так что сильно ногами не бейте

Аватара пользователя

Автор темы
Chocobo
Сообщения: 5526
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1434 раза

Базовая установка видеодрайвера в Linux Mint

Сообщение Chocobo » 10 янв 2017, 19:19

skymasterbb, руко-ногоприкладство у нас редко практикуется, так что не боись :smile:

Но вот обоснования тянуть на слабую (подозреваю все-таки старую) машинку 18-й минт - можно поставить под сомнения.

Засвети сюда inxi -Fxz, чтоб можно было в дальнейшем выстраивать стратегию)

Отправлено спустя 3 минуты 30 секунд:
И да, обычно когда тормозит мультимедиа, размер ОЗУ - дело второстепенное.
Вопрос именно какой камень и видеоадаптер

Аватара пользователя

PAVEL666
Сообщения: 78
Зарегистрирован: 05 сен 2016, 14:22
Благодарил (а): 18 раз
Поблагодарили: 5 раз

Базовая установка видеодрайвера в Linux Mint

Сообщение PAVEL666 » 11 янв 2017, 07:33

Тоже самое что у rel,только с nvidia. Помогите пожалуйста.
alexa@alexa-Aspire-M3630:~ > xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected primary 640x480+0+0 0mm x 0mm
640x480 73.0*

alexa@alexa-Aspire-M3630:~ > inxi -SG
System: Host: alexa-Aspire-M3630 Kernel: 4.9.2-040902-generic x86_64 (64 bit)
Desktop: KDE Plasma 4.14.2 Distro: Linux Mint 17.3 Rosa
Graphics: Card: NVIDIA GK208 [GeForce GT 640 Rev. 2]
Display Server: X.Org 1.17.1 drivers: nvidia,fbdev,nouveau (unloaded: vesa)
Resolution: 640x480@73.0hz
GLX Renderer: N/A GLX Version: N/A
Новый лох,лучше старых трёх!

Аватара пользователя

PAVEL666
Сообщения: 78
Зарегистрирован: 05 сен 2016, 14:22
Благодарил (а): 18 раз
Поблагодарили: 5 раз

Базовая установка видеодрайвера в Linux Mint

Сообщение PAVEL666 » 11 янв 2017, 10:41

Поставил более старый 340-й драйвер,заработало.Может ну его с новыми дровами танцевать?
Новый лох,лучше старых трёх!

Аватара пользователя

Автор темы
Chocobo
Сообщения: 5526
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1434 раза

Базовая установка видеодрайвера в Linux Mint

Сообщение Chocobo » 11 янв 2017, 11:09

PAVEL666, а система какой предлагает как рекомендуемый в менеджере драйверов?

Аватара пользователя

PAVEL666
Сообщения: 78
Зарегистрирован: 05 сен 2016, 14:22
Благодарил (а): 18 раз
Поблагодарили: 5 раз

Базовая установка видеодрайвера в Linux Mint

Сообщение PAVEL666 » 11 янв 2017, 11:13

360,но вот он и выдаёт одно разрешение и не нужное.
Новый лох,лучше старых трёх!

Аватара пользователя

Автор темы
Chocobo
Сообщения: 5526
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1434 раза

Базовая установка видеодрайвера в Linux Mint

Сообщение Chocobo » 11 янв 2017, 11:19

PAVEL666, Ну, в любом случае если опытным путем установил что 340-й не несет проблемы, то не вижу смысла не юзать его. Какого-то ощутимого выигрыша с обновления до 360 все равно не получишь (хотя и то, что рекомендованный сбоит - тоже странно)

Аватара пользователя

PAVEL666
Сообщения: 78
Зарегистрирован: 05 сен 2016, 14:22
Благодарил (а): 18 раз
Поблагодарили: 5 раз

Базовая установка видеодрайвера в Linux Mint

Сообщение PAVEL666 » 11 янв 2017, 11:26

Во-во.Ладно жена придёт,поюзает,тогда отпишу,а то на свободном зависал комп.
Новый лох,лучше старых трёх!


skymasterbb
Сообщения: 4
Зарегистрирован: 10 янв 2017, 18:14

Базовая установка видеодрайвера в Linux Mint

Сообщение skymasterbb » 11 янв 2017, 18:45

Chocobo писал(а): skymasterbb,
Засвети сюда inxi -Fxz, чтоб можно было в дальнейшем выстраивать стратегию)
skymasterbb@SkyNix ~ $ inxi -Fxz
System: Host: SkyNix Kernel: 4.4.0-59-generic i686 (32 bit gcc: 5.4.0)
Desktop: MATE 1.16.1 (Gtk 3.18.9-1ubuntu3.1)
Distro: Linux Mint 18.1 Serena
Machine: Mobo: ASUSTeK model: P5KPL-AM SE v: X.0x
Bios: American Megatrends v: 0602 date: 09/11/2009
CPU: Single core Intel Celeron 430 (-UP-) cache: 512 KB
flags: (lm nx pae sse sse2 sse3 ssse3) bmips: 3599 speed: 1799 MHz (max)
Graphics: Card: Advanced Micro Devices [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series]
bus-ID: 01:00.0
Display Server: X.Org 1.18.4 driver: N/A
Resolution: 1600x900@60.00hz
GLX Renderer: Gallium 0.4 on AMD CEDAR (DRM 2.43.0, LLVM 3.8.0)
GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio: Card-1 Intel NM10/ICH7 Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Card-2 Advanced Micro Devices [AMD/ATI] Cedar HDMI Audio [Radeon HD 5400/6300 Series]
driver: snd_hda_intel bus-ID: 01:00.1
Sound: Advanced Linux Sound Architecture v: k4.4.0-59-generic
Network: Card: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
driver: r8169 v: 2.3LK-NAPI port: e800 bus-ID: 02:00.0
IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 80.0GB (18.5% used)
ID-1: /dev/sda model: ST380815AS size: 80.0GB
Partition: ID-1: / size: 73G used: 13G (19%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 1.06GB used: 0.00GB (0%) fs: swap dev: /dev/dm-0
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 24.0C mobo: 33.0C gpu: 52.5
Fan Speeds (in rpm): cpu: 2295 sys-1: 0
Info: Processes: 169 Uptime: 3:06 Memory: 739.9/2013.4MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.461) inxi: 2.2.35
Отправлено спустя 12 минут 18 секунд:
И еще проблемка тут:
skymasterbb@SkyMint ~ $ inxi -Fxz
System: Host: SkyMint Kernel: 4.4.0-57-generic i686 (32 bit gcc: 5.4.0)
Desktop: Cinnamon 3.2.7 (Gtk 3.18.9-1ubuntu3.1)
Distro: Linux Mint 18.1 Serena
Machine: Mobo: ASRock model: K10N78D
Bios: American Megatrends v: P1.70 date: 04/26/2010
CPU: Dual core AMD Athlon II X2 250 (-MCP-) cache: 2048 KB
flags: (lm nx pae sse sse2 sse3 sse4a svm) bmips: 13199
clock speeds: max: 3000 MHz 1: 1800 MHz 2: 2300 MHz
Graphics: Card: NVIDIA GF116 [GeForce GTS 450 Rev. 2] bus-ID: 02:00.0
Display Server: X.Org 1.18.4 drivers: nouveau (unloaded: fbdev,vesa)
Resolution: 1280x1024@60.02hz
GLX Renderer: Gallium 0.4 on NVCF
GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio: Card-1 NVIDIA GF116 High Definition Audio Controller
driver: snd_hda_intel bus-ID: 02:00.1
Card-2 NVIDIA MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio
driver: snd_hda_intel bus-ID: 00:07.0
Card-3 Z-Star Micro Venus USB2.0 Camera
driver: USB Audio usb-ID: 002-003
Sound: Advanced Linux Sound Architecture v: k4.4.0-57-generic
Network: Card-1: NVIDIA MCP77 Ethernet
driver: forcedeth port: b880 bus-ID: 00:0a.0
IF: enp0s10 state: up speed: 100 Mbps duplex: full mac: <filter>
Card-2: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
driver: 8139too v: 0.9.28 port: d800 bus-ID: 01:0a.0
IF: enp1s10 state: down mac: <filter>
Drives: HDD Total Size: 320.1GB (4.2% used)
ID-1: /dev/sda model: ST3320418AS size: 320.1GB
Partition: ID-1: / size: 9.3G used: 6.1G (69%) fs: ext4 dev: /dev/sda1
ID-2: /home size: 35G used: 1.1G (4%) fs: ext4 dev: /dev/sda7
ID-3: swap-1 size: 6.14GB used: 0.00GB (0%) fs: swap dev: /dev/dm-0
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 28.5C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 206 Uptime: 1:58 Memory: 815.6/6064.3MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.461) inxi: 2.2.35


Unborn
Сообщения: 789
Зарегистрирован: 03 сен 2016, 10:36
Решено: 15
Благодарил (а): 2 раза
Поблагодарили: 119 раз

Базовая установка видеодрайвера в Linux Mint

Сообщение Unborn » 11 янв 2017, 19:05

skymasterbb, не нужна Минт 18.1, тяжко больно с таким железом. Ищи для своей мат. платы Core2 и 2х2 Гб планки, устанавливай 17.3 и проприетарные драйвера на видео.
Прощёлкал ты своевременный апгрейд. Печалька.
А со вторым то что? Не айс конечно, но уже лучше, чем первый.

Аватара пользователя

Автор темы
Chocobo
Сообщения: 5526
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1434 раза

Базовая установка видеодрайвера в Linux Mint

Сообщение Chocobo » 11 янв 2017, 19:20

skymasterbb, по первому хосту - чтоб не крутиться вокруг дров амд, версии 18+ брать явно не стоит. Ну и при таком камне, мультимедийная машинку все равно выйдет посредственная. Мать кстати, насколько я вижу поддерживает процы мощней. Еще планка на пару Гб оперативы и какой-нибудь Core2Duo - могут дать машинке вторую жизнь, с вложениями менее 50$. Ну а на том что есть - Rafaella/Rebecca/Rosa из минтов тут будут логичней, а с учетом ограниченных ресурсов я бы даже вкатил не минт а Debian 7 или Centos 6.

В чем проблема по второму компу? и 64 бита там бы жили уже обоснованно, без каких-либо явных видимых просадок

Аватара пользователя

PAVEL666
Сообщения: 78
Зарегистрирован: 05 сен 2016, 14:22
Благодарил (а): 18 раз
Поблагодарили: 5 раз

Базовая установка видеодрайвера в Linux Mint

Сообщение PAVEL666 » 12 янв 2017, 06:51

Так.После установки старых дров(340)всё нормально работает.Вывод:новые дровишки не всегда полезные(даже если пишут рекомендованные).Как то так.
Новый лох,лучше старых трёх!

Вернуться в «Видеокарты»