При запуске Libreoffice Calc происходит вылет компа

Офисные пакеты, текстовые и табличные процессоры и т.д.
Правила форума
Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа.

Автор темы
Torn
Сообщения: 6
Зарегистрирован: 11 дек 2016, 20:37
Благодарил (а): 2 раза

При запуске Libreoffice Calc происходит вылет компа

Сообщение Torn » 11 дек 2016, 20:46

Помогите пожалуйста.
Все программы Libreoficce работают. Calc не запускается. Начинает открываться, появляется рамка меню, после чего происходит сбой и вылет из системы: черный экран с надписью:
Linux Mint 17.3 Rose (имя пользователя)-G505 tty1
login:

После чего заново заходишь в систему. Удалять и переустанавливать пробовал. Ничего не помогает.

Система: Linux Mint 17.3 Rose 32 бит, офисс: Libreoffice 5.2.
Пробовал поставить Опеноффис - таже самая проблема и именно на Calk. переиодически, при работе в Writer происходит тоже самое, но в основном работает стабильно.
Подскажите, как решить?

Решение Chocobo » 11 дек 2016, 21:52
Ну исходя из этой инфы, как раз таки сегфолтятся иксы на свободном radeon-драйвере.

Можно попробовать два варианта решения проблемы:
1. Т.к. у нас тут 17.3 - есть смысл поставить видеодрайвер от производителя (проприетарный) - он будет предложен, если запустишь "Менеджер драйверов".
2. Можно попробовать поиграться с опциями Graphic output здесь
libre_graphics.png

Перейти к ответу ➙

Аватара пользователя

Chocobo
Сообщения: 5503
Зарегистрирован: 27 авг 2016, 19:57
Решено: 128
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1427 раз

Re: При запуске Libreoffice Calc происходит вылет компа

Сообщение Chocobo » 11 дек 2016, 21:09

Torn, привет.
вероятней всего, если отбивает на экран логина - это падение иксов.
стоит посмотреть содержимое /var/log/Xorg.0.log на предмет ошибок


Автор темы
Torn
Сообщения: 6
Зарегистрирован: 11 дек 2016, 20:37
Благодарил (а): 2 раза

Re: При запуске Libreoffice Calc происходит вылет компа

Сообщение Torn » 11 дек 2016, 21:23

Chocobo, привет. Спасибо, но будь уже другом - давай для совсем чайников))) Файл нашел. Как его посмотреть на предмет ошибок?

Аватара пользователя

Chocobo
Сообщения: 5503
Зарегистрирован: 27 авг 2016, 19:57
Решено: 128
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1427 раз

Re: При запуске Libreoffice Calc происходит вылет компа

Сообщение Chocobo » 11 дек 2016, 21:35

Torn, ну файл этот текстовый, так что открыть в любом редакторе. Только он сессионный (каждый раз новый), и до самой ошибки там может ничего и не проявится, а после начнет писаться новый.

Давай начнем с того, что узнаем с чем имеем дело, открывай терминал и пиши туда команды:
1. inxi -Fxz
2. cat /var/log/X* | grep EE

результаты каждой - сюда, будем смотреь :smile: .


Автор темы
Torn
Сообщения: 6
Зарегистрирован: 11 дек 2016, 20:37
Благодарил (а): 2 раза

Re: При запуске Libreoffice Calc происходит вылет компа

Сообщение Torn » 11 дек 2016, 21:40

1.
System: Host: volk-G505 Kernel: 3.19.0-32-generic i686 (32 bit gcc: 4.8.2)
Desktop: MATE 1.12.0 (Gtk 3.10.8~8+qiana)
Distro: Linux Mint 17.3 Rosa
Machine: System: LENOVO product: 20240 v: Lenovo G505
Mobo: LENOVO model: Lenovo G505 v: 00000000Not Defined
Bios: LENOVO v: 82CN15WW(V1.02) date: 05/15/2013
CPU: Quad core AMD A6-5200 APU with Radeon HD Graphics (-MCP-) cache: 8192 KB
flags: (lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 15971
clock speeds: max: 2000 MHz 1: 1200 MHz 2: 2000 MHz 3: 1000 MHz
4: 1000 MHz
Graphics: Card-1: Advanced Micro Devices [AMD/ATI] Kabini [Radeon HD 8400 / R3 Series]
bus-ID: 00:01.0
Card-2: Advanced Micro Devices [AMD/ATI] Sun PRO [Radeon HD 8570A/8570M]
bus-ID: 01:00.0
Display Server: X.Org 1.17.1 drivers: ati,radeon (unloaded: fbdev,vesa)
Resolution: 1366x768@60.0hz
GLX Renderer: Gallium 0.4 on AMD KABINI
GLX Version: 3.0 Mesa 10.5.9 Direct Rendering: Yes
Audio: Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
driver: snd_hda_intel bus-ID: 00:14.2
Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio
driver: snd_hda_intel bus-ID: 00:01.1
Sound: Advanced Linux Sound Architecture v: k3.19.0-32-generic
Network: Card-1: Qualcomm Atheros QCA8172 Fast Ethernet
driver: alx port: 2000 bus-ID: 02:00.0
IF: eth0 state: down mac: <filter>
Card-2: Qualcomm Atheros AR9485 Wireless Network Adapter
driver: ath9k bus-ID: 03:00.0
IF: wlan0 state: up mac: <filter>
Drives: HDD Total Size: 1000.2GB (48.6% used)
ID-1: /dev/sda model: WDC_WD10JPVT size: 1000.2GB
Partition: ID-1: / size: 11G used: 6.4G (62%) fs: ext4 dev: /dev/sda7
ID-2: /home size: 40G used: 9.0G (24%) fs: ext4 dev: /dev/sda8
ID-3: swap-1 size: 2.05GB used: 0.02GB (1%) fs: swap dev: /dev/sda6
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 55.9C mobo: N/A gpu: 56.0,N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 218 Uptime: 2:43 Memory: 1981.9/3480.9MB
Init: Upstart runlevel: 2 Gcc sys: 4.8.4
Client: Shell (bash 4.3.111) inxi: 2.2.28
2.
WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 9530.659] (EE) Failed to load module "fglrx" (module does not exist, 0)
[ 9530.662] (EE) Failed to load module "fglrx" (module does not exist, 0)
[ 9530.867] (EE) RADEON(G0): [XvMC] Failed to initialize extension.
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 9467.233] (EE) Failed to load module "fglrx" (module does not exist, 0)
[ 9467.236] (EE) Failed to load module "fglrx" (module does not exist, 0)
[ 9467.436] (EE) RADEON(G0): [XvMC] Failed to initialize extension.
[ 9529.172] (EE)
[ 9529.172] (EE) Backtrace:
[ 9529.173] (EE) 0: /usr/bin/X (xorg_backtrace+0x4f) [0xb76edc1f]
[ 9529.173] (EE) 1: /usr/bin/X (0xb754c000+0x1a5de4) [0xb76f1de4]
[ 9529.173] (EE) 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb7528c98]
[ 9529.173] (EE) 3: /usr/lib/xorg/modules/libfb.so (fbBltOne+0x4d3) [0xb37cd6f3]
[ 9529.173] (EE) 4: /usr/lib/xorg/modules/libfb.so (fbCopy1toN+0x270) [0xb37ce330]
[ 9529.173] (EE) 5: /usr/lib/xorg/modules/libglamoregl.so (0xb6bce000+0x875d) [0xb6bd675d]
[ 9529.173] (EE) 6: /usr/bin/X (miCopyRegion+0x1b8) [0xb76cd0d8]
[ 9529.173] (EE) 7: /usr/bin/X (miDoCopy+0x510) [0xb76cd6f0]
[ 9529.173] (EE) 8: /usr/lib/xorg/modules/libglamoregl.so (0xb6bce000+0x9c92) [0xb6bd7c92]
[ 9529.173] (EE) 9: /usr/bin/X (0xb754c000+0x127e3b) [0xb7673e3b]
[ 9529.173] (EE) 10: /usr/bin/X (0xb754c000+0x39071) [0xb7585071]
[ 9529.173] (EE) 11: /usr/bin/X (0xb754c000+0x3d1bd) [0xb75891bd]
[ 9529.174] (EE) 12: /usr/bin/X (0xb754c000+0x412e5) [0xb758d2e5]
[ 9529.174] (EE) 13: /usr/bin/X (0xb754c000+0x2af7e) [0xb7576f7e]
[ 9529.174] (EE) 14: /lib/i386-linux-gnu/libc.so.6 (__libc_start_main+0xf3) [0xb718baf3]
[ 9529.174] (EE) 15: /usr/bin/X (0xb754c000+0x2afb4) [0xb7576fb4]
[ 9529.174] (EE)
[ 9529.174] (EE) Segmentation fault at address 0x151c
[ 9529.174] (EE)
[ 9529.174] (EE) Caught signal 11 (Segmentation fault). Server aborting
[ 9529.174] (EE)
[ 9529.174] (EE)
[ 9529.174] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 9529.174] (EE)
[ 9529.188] (EE) Server terminated with error (1). Closing log file.
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 182.690] (EE) Failed to load module "fglrx" (module does not exist, 0)
[ 182.692] (EE) Failed to load module "fglrx" (module does not exist, 0)
[ 183.377] (EE) RADEON(G0): [XvMC] Failed to initialize extension.

Аватара пользователя

Chocobo
Сообщения: 5503
Зарегистрирован: 27 авг 2016, 19:57
Решено: 128
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1427 раз

Re: При запуске Libreoffice Calc происходит вылет компа

Сообщение Chocobo » 11 дек 2016, 21:52

Ну исходя из этой инфы, как раз таки сегфолтятся иксы на свободном radeon-драйвере.

Можно попробовать два варианта решения проблемы:
1. Т.к. у нас тут 17.3 - есть смысл поставить видеодрайвер от производителя (проприетарный) - он будет предложен, если запустишь "Менеджер драйверов".
2. Можно попробовать поиграться с опциями Graphic output здесь
libre_graphics.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.


Автор темы
Torn
Сообщения: 6
Зарегистрирован: 11 дек 2016, 20:37
Благодарил (а): 2 раза

Re: При запуске Libreoffice Calc происходит вылет компа

Сообщение Torn » 11 дек 2016, 22:35

Chocobo, поставил драйвер, тот который updates. Все работает как надо, вылетов, по крайней мере пока - никаких нет.
Огромное тебе человеческое спасибо!

Вернуться в «Офис и документы»