Не могу установить старое ядро

О том о сем
Аватара пользователя

Автор темы
BadBird
Сообщения: 1326
Зарегистрирован: 09 сен 2016, 18:08
Решено: 2
Благодарил (а): 63 раза
Поблагодарили: 116 раз

Не могу установить старое ядро

Сообщение BadBird » 27 апр 2017, 07:21

Сейчас стоит 4.8
Иду сюда: http://kernel.ubuntu.com/~kernel-ppa/mainline/ и скачиваю к примеру 3.19
С помощью gdebi ставлю ядро и gdebi говорит что ядро установлено.
Обновляю груб: sudo update-grub
Но когда я во время старта ос захожу в список ядер что бы переключиться на старое ядро, то его там не бывает.
Как правильно установить старое ядро?
Нужно все это для того что бы проверить, может нормально будет клавиатура работать со старыми ядрами...
Всё о тайлинге окон...ну, или почти всё: Тыц!!!

Аватара пользователя

Chocobo
Сообщения: 5503
Зарегистрирован: 27 авг 2016, 19:57
Решено: 128
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1427 раз

Не могу установить старое ядро

Сообщение Chocobo » 27 апр 2017, 07:34

BadBird, Какие пакеты стягиваешь?
Бери linux-image***, linux-headers***, и linux-headers***-all

да и апдейт граба при вызове сам покажет какие пункты нашел и внес в меню

Код: Выделить всё

Generating grub configuration file ...
Найден образ linux: /boot/vmlinuz-4.9.0-0.bpo.2-amd64
Найден образ initrd: /boot/initrd.img-4.9.0-0.bpo.2-amd64
Найден образ linux: /boot/vmlinuz-3.16.0-4-amd64
Найден образ initrd: /boot/initrd.img-3.16.0-4-amd64
Found memtest86+ image: /boot/memtest86+.bin
Found memtest86+ multiboot image: /boot/memtest86+_multiboot.bin
  No volume groups found
завершено

Аватара пользователя

symon2014
Сообщения: 1578
Зарегистрирован: 29 авг 2016, 02:17
Решено: 19
Откуда: Феодосия
Благодарил (а): 47 раз
Поблагодарили: 427 раз

Не могу установить старое ядро

Сообщение symon2014 » 27 апр 2017, 07:35

Попробуй ukuu
:sry:
Debian (9.1) , LMDE2 , LM 18.2 Mate . Благодарности складываем сюда ---> R320161344462

Аватара пользователя

Chocobo
Сообщения: 5503
Зарегистрирован: 27 авг 2016, 19:57
Решено: 128
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1427 раз

Не могу установить старое ядро

Сообщение Chocobo » 27 апр 2017, 07:37

symon2014, ну или да, тоже верно) Для ленивых :smile:
прада оно мне уведомлениями надоедало потом своими

Аватара пользователя

Автор темы
BadBird
Сообщения: 1326
Зарегистрирован: 09 сен 2016, 18:08
Решено: 2
Благодарил (а): 63 раза
Поблагодарили: 116 раз

Не могу установить старое ядро

Сообщение BadBird » 27 апр 2017, 08:06

symon2014 писал(а): Попробуй ukuu
Пробовал устанавливать 3.19 и 4.0, но не ставятся, пишут что ядро установилось с ошибками...
Всё о тайлинге окон...ну, или почти всё: Тыц!!!

Аватара пользователя

symon2014
Сообщения: 1578
Зарегистрирован: 29 авг 2016, 02:17
Решено: 19
Откуда: Феодосия
Благодарил (а): 47 раз
Поблагодарили: 427 раз

Не могу установить старое ядро

Сообщение symon2014 » 27 апр 2017, 08:19

BadBird, А минт какой, по идее с установкой на 18 будут проблемы. Может я и не прав, но кажись тапки назад плохо ходят. Т.Е. на 17 проще установить четвёртые ядра, чем на 18 третьи (имхо).
:sry:
Debian (9.1) , LMDE2 , LM 18.2 Mate . Благодарности складываем сюда ---> R320161344462

Аватара пользователя

Автор темы
BadBird
Сообщения: 1326
Зарегистрирован: 09 сен 2016, 18:08
Решено: 2
Благодарил (а): 63 раза
Поблагодарили: 116 раз

Не могу установить старое ядро

Сообщение BadBird » 27 апр 2017, 08:28

symon2014, удалось установить 3.16 но клава не заработала.
Буду перебирать пока не надоест )))
За утилиту, спасибо!!!
Всё о тайлинге окон...ну, или почти всё: Тыц!!!

Аватара пользователя

PAVEL666
Сообщения: 78
Зарегистрирован: 05 сен 2016, 14:22
Благодарил (а): 18 раз
Поблагодарили: 5 раз

Не могу установить старое ядро

Сообщение PAVEL666 » 27 апр 2017, 10:09

ukuu можно отладить на показ уведомлений раз в день,а вот ядра старые она не ставит.
Новый лох,лучше старых трёх!

Аватара пользователя

Автор темы
BadBird
Сообщения: 1326
Зарегистрирован: 09 сен 2016, 18:08
Решено: 2
Благодарил (а): 63 раза
Поблагодарили: 116 раз

Не могу установить старое ядро

Сообщение BadBird » 27 апр 2017, 10:16

PAVEL666 писал(а): а вот ядра старые она не ставит.
Ставит, и новые и старые ставит.
Проверил работу клавиатуры на 3.0.0-0300, 3.1.0-030100, 3.15.10-031510, 3.2.0-030200, 3.3.0-030300 устанавливая их с помощью данной утилиты, но пока что клава не работает, хотя во всем остальном ядра работают....
Это пост например я пишу с ядра 3.3 ожидая установки 3.4.
Всё о тайлинге окон...ну, или почти всё: Тыц!!!

Аватара пользователя

PAVEL666
Сообщения: 78
Зарегистрирован: 05 сен 2016, 14:22
Благодарил (а): 18 раз
Поблагодарили: 5 раз

Не могу установить старое ядро

Сообщение PAVEL666 » 27 апр 2017, 10:26

Извиняйте,не правильно написал.Не переводит на ниже установленное.Надо ручками.
Новый лох,лучше старых трёх!

Аватара пользователя

Автор темы
BadBird
Сообщения: 1326
Зарегистрирован: 09 сен 2016, 18:08
Решено: 2
Благодарил (а): 63 раза
Поблагодарили: 116 раз

Не могу установить старое ядро

Сообщение BadBird » 27 апр 2017, 10:29

PAVEL666 писал(а): Извиняйте,не правильно написал.
Ничего, бывает.
PAVEL666 писал(а): Не переводит на ниже установленное.Надо ручками.
Это да, есть такое.
Всё о тайлинге окон...ну, или почти всё: Тыц!!!

Аватара пользователя

Chocobo
Сообщения: 5503
Зарегистрирован: 27 авг 2016, 19:57
Решено: 128
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1427 раз

Не могу установить старое ядро

Сообщение Chocobo » 27 апр 2017, 10:55

Тоже решил немножко побаловаться со старыми ядрами :-D
Снимок экрана в 2017-04-27 13-52-35.png
Работает, зараза :crazy:
в dmesg ничего страшного
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Аватара пользователя

Автор темы
BadBird
Сообщения: 1326
Зарегистрирован: 09 сен 2016, 18:08
Решено: 2
Благодарил (а): 63 раза
Поблагодарили: 116 раз

Не могу установить старое ядро

Сообщение BadBird » 27 апр 2017, 11:23

Chocobo писал(а): Работает, зараза
Я с 3.0 начал, поднимусь до 4.1 и тоже начну с низов )))
Всё о тайлинге окон...ну, или почти всё: Тыц!!!

Аватара пользователя

Chocobo
Сообщения: 5503
Зарегистрирован: 27 авг 2016, 19:57
Решено: 128
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1427 раз

Не могу установить старое ядро

Сообщение Chocobo » 27 апр 2017, 11:32

BadBird, только ukuu тут вряд ли поможет
я брал к своей бести с http://snapshot.debian.org/
Пришлось подтянуть следующее.

Код: Выделить всё

cpp-4.4_4.4.7-8_amd64.deb
gcc-4.4_4.4.7-8_amd64.deb
gcc-4.4-base_4.4.7-8_amd64.deb
linux-headers-2.6.39-2-all-amd64_2.6.39-3_amd64.deb
linux-headers-2.6.39-2-amd64_2.6.39-3_amd64.deb
linux-headers-2.6.39-2-common_2.6.39-3_amd64.deb
linux-image-2.6.39-2-amd64_2.6.39-3_amd64.deb
linux-kbuild-2.6.39_2.6.39-1_amd64.deb
И стартует только с sysVinit, системда ему не нравится :smile:
Такой вот бутчарт получился
bootchart.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Аватара пользователя

Автор темы
BadBird
Сообщения: 1326
Зарегистрирован: 09 сен 2016, 18:08
Решено: 2
Благодарил (а): 63 раза
Поблагодарили: 116 раз

Не могу установить старое ядро

Сообщение BadBird » 27 апр 2017, 11:52

Chocobo писал(а): только ukuu тут вряд ли поможет
Ну ничего себе...дебиан он и в африке дебиан, и как всегда в своем репертуаре...то цвет носков пользователя пк ему не нравятся, то погода за окном не та...
Всё о тайлинге окон...ну, или почти всё: Тыц!!!

Вернуться в «Болталка: Оффтоп, разбор полетов»