Как сделать так,чтобы .sh файлы запускались,а не открывались в xed-e?

Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот
Аватара пользователя

Автор темы
Vagrant
Сообщения: 39
Зарегистрирован: 09 ноя 2016, 06:31
Благодарил (а): 5 раз
Поблагодарили: 3 раза

Как сделать так,чтобы .sh файлы запускались,а не открывались в xed-e?

Сообщение Vagrant » 10 май 2017, 15:29

Собсна,такая вот беда.
В настройках ничего не нашел.
Все "права" выставлены как надо.

Решение Chocobo » 13 май 2017, 10:53
Vagrant писал(а): Нету там Thunara-a..
ага, крыса не использует dconf это из гномья, в xfce своя штука - xfconf

И чтоб по умолчанию Thunar'у назначить исполнение скрипта - надо дать такую директиву

Код: Выделить всё

xfconf-query --channel thunar --property /misc-exec-shell-scripts-by-default --create --type bool --set true
Сейчас проверил у себя - все работает
2017-05-13-135137_1920x1080_scrot.png
Один момент, val прав. Аккуратней с такими разрешениями)

Перейти к ответу ➙


symon2014

Как сделать так,чтобы .sh файлы запускались,а не открывались в xed-e?

Сообщение symon2014 » 10 май 2017, 15:34

Vagrant писал(а): Собсна,такая вот беда.
Собсна, посмотреть бы, чё и как ты запускаешь.
http://www.linuxrussia.com/sh-ubuntu.html

Аватара пользователя

Автор темы
Vagrant
Сообщения: 39
Зарегистрирован: 09 ноя 2016, 06:31
Благодарил (а): 5 раз
Поблагодарили: 3 раза

Как сделать так,чтобы .sh файлы запускались,а не открывались в xed-e?

Сообщение Vagrant » 10 май 2017, 16:28

symon2014 писал(а): Собсна, посмотреть бы, чё и как ты запускаешь.
Собсна,обычная цяцька.
В папке с игрой имеется скрипт,ну,к примеру, start.sh,при двойном клике на котором открывается текстовый редактор.
В Mint-e c Cinnamon-ом,никогда такой траблы не было,да и в других дистрах не припомню такого.

Аватара пользователя

di_mok
Сообщения: 4710
Зарегистрирован: 27 авг 2016, 16:06
Решено: 29
Откуда: Арзамас
Благодарил (а): 1134 раза
Поблагодарили: 937 раз

Как сделать так,чтобы .sh файлы запускались,а не открывались в xed-e?

Сообщение di_mok » 10 май 2017, 16:41

Код: Выделить всё

chmod +x start.sh
Настоящая водка — это не пьянство, а ключ к своей совести, с нее-то и начинается настоящая мудрость. (c)
Изображение
Изображение

Аватара пользователя

Автор темы
Vagrant
Сообщения: 39
Зарегистрирован: 09 ноя 2016, 06:31
Благодарил (а): 5 раз
Поблагодарили: 3 раза

Как сделать так,чтобы .sh файлы запускались,а не открывались в xed-e?

Сообщение Vagrant » 10 май 2017, 18:12

di_mok писал(а):chmod +x start.sh
А это разве не то же самое,что поставить галку "Разрешить запуск этого файла в качестве программы"?

Аватара пользователя

di_mok
Сообщения: 4710
Зарегистрирован: 27 авг 2016, 16:06
Решено: 29
Откуда: Арзамас
Благодарил (а): 1134 раза
Поблагодарили: 937 раз

Как сделать так,чтобы .sh файлы запускались,а не открывались в xed-e?

Сообщение di_mok » 10 май 2017, 18:16

Да
Настоящая водка — это не пьянство, а ключ к своей совести, с нее-то и начинается настоящая мудрость. (c)
Изображение
Изображение

Аватара пользователя

val
Сообщения: 49
Зарегистрирован: 02 сен 2016, 22:17
Решено: 2
Поблагодарили: 11 раз

Как сделать так,чтобы .sh файлы запускались,а не открывались в xed-e?

Сообщение val » 10 май 2017, 18:37

[img] но лучше выбрать №каждый раз спрашивать" а то знаете sh файлы бывают разные
У вас нет необходимых прав для просмотра вложений в этом сообщении.
В чем Сила Брат?!А Сила,она во Сне! :smoke:


avkP3

Как сделать так,чтобы .sh файлы запускались,а не открывались в xed-e?

Сообщение avkP3 » 10 май 2017, 21:28

Vagrant писал(а): Собсна,такая вот беда.
В настройках ничего не нашел.
Все "права" выставлены как надо.

Код: Выделить всё

sudo apt-get install dconf-editor

Аватара пользователя

semiconductor
Сообщения: 38
Зарегистрирован: 20 сен 2016, 06:07
Благодарил (а): 1 раз
Поблагодарили: 1 раз

Как сделать так,чтобы .sh файлы запускались,а не открывались в xed-e?

Сообщение semiconductor » 10 май 2017, 22:33

Не проще ли шелл-скрипт в терминале запустить?

Аватара пользователя

Dja
Сообщения: 4988
Зарегистрирован: 27 авг 2016, 17:03
Решено: 17
Откуда: Voskresensk
Благодарил (а): 673 раза
Поблагодарили: 521 раз

Как сделать так,чтобы .sh файлы запускались,а не открывались в xed-e?

Сообщение Dja » 11 май 2017, 08:24

./name_script.sh &

Аватара пользователя

Автор темы
Vagrant
Сообщения: 39
Зарегистрирован: 09 ноя 2016, 06:31
Благодарил (а): 5 раз
Поблагодарили: 3 раза

Как сделать так,чтобы .sh файлы запускались,а не открывались в xed-e?

Сообщение Vagrant » 12 май 2017, 19:23

Мдэ.."Дело ясное,что дело темное".
Снова вернулся на Cinnamon.
Извините,что отнял ваше время..

зы Темку можно удалить,проблемка,видимо,только у меня.


avkP3

Как сделать так,чтобы .sh файлы запускались,а не открывались в xed-e?

Сообщение avkP3 » 12 май 2017, 20:54

Vagrant писал(а): Как сделать так,чтобы .sh файлы запускались,а не открывались в xed-e?
Мдэ.."Дело ясное,что дело темное".
Снова вернулся на Cinnamon.
Зря вы это сделали... :sad:

Код: Выделить всё

sudo apt-get install dconf-editor
Я же вам привёл пример

Только нужно было вам найти следующее:
Так, как в Xfce файловым менеджером является Thunar,
нужно было найти вот это:
org => thunar => preferences или подобное.
Точно не могу сказать, у меня в Ubuntu установлен Nemo.

Аватара пользователя

Автор темы
Vagrant
Сообщения: 39
Зарегистрирован: 09 ноя 2016, 06:31
Благодарил (а): 5 раз
Поблагодарили: 3 раза

Как сделать так,чтобы .sh файлы запускались,а не открывались в xed-e?

Сообщение Vagrant » 13 май 2017, 09:30

Зря вы это сделали...
Зря вернулся на окружении в котором у меня не возникает проблем?
нужно было найти вот это:
org => thunar => preferences или подобное.
Нету там Thunara-a..

Аватара пользователя

Chocobo
Сообщения: 8876
Зарегистрирован: 27 авг 2016, 19:57
Решено: 195
Откуда: НН
Благодарил (а): 608 раз
Поблагодарили: 2475 раз

Как сделать так,чтобы .sh файлы запускались,а не открывались в xed-e?

Сообщение Chocobo » 13 май 2017, 10:53

Vagrant писал(а): Нету там Thunara-a..
ага, крыса не использует dconf это из гномья, в xfce своя штука - xfconf

И чтоб по умолчанию Thunar'у назначить исполнение скрипта - надо дать такую директиву

Код: Выделить всё

xfconf-query --channel thunar --property /misc-exec-shell-scripts-by-default --create --type bool --set true
Сейчас проверил у себя - все работает
2017-05-13-135137_1920x1080_scrot.png
Один момент, val прав. Аккуратней с такими разрешениями)
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Изображение
   
Изображение

Аватара пользователя

Автор темы
Vagrant
Сообщения: 39
Зарегистрирован: 09 ноя 2016, 06:31
Благодарил (а): 5 раз
Поблагодарили: 3 раза

Как сделать так,чтобы .sh файлы запускались,а не открывались в xed-e?

Сообщение Vagrant » 13 май 2017, 18:07

надо дать такую директиву
Угу.Получилось.Теперь стартует автоматом.
В настройках появилась вот такая строка:
08.jpg
А нет какого-нибудь простого способа включить эту фишку?
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Аватара пользователя

Chocobo
Сообщения: 8876
Зарегистрирован: 27 авг 2016, 19:57
Решено: 195
Откуда: НН
Благодарил (а): 608 раз
Поблагодарили: 2475 раз

Как сделать так,чтобы .sh файлы запускались,а не открывались в xed-e?

Сообщение Chocobo » 13 май 2017, 18:12

Vagrant, если тут же в графической оснастке - можно самостоятельно завести этот ключ с нужным именем, типом и значением. А галки в конфиге на эту тему вроде как еще не завезли, может найдем в 4.14, кто знает :smile:
Так что пока держи в памяти эту фишку :secret:
Изображение
   
Изображение

Вернуться в «Xfce»