Проблема с графическим планшетом Ugee M708

погружаемся в мир звука, графики и видео
Правила форума
Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа.

Автор темы
Aleksey
Сообщения: 11
Зарегистрирован: 23 июн 2017, 14:45
Благодарил (а): 1 раз

Проблема с графическим планшетом Ugee M708

Сообщение Aleksey » 23 июн 2017, 14:52

Linux Mint Cinnamon 18 не видит графический планшет Ugee M708. На офф сайте Ugee нет драйверов под Linux. Подскажите пожалуйста как решить проблему

Аватара пользователя

Bill Williamson
Сообщения: 463
Зарегистрирован: 31 авг 2016, 10:38
Решено: 18
Благодарил (а): 172 раза
Поблагодарили: 97 раз

Проблема с графическим планшетом Ugee M708

Сообщение Bill Williamson » 23 июн 2017, 16:08

Тут у одного товарища все работает и еще тут посмотрите.


Автор темы
Aleksey
Сообщения: 11
Зарегистрирован: 23 июн 2017, 14:45
Благодарил (а): 1 раз

Проблема с графическим планшетом Ugee M708

Сообщение Aleksey » 25 июн 2017, 14:59

Спасибо Вам большое за ответ! Но я только начинаю "общаться" с Линуксом. Я скачал драйвера ядра ( по 2-ой ссылке которую Вы мне указали), а как установить эти драйвера я не понял. Если Вам не трудно подскажите как это сделать. Буду Вам премного благодарен.

В сети
Аватара пользователя

Chocobo
Сообщения: 5544
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1437 раз

Проблема с графическим планшетом Ugee M708

Сообщение Chocobo » 25 июн 2017, 15:26

Aleksey, Драйвера они похоже распространяют в форме дебпакета по той ссылке.
тут есть digimend-dkms_6_all.deb, его можно установить даблкдиком по скачанному файлу, зависимости вроде все в норме.


Автор темы
Aleksey
Сообщения: 11
Зарегистрирован: 23 июн 2017, 14:45
Благодарил (а): 1 раз

Проблема с графическим планшетом Ugee M708

Сообщение Aleksey » 25 июн 2017, 15:57

Спасибо! Сделал как вы написали, что-то установилось, но Linux планшет так и не видит. У меня стоит Linux Mint Cinnamon 18. Может я что-то не так делаю? Делал как написано по ссылке. Спасибо за ваше понимание.

В сети
Аватара пользователя

Chocobo
Сообщения: 5544
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1437 раз

Проблема с графическим планшетом Ugee M708

Сообщение Chocobo » 25 июн 2017, 16:01

Aleksey, для начала, после установки стоит перезагрузить систему чтоб udev смог подцепить устройство согласно новых правил.

Потом покажите сюда lsusb еще


Автор темы
Aleksey
Сообщения: 11
Зарегистрирован: 23 июн 2017, 14:45
Благодарил (а): 1 раз

Проблема с графическим планшетом Ugee M708

Сообщение Aleksey » 26 июн 2017, 14:50

После перезагрузки Linux перестал видеть планшет даже как мышь.


Автор темы
Aleksey
Сообщения: 11
Зарегистрирован: 23 июн 2017, 14:45
Благодарил (а): 1 раз

Проблема с графическим планшетом Ugee M708

Сообщение Aleksey » 26 июн 2017, 14:54

После ввода команды lsusb выяснил, что планшет определяется как UC-Logic Technology Corp.


Автор темы
Aleksey
Сообщения: 11
Зарегистрирован: 23 июн 2017, 14:45
Благодарил (а): 1 раз

Проблема с графическим планшетом Ugee M708

Сообщение Aleksey » 27 июн 2017, 13:49

Только это проблему не решило. Linux так и не видит планшета.

В сети
Аватара пользователя

Chocobo
Сообщения: 5544
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1437 раз

Проблема с графическим планшетом Ugee M708

Сообщение Chocobo » 27 июн 2017, 13:54

Chocobo писал(а): Потом покажите сюда lsusb еще
Вроде прямым текстом запрашиваю что требуется, в каждой теме :smile:
и вдобавок usb-devices еще, глянем что за модуль его цепляет.


Автор темы
Aleksey
Сообщения: 11
Зарегистрирован: 23 июн 2017, 14:45
Благодарил (а): 1 раз

Проблема с графическим планшетом Ugee M708

Сообщение Aleksey » 27 июн 2017, 14:25

Похоже это:
T:  Bus=06 Lev=01 Prnt=01 Port=01 Cnt=02 Dev#=  3 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=5543 ProdID=0081 Rev=00.00
S:  Manufacturer=UC-LOIC
S:  Product=TABLET 1060
C:  #Ifs= 3 Cfg#= 1 Atr=a0 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=02 Driver=usbhid
I:  If#= 1 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=02 Driver=usbhid
I:  If#= 2 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=00 Prot=00 Driver=usbhid
Последний раз редактировалось пользователем 1 Dja; всего редактировалось раз: 16
Причина: spoil


Автор темы
Aleksey
Сообщения: 11
Зарегистрирован: 23 июн 2017, 14:45
Благодарил (а): 1 раз

Проблема с графическим планшетом Ugee M708

Сообщение Aleksey » 28 июн 2017, 06:46

lsusb:
Bus 006 Device 016: ID 5543:0081 UC-Logic Technology Corp.

В сети
Аватара пользователя

Chocobo
Сообщения: 5544
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1437 раз

Проблема с графическим планшетом Ugee M708

Сообщение Chocobo » 28 июн 2017, 06:58

Aleksey, покажи еще
apt policy linux-headers-$(uname -r)

lsmod | grep hid

Также попробуй отключить девайс от usb, сделать sudo modprobe hid-uclogic и затем подключить его обратно.
и посмотреть сменился ли на что-то usbhid в выхлопах выше


Он пока цепляется дефолтным usbhid как обычные клавомыши. а должны быть еще hid-uclogic hid-kye hid-huion.
Либо их нет, и дровина стоит некорректно (тогда ругнется на этапе modprobe), либо udev утаскивает не на тот драйвер, возможно правилами по ID


Автор темы
Aleksey
Сообщения: 11
Зарегистрирован: 23 июн 2017, 14:45
Благодарил (а): 1 раз

Проблема с графическим планшетом Ugee M708

Сообщение Aleksey » 28 июн 2017, 07:26

apt policy linux-headers-$(uname -r):
linux-headers-4.4.0-53-generic:
  Установлен: 4.4.0-53.74
  Кандидат:   4.4.0-53.74
  Таблица версий:
 *** 4.4.0-53.74 500
        500 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
        100 /var/lib/dpkg/status

lsmod | grep hid:
hid_uclogic            16384  0
mac_hid                16384  0
hid_generic            16384  0
usbhid                 49152  0
hid                   118784  3 hid_generic,hid_uclogic,usbhid

sudo modprobe hid-uclogic:
Ничего не произошло. После подключения планшета никаких изменений
Последний раз редактировалось пользователем 1 Dja; всего редактировалось раз: 16
Причина: spoil

В сети
Аватара пользователя

Chocobo
Сообщения: 5544
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1437 раз

Проблема с графическим планшетом Ugee M708

Сообщение Chocobo » 28 июн 2017, 07:53

тогда надо смотреть в выхлоп dmesg - где инициируется эта железка. Может что прояснит.
У меня пока нет идей что ему не так, на сайте с дровами ничего специфичного не указано про их взлет.


Unborn
Сообщения: 792
Зарегистрирован: 03 сен 2016, 10:36
Решено: 15
Благодарил (а): 2 раза
Поблагодарили: 120 раз

Проблема с графическим планшетом Ugee M708

Сообщение Unborn » 28 июн 2017, 08:10

Aleksey, после всей движухи с установкой пробовал выключить машину и включить, а не перезагружать с подключенным планшетом?
И к какой машине он подключен и в какой порт юсб? И Минт установлен в УЕФИ, эмуляции БИОС или БИОС?
Chocobo, может правило юдев руками написать придётся?

В сети
Аватара пользователя

Chocobo
Сообщения: 5544
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1437 раз

Проблема с графическим планшетом Ugee M708

Сообщение Chocobo » 28 июн 2017, 08:17

Unborn, В пакете насколько вижу вот что есть в /lib/udev/rules.d/90-hid-rebind.rules

Код: Выделить всё

SUBSYSTEM=="hid", ACTION=="add", ENV{HID_ID}=="0003:0000099A:00002620", \
	RUN+="/sbin/hid-rebind"
SUBSYSTEM=="hid", ACTION=="add", ENV{HID_ID}=="0003:0000256C:0000006E", \
	RUN+="/sbin/hid-rebind"
SUBSYSTEM=="hid", ACTION=="add", ENV{HID_ID}=="0003:00005543:*", \
	RUN+="/sbin/hid-rebind"
SUBSYSTEM=="hid", ACTION=="add", ENV{HID_ID}=="0003:00000458:*", \
	RUN+="/sbin/hid-rebind"
SUBSYSTEM=="hid", ACTION=="add", ENV{HID_ID}=="0003:00002179:00000053", \
	RUN+="/sbin/hid-rebind"
Надо тогда смотреть совпадает ли железяка этим айдишникам :hm:


Автор темы
Aleksey
Сообщения: 11
Зарегистрирован: 23 июн 2017, 14:45
Благодарил (а): 1 раз

Проблема с графическим планшетом Ugee M708

Сообщение Aleksey » 29 июн 2017, 04:55

Пробовал и перезагружать и выключать, не помогает. Минт установлен на Биос. AMD A10-6800K, 8Gb, GeForce GT 740.


Unborn
Сообщения: 792
Зарегистрирован: 03 сен 2016, 10:36
Решено: 15
Благодарил (а): 2 раза
Поблагодарили: 120 раз

Проблема с графическим планшетом Ugee M708

Сообщение Unborn » 29 июн 2017, 07:01

Aleksey, не в юсб3 подключаешь? Ну и когда воткнёшь - в Терминале - dmesg - смотри что выдало последние строки - [......] usb .....


Автор темы
Aleksey
Сообщения: 11
Зарегистрирован: 23 июн 2017, 14:45
Благодарил (а): 1 раз

Проблема с графическим планшетом Ugee M708

Сообщение Aleksey » 29 июн 2017, 07:25

Я так полагаю, что с планшетом связаны эти строки:
[    1.870477] usb 6-2: new full-speed USB device number 3 using xhci_hcd
[    1.935873]  sda: sda1 sda2 sda3 sda4 < sda5 sda6 >
[    1.936471] sd 3:0:0:0: [sda] Attached SCSI disk
[    2.016685] usb 6-2: New USB device found, idVendor=5543, idProduct=0081
[    2.016688] usb 6-2: New USB device strings: Mfr=5, Product=6, SerialNumber=0
[    2.016690] usb 6-2: Product: TABLET 1060
[    2.016691] usb 6-2: Manufacturer: UC-LOIC
[    2.026247] input: UC-LOIC TABLET 1060 as /devices/pci0000:00/0000:00:10.0/usb6/6-2/6-2:1.0/0003:5543:0081.0003/input/input6
[    2.026403] hid-generic 0003:5543:0081.0003: input,hidraw2: USB HID v1.11 Mouse [UC-LOIC TABLET 1060] on usb-0000:00:10.0-2/input0
[    2.033147] input: UC-LOIC TABLET 1060 as /devices/pci0000:00/0000:00:10.0/usb6/6-2/6-2:1.1/0003:5543:0081.0004/input/input7
[    2.033317] hid-generic 0003:5543:0081.0004: input,hiddev0,hidraw3: USB HID v1.11 Mouse [UC-LOIC TABLET 1060] on usb-0000:00:10.0-2/input1
[    2.044913] input: UC-LOIC TABLET 1060 as /devices/pci0000:00/0000:00:10.0/usb6/6-2/6-2:1.2/0003:5543:0081.0005/input/input8
[    2.050472] tsc: Refined TSC clocksource calibration: 4092.352 MHz
[    2.050476] clocksource: tsc: mask: 0xffffffffffffffff max_cycles: 0x3afd2687fcc, max_idle_ns: 440795334907 ns
[    2.098716] hid-generic 0003:5543:0081.0005: input,hidraw4: USB HID v1.11 Keyboard [UC-LOIC TABLET 1060] on usb-0000:00:10.0-2/input2
[    2.543502] scsi 6:0:0:0: Direct-Access     Generic  USB SD Reader    1.00 PQ: 0 ANSI: 0
[    2.544055] scsi 6:0:0:1: Direct-Access     Generic  USB CF Reader    1.01 PQ: 0 ANSI: 0
[    2.544745] scsi 6:0:0:2: Direct-Access     Generic  USB SM Reader    1.02 PQ: 0 ANSI: 0
[    2.545359] scsi 6:0:0:3: Direct-Access     Generic  USB MS Reader    1.03 PQ: 0 ANSI: 0
Последний раз редактировалось пользователем 1 Dja; всего редактировалось раз: 16
Причина: spoil

Вернуться в «Мультимедиа»