Установка Retropie в LMDE2

Аватара пользователя

Автор темы
wanoska
Сообщения: 164
Зарегистрирован: 17 окт 2016, 12:36
Решено: 4
Откуда: Кинешма
Благодарил (а): 31 раз
Поблагодарили: 41 раз

Установка Retropie в LMDE2

Сообщение wanoska » 06 июл 2017, 16:20

Всем привет, возникла хотелка поставить Retropie https://retropie.org.uk/docs/RetroPie-U ... l-retropie, но при запуске скрипта ./retropie_setup.sh он говорит хочу mint выше 17, проверка прописана в criptmodules/system.sh но как ее поменять что бы и lmde2 кушал? вот архив
RetroPie-Setup-master.zip

Решение wanoska » 06 июл 2017, 17:17
цитата с оф сайта, надо блин документацию до конца читать Ваньке :-D
Section 3.12: SteamOS hack to allow installation

While SteamOS is not based on Ubuntu 16.04 it is based on Debian 8 which is supported. Currently you can install it and it will set everything up properly. EmulationStation has issues launching roms just like through a manual installation. However the samba share setup and all other parts of RetroPie appear to function normally.

To start follow the same instructions of doing a git clone of the RetroPie repo. Then you have to edit

RetroPie-Setup/scriptmodules/system.sh

In the get_os_version() function the work-around is to change:

error="Unsupported OS"
;;
esac

To

__os_debian_ver="8"
;;
esac

This will obviously override any platform checking done by the script and is very hacky, but it will let the retropie setup continue properly until actual support exists

Перейти к ответу ➙
У вас нет необходимых прав для просмотра вложений в этом сообщении.
LM18.2 Cinnamon 3.2.7 Kernel: 4.12.0-041200-generic

Аватара пользователя

di_mok
Сообщения: 2220
Зарегистрирован: 27 авг 2016, 16:06
Решено: 15
Откуда: Арзамас
Благодарил (а): 577 раз
Поблагодарили: 341 раз

Установка Retropie в LMDE2

Сообщение di_mok » 06 июл 2017, 16:38

Тупейший способ - заменить строку error="You need Linux Mint 17 or newer" на __os_debian_ver="8", но проверить сейчас не могу
Настоящая водка — это не пьянство, а ключ к своей совести, с нее-то и начинается настоящая мудрость. (c)

Аватара пользователя

Chocobo
Сообщения: 5544
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1438 раз

Установка Retropie в LMDE2

Сообщение Chocobo » 06 июл 2017, 16:41

di_mok, Ага должно сработать.

Или поставить в той же проверке lt 2 в 114 строке:

Код: Выделить всё

LinuxMint)
            if compareVersions "$__os_release" lt 2; then
                error="You need Linux Mint 17 or newer"
Тогда бетси, со своей второй версией пройдет проверку)

Аватара пользователя

Автор темы
wanoska
Сообщения: 164
Зарегистрирован: 17 окт 2016, 12:36
Решено: 4
Откуда: Кинешма
Благодарил (а): 31 раз
Поблагодарили: 41 раз

Установка Retropie в LMDE2

Сообщение wanoska » 06 июл 2017, 17:17

цитата с оф сайта, надо блин документацию до конца читать Ваньке :-D
Section 3.12: SteamOS hack to allow installation

While SteamOS is not based on Ubuntu 16.04 it is based on Debian 8 which is supported. Currently you can install it and it will set everything up properly. EmulationStation has issues launching roms just like through a manual installation. However the samba share setup and all other parts of RetroPie appear to function normally.

To start follow the same instructions of doing a git clone of the RetroPie repo. Then you have to edit

RetroPie-Setup/scriptmodules/system.sh

In the get_os_version() function the work-around is to change:

error="Unsupported OS"
;;
esac

To

__os_debian_ver="8"
;;
esac

This will obviously override any platform checking done by the script and is very hacky, but it will let the retropie setup continue properly until actual support exists
LM18.2 Cinnamon 3.2.7 Kernel: 4.12.0-041200-generic

Аватара пользователя

di_mok
Сообщения: 2220
Зарегистрирован: 27 авг 2016, 16:06
Решено: 15
Откуда: Арзамас
Благодарил (а): 577 раз
Поблагодарили: 341 раз

Установка Retropie в LMDE2

Сообщение di_mok » 06 июл 2017, 17:41

:lol:
Настоящая водка — это не пьянство, а ключ к своей совести, с нее-то и начинается настоящая мудрость. (c)

Аватара пользователя

Chocobo
Сообщения: 5544
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1438 раз

Установка Retropie в LMDE2

Сообщение Chocobo » 06 июл 2017, 17:43

di_mok, в яблочко :ok:

Аватара пользователя

di_mok
Сообщения: 2220
Зарегистрирован: 27 авг 2016, 16:06
Решено: 15
Откуда: Арзамас
Благодарил (а): 577 раз
Поблагодарили: 341 раз

Установка Retropie в LMDE2

Сообщение di_mok » 06 июл 2017, 17:45

Chocobo, ты на днях баш помянул :-D
Настоящая водка — это не пьянство, а ключ к своей совести, с нее-то и начинается настоящая мудрость. (c)

Вернуться в «Linux Mint Debian Edition»