✓ Решено Ошибка при установке Seamonkey

Вы не знаете в какой раздел задать вопрос? Ищите ответы на популярные вопросы? Тогда вам сюда!
Правила форума
Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах
alex-brok
Сообщения: 10
Зарегистрирован: 07 июл 2017, 06:51
Благодарил (а): 2 раза

Ошибка при установке Seamonkey

Сообщение alex-brok » 07 июл 2017, 07:18

При установке Seamonkey 2.46 с деб пакета появилось сообщение:
Ошибка: Конфликтует с установленным пакетом "hunspel-en-us": `iceweasel`. Но `/seamonkey-mozilla-bulld_2.46-0ubuntu1_amd64.deb` доступен через: `gnome-www-browser,iceweasel,www-browser,semonkey`

Как можно удалить этот конфликт и установить Seamonkey с деб пакета?

Решение Chocobo » 07 июл 2017, 09:43
alex-brok, да не, пакет тот же, не думаю что то-нибудь изменится.

Попробуй лучше удалить пакет который вызывает конфликт - apt remove hunspell-en-us, я глянул он без зависимостей улетает, ничего не обломится.

Перейти к ответу ➙
LM 18.2 x64. xfce

Аватара пользователя
Dja
Сообщения: 1991
Зарегистрирован: 27 авг 2016, 17:03
Решено: 11
Откуда: Воскресенск
Благодарил (а): 301 раз
Поблагодарили: 219 раз

Ошибка при установке Seamonkey

Сообщение Dja » 07 июл 2017, 07:56

Код: Выделить всё

sudo apt install -f && sudo apt update && sudo apt upgrade -y
Новичок? - ознакомься с правилами
Изображение
В поисках истины :grabli:
Изображение

alex-brok
Сообщения: 10
Зарегистрирован: 07 июл 2017, 06:51
Благодарил (а): 2 раза

Ошибка при установке Seamonkey

Сообщение alex-brok » 07 июл 2017, 08:06

Можно кратко объяснить, что будет инсталиться, апдейтиться и апграйтиться? )) хочется понимать что делаю
LM 18.2 x64. xfce

Аватара пользователя
Dja
Сообщения: 1991
Зарегистрирован: 27 авг 2016, 17:03
Решено: 11
Откуда: Воскресенск
Благодарил (а): 301 раз
Поблагодарили: 219 раз

Ошибка при установке Seamonkey

Сообщение Dja » 07 июл 2017, 08:13

alex-brok, инсталлиться ничего (если только новые пакеты при обновлении). апдейт и апгрейд - обновление. инсталл -ф - удовлетворение зависимостей.
Новичок? - ознакомься с правилами
Изображение
В поисках истины :grabli:
Изображение

Аватара пользователя
Chocobo
Сообщения: 4564
Зарегистрирован: 27 авг 2016, 19:57
Решено: 108
Откуда: НН
Благодарил (а): 373 раза
Поблагодарили: 1223 раза

Ошибка при установке Seamonkey

Сообщение Chocobo » 07 июл 2017, 08:16

alex-brok,
а сам Iceweasel тоже установлен?
У меня инсталлится без кофликтов аналогичная версия

Снимок экрана от 2017-07-07 11-13-49.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Изображение

alex-brok
Сообщения: 10
Зарегистрирован: 07 июл 2017, 06:51
Благодарил (а): 2 раза

Ошибка при установке Seamonkey

Сообщение alex-brok » 07 июл 2017, 09:14

Dja, после обновления ошибка такая же.
Chocobo, я так понимаю если конфликт с Iceweasel есть, то это значит он установлен....
У меня несколько другая конфигурация:

Код: Выделить всё

System:    Host: Desktop-Lin Kernel: 4.8.0-58-generic x86_64 (64 bit)
           Desktop: Xfce 4.12.3 Distro: Linux Mint 18.2 Sonya
Последний раз редактировалось alex-brok 07 июл 2017, 09:18, всего редактировалось 1 раз.
LM 18.2 x64. xfce

Аватара пользователя
Chocobo
Сообщения: 4564
Зарегистрирован: 27 авг 2016, 19:57
Решено: 108
Откуда: НН
Благодарил (а): 373 раза
Поблагодарили: 1223 раза

Ошибка при установке Seamonkey

Сообщение Chocobo » 07 июл 2017, 09:15

alex-brok, сам он не установится :smile: поэтому тебе видней
Покажи лучше apt policy iceweasel
Изображение

alex-brok
Сообщения: 10
Зарегистрирован: 07 июл 2017, 06:51
Благодарил (а): 2 раза

Ошибка при установке Seamonkey

Сообщение alex-brok » 07 июл 2017, 09:20

Chocobo, вы правы - iceweasel отсуствует. Надо установить?
LM 18.2 x64. xfce

Аватара пользователя
Chocobo
Сообщения: 4564
Зарегистрирован: 27 авг 2016, 19:57
Решено: 108
Откуда: НН
Благодарил (а): 373 раза
Поблагодарили: 1223 раза

Ошибка при установке Seamonkey

Сообщение Chocobo » 07 июл 2017, 09:24

Да не, наоборот по первому выхлопу он мог бы мешать.

Ну и сам дебпакет откуда брал?

я например ставил с репозитория
deb http://downloads.sourceforge.net/projec ... ozilla/apt all main
как описано тут
Изображение

alex-brok
Сообщения: 10
Зарегистрирован: 07 июл 2017, 06:51
Благодарил (а): 2 раза

Ошибка при установке Seamonkey

Сообщение alex-brok » 07 июл 2017, 09:33

Я взял там же но не с репозитория, а скачал деб пакет https://sourceforge.net/projects/ubuntu ... lla-build/

Попробую ещё по этой инструкции, с репозитория, установить...
LM 18.2 x64. xfce

Аватара пользователя
Chocobo
Сообщения: 4564
Зарегистрирован: 27 авг 2016, 19:57
Решено: 108
Откуда: НН
Благодарил (а): 373 раза
Поблагодарили: 1223 раза

Ошибка при установке Seamonkey

Сообщение Chocobo » 07 июл 2017, 09:43

alex-brok, да не, пакет тот же, не думаю что то-нибудь изменится.

Попробуй лучше удалить пакет который вызывает конфликт - apt remove hunspell-en-us, я глянул он без зависимостей улетает, ничего не обломится.
Изображение

alex-brok
Сообщения: 10
Зарегистрирован: 07 июл 2017, 06:51
Благодарил (а): 2 раза

Ошибка при установке Seamonkey

Сообщение alex-brok » 07 июл 2017, 10:30

Chocobo, Yes!!! :cray2: После удаления hunspell-en-us установился Seamonkey !
тот пакет hunspell-en-us который мешал - это остаток удаленной проги.
В консоли предложено выполнить sudo apt autoremove, я так понимаю, что это удаление остатков удаленных пакетов?
LM 18.2 x64. xfce

Аватара пользователя
Chocobo
Сообщения: 4564
Зарегистрирован: 27 авг 2016, 19:57
Решено: 108
Откуда: НН
Благодарил (а): 373 раза
Поблагодарили: 1223 раза

Ошибка при установке Seamonkey

Сообщение Chocobo » 07 июл 2017, 10:32

alex-brok, Ага, те пакеты которые не используются (по мнению апта)

Код: Выделить всё

 autoremove       - Remove automatically all unused packages
Изображение


Вернуться в «Вопрос новичка и FaQ»

Кто сейчас на конференции

Сейчас этот форум просматривают: Linkdex [Bot] и 0 гостей