Не запускается система

Правила форума
Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа.

Автор темы
Spaawa
Сообщения: 12
Зарегистрирован: 04 июн 2017, 17:40
Благодарил (а): 2 раза

Не запускается система

Сообщение Spaawa » 07 июл 2017, 18:06

Всем привет!
Думаю по заголовку все понятно.
Загрузка проходит этап логотипа минт и останавливается на этапе черного экрана. Ждать можно сколько угодно, дальше не идет.
Единственная зацепка это то, что система спокойно грузится если выбрать режим systemd в адвансед в груб(скрин приложил).
Последние действия которые я совершал перед появлением проблемы это установка и настройка openvpn(я его уже удалил, не помогло).
Ну и еще, что кажется мне причиной этой проблемы, так это что я ребутнул ноут посредством кнопки, во время загрузки системы.
В общем надеюсь на вашу помощь! Пишите если нужны выводы логов или еще чего-то, я просто не знаю что в данном случае выставлять на показ, поэтому просьба не пинать.
Заранее спасибо.

Код: Выделить всё

pc@pc ~ $ lsb_release -a
No LSB modules are available.
Distributor ID:	LinuxMint
Description:	Linux Mint 18.1 Serena
Release:	18.1
Codename:	serena
Pc_h7gIdtwc.jpg

Решение Chocobo » 08 июл 2017, 10:45
Spaawa,
Start-Date: 2017-07-06 18:39:46
Commandline: apt-get install upstart-sysv
Вот и ответ. они конфликтуют меж собой с systemd-sysv.
Следующий вопрос зачем ты его притянул, т.к. он тут один - не похоже что кто-то его притащил зависимостью )

Ну и вернуть все обратно - просто с apt install systemd-sysv

Перейти к ответу ➙
У вас нет необходимых прав для просмотра вложений в этом сообщении.

В сети
Аватара пользователя

Chocobo
Сообщения: 5523
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1434 раза

Не запускается система

Сообщение Chocobo » 07 июл 2017, 19:18

Spaawa писал(а): система спокойно грузится если выбрать режим systemd в адвансед в груб(скрин приложил).
Тут стоит заметить, что загрузка в systemd и есть режим по-умолчанию для Serena)

В грабе по рабочему и поломанному пункту нажми e для входа в режим редактирования, будет показана строка загрузочной конфигурации.

Сравни чем они там отличаются.


Автор темы
Spaawa
Сообщения: 12
Зарегистрирован: 04 июн 2017, 17:40
Благодарил (а): 2 раза

Не запускается система

Сообщение Spaawa » 07 июл 2017, 21:41

Chocobo, Отличаются наличием этой строчки. Соответственно в нерабочем варианте она отсутствует
5QaiCdbr86o.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.

В сети
Аватара пользователя

Chocobo
Сообщения: 5523
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1434 раза

Не запускается система

Сообщение Chocobo » 07 июл 2017, 21:54

Spaawa, думается ты каким-то образом поломал дефолтный инит.
Потому что обычно все как раз наоборот, по дефолту грузится системд, а как дополнительная опция прописан апстарт.

У тебя тут все несколько иначе, ну или наоборот.
проверь наудачу куда ссылается инит,

Код: Выделить всё

chocobo@desktop ~ $ ls -l /sbin/init
lrwxrwxrwx 1 root root 20 июл  7 21:04 /sbin/init -> /lib/systemd/systemd
Но он наверное переписывется директивой из параметра ядра, когда загружаешься с его указанием.

Поэтому верней попробовать с лайва - примонтировать корневую фс и посмотреть куда ведет этот симлинк там.
Это если хочется разобраться. Также неплохо бы посмотреть последние изменения по пакетам под появление проблемы, 90% вероятности влияния чего-нибудь из них.


А вкачестве решения "в лоб", чтоб просто работало - допиши init=/lib/systemd/systemd в значения строки GRUB_CMDLINE_LINUX="" из файла /etc/default/grub и дай sudo update-grub


Автор темы
Spaawa
Сообщения: 12
Зарегистрирован: 04 июн 2017, 17:40
Благодарил (а): 2 раза

Не запускается система

Сообщение Spaawa » 08 июл 2017, 10:04

Chocobo,

Код: Выделить всё

pc@pc ~ $ ls -l /sbin/init
lrwxrwxrwx 1 root root 7 май 19  2016 /sbin/init -> upstart
Вот как раз последние изменения по пакетам.
После Start-Date: 2017-07-06 22:46:23(включительно) идут команды производившиеся уже после появления проблемы.

Код: Выделить всё

Start-Date: 2017-07-06  16:50:29
Commandline: apt-get install -y openvpn
Requested-By: pc (1000)
Upgrade: openvpn:amd64 (2.3.10-1ubuntu2, 2.3.10-1ubuntu2.1)
End-Date: 2017-07-06  16:50:42

Start-Date: 2017-07-06  16:51:27
Commandline: apt-get install openvpn easy-rsa
Requested-By: pc (1000)
Install: easy-rsa:amd64 (2.2.2-2)
End-Date: 2017-07-06  16:51:30

Start-Date: 2017-07-06  18:39:46
Commandline: apt-get install upstart-sysv
Requested-By: pc (1000)
Install: upstart-sysv:amd64 (1.13.2-0ubuntu21.1)
Remove: systemd-sysv:amd64 (229-4ubuntu17)
End-Date: 2017-07-06  18:39:59

Start-Date: 2017-07-06  22:33:59
Commandline: apt-get autoremove
Remove: libopenal1:amd64 (1:1.16.0-3), chromium-bsu-data:amd64 (0.9.15.1-1), libglc0:amd64 (0.7.2-5ubuntu4), libglewmx1.13:amd64 (1.13.0-2), libalut0:amd64 (1.1.0-5), libsdl-image1.2:amd64 (1.2.12-5build2), fonts-uralic:amd64 (0.0.20040829-5)
End-Date: 2017-07-06  22:34:09

Start-Date: 2017-07-06  22:35:29
Commandline: apt-get dist-upgrade
Install: libcapnp-0.5.3:amd64 (0.5.3-2ubuntu1, automatic), libmircore1:amd64 (0.26.3+16.04.20170605-0ubuntu1, automatic), libmircommon7:amd64 (0.26.3+16.04.20170605-0ubuntu1, automatic)
Upgrade: libdns-export162:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.6, 1:9.10.3.dfsg.P4-8ubuntu1.7), libisccfg140:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.6, 1:9.10.3.dfsg.P4-8ubuntu1.7), uuid-runtime:amd64 (2.27.1-6ubuntu3.2, 2.27.1-6ubuntu3.3), libfdisk1:amd64 (2.27.1-6ubuntu3.2, 2.27.1-6ubuntu3.3), python-samba:amd64 (2:4.3.11+dfsg-0ubuntu0.16.04.7, 2:4.3.11+dfsg-0ubuntu0.16.04.8), linux-libc-dev:amd64 (4.4.0-79.100, 4.4.0-83.106), libnss3-nssdb:amd64 (2:3.28.4-0ubuntu0.16.04.1, 2:3.28.4-0ubuntu0.16.04.2), libwbclient0:amd64 (2:4.3.11+dfsg-0ubuntu0.16.04.7, 2:4.3.11+dfsg-0ubuntu0.16.04.8), libpulsedsp:i386 (1:8.0-0ubuntu3.2, 1:8.0-0ubuntu3.3), libpulsedsp:amd64 (1:8.0-0ubuntu3.2, 1:8.0-0ubuntu3.3), pulseaudio:amd64 (1:8.0-0ubuntu3.2, 1:8.0-0ubuntu3.3), libmount1:amd64 (2.27.1-6ubuntu3.2, 2.27.1-6ubuntu3.3), bind9-host:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.6, 1:9.10.3.dfsg.P4-8ubuntu1.7), dnsutils:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.6, 1:9.10.3.dfsg.P4-8ubuntu1.7), google-chrome-stable:amd64 (59.0.3071.109-1, 59.0.3071.115-1), util-linux:amd64 (2.27.1-6ubuntu3.2, 2.27.1-6ubuntu3.3), libisc160:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.6, 1:9.10.3.dfsg.P4-8ubuntu1.7), locales:amd64 (2.23-0ubuntu7, 2.23-0ubuntu9), libnss3-1d:amd64 (2:3.28.4-0ubuntu0.16.04.1, 2:3.28.4-0ubuntu0.16.04.2), thunderbird-gnome-support:amd64 (1:52.1.1+build1-0ubuntu0.16.04.1, 1:52.2.1+build1-0ubuntu0.16.04.1), mount:amd64 (2.27.1-6ubuntu3.2, 2.27.1-6ubuntu3.3), ntp:amd64 (1:4.2.8p4+dfsg-3ubuntu5.4, 1:4.2.8p4+dfsg-3ubuntu5.5), samba-libs:amd64 (2:4.3.11+dfsg-0ubuntu0.16.04.7, 2:4.3.11+dfsg-0ubuntu0.16.04.8), ntpdate:amd64 (1:4.2.8p4+dfsg-3ubuntu5.4, 1:4.2.8p4+dfsg-3ubuntu5.5), libblkid1:amd64 (2.27.1-6ubuntu3.2, 2.27.1-6ubuntu3.3), libnautilus-extension1a:amd64 (1:3.18.4.is.3.14.3-0ubuntu5, 1:3.18.4.is.3.14.3-0ubuntu6), libisc-export160:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.6, 1:9.10.3.dfsg.P4-8ubuntu1.7), libc-bin:amd64 (2.23-0ubuntu7, 2.23-0ubuntu9), libpulse0:amd64 (1:8.0-0ubuntu3.2, 1:8.0-0ubuntu3.3), libpulse0:i386 (1:8.0-0ubuntu3.2, 1:8.0-0ubuntu3.3), libmirclient9:amd64 (0.21.0+16.04.20160330-0ubuntu1, 0.26.3+16.04.20170605-0ubuntu1), libpulse-mainloop-glib0:i386 (1:8.0-0ubuntu3.2, 1:8.0-0ubuntu3.3), libpulse-mainloop-glib0:amd64 (1:8.0-0ubuntu3.2, 1:8.0-0ubuntu3.3), samba-common:amd64 (2:4.3.11+dfsg-0ubuntu0.16.04.7, 2:4.3.11+dfsg-0ubuntu0.16.04.8), libuuid1:amd64 (2.27.1-6ubuntu3.2, 2.27.1-6ubuntu3.3), libuuid1:i386 (2.27.1-6ubuntu3.2, 2.27.1-6ubuntu3.3), libgcrypt20:amd64 (1.6.5-2ubuntu0.2, 1.6.5-2ubuntu0.3), libgcrypt20:i386 (1.6.5-2ubuntu0.2, 1.6.5-2ubuntu0.3), liblwres141:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.6, 1:9.10.3.dfsg.P4-8ubuntu1.7), libsmartcols1:amd64 (2.27.1-6ubuntu3.2, 2.27.1-6ubuntu3.3), libsmbclient:amd64 (2:4.3.11+dfsg-0ubuntu0.16.04.7, 2:4.3.11+dfsg-0ubuntu0.16.04.8), smbclient:amd64 (2:4.3.11+dfsg-0ubuntu0.16.04.7, 2:4.3.11+dfsg-0ubuntu0.16.04.8), samba-common-bin:amd64 (2:4.3.11+dfsg-0ubuntu0.16.04.7, 2:4.3.11+dfsg-0ubuntu0.16.04.8), bsdutils:amd64 (1:2.27.1-6ubuntu3.2, 1:2.27.1-6ubuntu3.3), thunderbird:amd64 (1:52.1.1+build1-0ubuntu0.16.04.1, 1:52.2.1+build1-0ubuntu0.16.04.1), libdns162:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.6, 1:9.10.3.dfsg.P4-8ubuntu1.7), pulseaudio-module-x11:amd64 (1:8.0-0ubuntu3.2, 1:8.0-0ubuntu3.3), multiarch-support:amd64 (2.23-0ubuntu7, 2.23-0ubuntu9), pulseaudio-module-bluetooth:amd64 (1:8.0-0ubuntu3.2, 1:8.0-0ubuntu3.3), libnss3:amd64 (2:3.28.4-0ubuntu0.16.04.1, 2:3.28.4-0ubuntu0.16.04.2), libnss3:i386 (2:3.28.4-0ubuntu0.16.04.1, 2:3.28.4-0ubuntu0.16.04.2), btrfs-tools:amd64 (4.4-1, 4.4-1ubuntu1), mint-upgrade-info:amd64 (1.0.7, 1.0.8), libisccc140:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.6, 1:9.10.3.dfsg.P4-8ubuntu1.7), nautilus-data:amd64 (1:3.18.4.is.3.14.3-0ubuntu5, 1:3.18.4.is.3.14.3-0ubuntu6), libbind9-140:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.6, 1:9.10.3.dfsg.P4-8ubuntu1.7), pulseaudio-utils:amd64 (1:8.0-0ubuntu3.2, 1:8.0-0ubuntu3.3), less:amd64 (481-2.1ubuntu0.1, 481-2.1ubuntu0.2)
End-Date: 2017-07-06  22:38:02

Start-Date: 2017-07-06  22:46:23
Commandline: apt-get purge openvpn
Requested-By: pc (1000)
Purge: openvpn:amd64 (2.3.10-1ubuntu2.1), network-manager-openvpn:amd64 (1.1.93-1ubuntu1.1), network-manager-openvpn-gnome:amd64 (1.1.93-1ubuntu1.1)
End-Date: 2017-07-06  22:46:35

Start-Date: 2017-07-06  22:52:20
Commandline: apt-get install --reinstall grub-efi
Requested-By: pc (1000)
Install: grub-efi:amd64 (2.02~beta2-36ubuntu3.11)
End-Date: 2017-07-06  22:52:25

Start-Date: 2017-07-06  23:06:08
Commandline: aptdaemon role='role-commit-packages' sender=':1.45'
Install: libcuda1-375:amd64 (375.66-0ubuntu0.16.04.1), libvdpau1:amd64 (1.1.1-3ubuntu1, automatic), xserver-xorg-legacy:amd64 (2:1.18.4-0ubuntu0.2, automatic), nvidia-prime:amd64 (0.8.2linuxmint1), libxnvctrl0:amd64 (361.42-0ubuntu1, automatic), lib32gcc1:amd64 (1:6.0.1-0ubuntu1, automatic), libc6-i386:amd64 (2.23-0ubuntu9, automatic), screen-resolution-extra:amd64 (0.17.1, automatic), ocl-icd-libopencl1:amd64 (2.2.8-1, automatic), libjansson4:amd64 (2.7-3, automatic), bbswitch-dkms:amd64 (0.8-3ubuntu1, automatic), nvidia-opencl-icd-375:amd64 (375.66-0ubuntu0.16.04.1), nvidia-375:amd64 (375.66-0ubuntu0.16.04.1), nvidia-settings:amd64 (361.42-0ubuntu1)
End-Date: 2017-07-06  23:09:38

Start-Date: 2017-07-07  17:56:47
Commandline: aptdaemon role='role-commit-packages' sender=':1.55'
Install: bcmwl-kernel-source:amd64 (6.30.223.271+bdcom-0ubuntu1~1.1)
Remove: firmware-b43-installer:amd64 (1:019-2)
End-Date: 2017-07-07  17:58:07
Решение в лоб это конечно хорошо, но хотелось бы вылечить проблему, а не замазать)

В сети
Аватара пользователя

Chocobo
Сообщения: 5523
Зарегистрирован: 27 авг 2016, 19:57
Решено: 129
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1434 раза

Не запускается система

Сообщение Chocobo » 08 июл 2017, 10:45

Spaawa,
Start-Date: 2017-07-06 18:39:46
Commandline: apt-get install upstart-sysv
Вот и ответ. они конфликтуют меж собой с systemd-sysv.
Следующий вопрос зачем ты его притянул, т.к. он тут один - не похоже что кто-то его притащил зависимостью )

Ну и вернуть все обратно - просто с apt install systemd-sysv


Автор темы
Spaawa
Сообщения: 12
Зарегистрирован: 04 июн 2017, 17:40
Благодарил (а): 2 раза

Не запускается система

Сообщение Spaawa » 08 июл 2017, 10:56

Chocobo,
Спасибо! Заработало)

У меня не работал VPN. Я полез в гугл и пробовал все что там писали, и видимо это я взял из темы по решении VPN проблемы. :sry:

Вернуться в «Загрузка системы, бэкапы и восстановление»