Про обновления

Аватара пользователя

Автор темы
Unat
Сообщения: 141
Зарегистрирован: 09 июн 2017, 12:41
Решено: 1
Благодарил (а): 50 раз
Поблагодарили: 3 раза

Про обновления

Сообщение Unat » 09 июл 2017, 20:01

Вот вижу в Менеджере Обновлений такую картинку. Причём даже в режиме "Не сломай мой компьютер", правда при этом галочки не стоят. Стоит ли это устанавливать? И что делает у меня в МАТЕ "cinnamon-nemo"?
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Аватара пользователя

Chocobo
Сообщения: 5503
Зарегистрирован: 27 авг 2016, 19:57
Решено: 128
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1427 раз

Про обновления

Сообщение Chocobo » 09 июл 2017, 20:08

Unat, Если вопрос заключается в том "почему я это вижу" - то настройка отображения уровней и выбора их по умолчанию, согласно заданной политике задается в настройках.
Screenshot_20170709_230530.png
Ставить или не ставить - выбор всегда за пользователем.
Только стоит обратить внимание что те обновления которые помечены пиктограммой с знаком восклицания - несут в себе обновления безопасности. Как правило пустяковые и никогда нам не угрожающие, но тем не менее.
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Аватара пользователя

Автор темы
Unat
Сообщения: 141
Зарегистрирован: 09 июн 2017, 12:41
Решено: 1
Благодарил (а): 50 раз
Поблагодарили: 3 раза

Про обновления

Сообщение Unat » 09 июл 2017, 20:18

Знаю. Но почему то раньше никогда у меня эти оранжевые и красные опции даже не отображались в режиме "Не сломай мой компьютер", вот что меня смущает.

Аватара пользователя

Chocobo
Сообщения: 5503
Зарегистрирован: 27 авг 2016, 19:57
Решено: 128
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1427 раз

Про обновления

Сообщение Chocobo » 09 июл 2017, 20:23

Unat, в 18.2 изменилась политика обновлений, об этом уже неоднократно упоминали. Переработали разбитие по уровням и по умолчанию больше их не прячут, т.к. поняли, что нехорошо прятать от пользователя заплатки к софту.

Вручную можно выставить отображение только 1 и 2 левела если хочется.

Аватара пользователя

Автор темы
Unat
Сообщения: 141
Зарегистрирован: 09 июн 2017, 12:41
Решено: 1
Благодарил (а): 50 раз
Поблагодарили: 3 раза

Про обновления

Сообщение Unat » 09 июл 2017, 20:45

Про то, что политика обновлений изменилась - от вас только услышал. Но вот то, что теперь в Менеджере Обновлений по-английски писать стали, тогда как доселе всё там на русском было - заметил сразу.
Ну а могут эти "оранжевые заплатки" по прошествии некоторого времени "позеленеть"? Ну, по мере того, как их получше протестируют?

Аватара пользователя

symon2014
Сообщения: 1578
Зарегистрирован: 29 авг 2016, 02:17
Решено: 19
Откуда: Феодосия
Благодарил (а): 47 раз
Поблагодарили: 427 раз

Про обновления

Сообщение symon2014 » 09 июл 2017, 20:49

:sry:
Debian (9.1) , LMDE2 , LM 18.2 Mate . Благодарности складываем сюда ---> R320161344462

Аватара пользователя

Автор темы
Unat
Сообщения: 141
Зарегистрирован: 09 июн 2017, 12:41
Решено: 1
Благодарил (а): 50 раз
Поблагодарили: 3 раза

Про обновления

Сообщение Unat » 09 июл 2017, 21:08

Не думаю, что он ответит. Может тут кто-либо, на основе своего опыта (ну мало ли была точно такая же "оранжевая" ситуация с этими обновлениями), в курсе?

Аватара пользователя

Chocobo
Сообщения: 5503
Зарегистрирован: 27 авг 2016, 19:57
Решено: 128
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1427 раз

Про обновления

Сообщение Chocobo » 09 июл 2017, 22:08

Unat писал(а): от вас только услышал.
Поглядывайте за новостями проекта, раз интересуют подобного рода изменения :smile:
Unat писал(а): Ну а могут эти "оранжевые заплатки" по прошествии некоторого времени "позеленеть"? Ну, по мере того, как их получше протестируют?
Нет. От того кто их тестировал и насколько тщательно - ничего не изменится. По прошествии времени только тестируемая версия безнадежно протухнет и сменится новой)

Различия в уровнях именно по возможному влиянию на систему.

Если обновить, например, пакет conky - это фигня и пройдет назаметно.
если сinnamon - уже сложней ибо комплексная штука
glibc или systemd - и вовсе может много куда аукнуться, в теории.


Filin
Сообщения: 171
Зарегистрирован: 05 ноя 2016, 15:20
Решено: 1
Благодарил (а): 24 раза
Поблагодарили: 20 раз

Про обновления

Сообщение Filin » 10 июл 2017, 03:13

Unat писал(а): И что делает у меня в МАТЕ "cinnamon-nemo"?
Unat, система установила его что бы использовать какие то необходимые для неё патчи, сценарии, расширения. То есть для себя. Вреда от этого никакого нет тем более что он спокойно лежит где то в недрах операционки и кушать не просит :smile: а вот польза безусловно есть . Ну естественно время от времени он будет просить обновиться. У меня таким образом Nautilus появился - тоже в первый момент не мог сообразить "когда же это я его устанавливал ?".

Аватара пользователя

prusony
Сообщения: 38
Зарегистрирован: 04 май 2017, 08:33
Решено: 4
Благодарил (а): 24 раза

Про обновления

Сообщение prusony » 10 июл 2017, 05:23

Мнение бегинера. )
LM-18.1-KDE живёт на компе несколько месяцев, устанавливаю ВСЁ что предлагается, ну доверчивый такой... )) Всё работает до сих пор, правда GRUB в одном из меню предлагает штук семь "кернелов" , все работают.
За одно вопрос детский - лишние ядра надо удалять ? (Много ли места для них резЕрвится? Оставить самое старое и самое новое например, ядро.)

Аватара пользователя

symon2014
Сообщения: 1578
Зарегистрирован: 29 авг 2016, 02:17
Решено: 19
Откуда: Феодосия
Благодарил (а): 47 раз
Поблагодарили: 427 раз

Про обновления

Сообщение symon2014 » 10 июл 2017, 05:26

prusony, Если /boot не отдельным разделом, то в принципе по барабану. Я завёл привычку оставлять 2 последних (ИМХО).
:sry:
Debian (9.1) , LMDE2 , LM 18.2 Mate . Благодарности складываем сюда ---> R320161344462

Аватара пользователя

Автор темы
Unat
Сообщения: 141
Зарегистрирован: 09 июн 2017, 12:41
Решено: 1
Благодарил (а): 50 раз
Поблагодарили: 3 раза

Про обновления

Сообщение Unat » 10 июл 2017, 09:12

Chocobo писал(а): Ставить или не ставить - выбор всегда за пользователем.
Вот вы бы на моём месте поставили?
Filin писал(а): Вреда от этого никакого нет тем более что он спокойно лежит где то в недрах операционки и кушать не просит а вот польза безусловно есть . Ну естественно время от времени он будет просить обновиться. У меня таким образом Nautilus появился
Вот меня прям таки прёт от интереса - я ж любопытный, ё-моё! Ведь Nemo - это Файловый менеджер, используемый в Циннамоне, верно? А у меня МАТЕ со своим Файловым менеджером. Для каких целей обновления МАТЕ-дистрибутива мне подсовывает обновления для Циннамона?

Аватара пользователя

x230
Сообщения: 650
Зарегистрирован: 02 сен 2016, 19:07
Решено: 3
Благодарил (а): 136 раз
Поблагодарили: 136 раз

Про обновления

Сообщение x230 » 10 июл 2017, 09:24

Unat писал(а):почему то раньше никогда у меня эти оранжевые ... не отображались
Это конечно не "агрессивный маркетинг" Филиппа Котлера, но, как правильно выразился Chocobo:
Chocobo писал(а):изменилась политика обновлений
Последний раз редактировалось пользователем 1 x230; всего редактировалось раз: 10
моя платформа :
ОС: Linux Mint 18.2 Sonya, 64-bits. DE: Xfce 4.12.3 Ядро: 4.10.0-38-generic x86_64 Browser: Pale Moon 27.6.*
Железо: Intel Core i3-3210; CPU 3.20GHz x 2; Mem 4GB; VGA - на борту.

Аватара пользователя

x230
Сообщения: 650
Зарегистрирован: 02 сен 2016, 19:07
Решено: 3
Благодарил (а): 136 раз
Поблагодарили: 136 раз

Про обновления

Сообщение x230 » 10 июл 2017, 09:31

symon2014 писал(а): завёл привычку оставлять 2 последних
Встречное предложение: оставлять родное ("старое") + лучшее (быстрейшее, безглючнейшее, пусть субъективно) + последнее.
...
Чувствую перебор будет... :-D
...
Ну, да ладно. Сам оставил родное ядро. Последнее снёс в ожидании новой версии virtualbox. А вот на нетбуке поставил последнее 4.12 lowlatency (к стати - летает!)
Последний раз редактировалось пользователем 3 x230; всего редактировалось раз: 10
моя платформа :
ОС: Linux Mint 18.2 Sonya, 64-bits. DE: Xfce 4.12.3 Ядро: 4.10.0-38-generic x86_64 Browser: Pale Moon 27.6.*
Железо: Intel Core i3-3210; CPU 3.20GHz x 2; Mem 4GB; VGA - на борту.

Аватара пользователя

Chocobo
Сообщения: 5503
Зарегистрирован: 27 авг 2016, 19:57
Решено: 128
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1427 раз

Про обновления

Сообщение Chocobo » 10 июл 2017, 09:32

Unat писал(а): Вот меня прям таки прёт от интереса - я ж любопытный, ё-моё!
Тут думаю особенности или неточности нейминга в менеджере приложений, ибо обновляться на самом деле будет пакет libnemo-extension1, насчет этого можно удостовериться в apt list --upgradable
т.е фактически библиотеки расширений, которые возможно совместимы и c Caja. Сам немо не притянется :smile:

Аватара пользователя

Автор темы
Unat
Сообщения: 141
Зарегистрирован: 09 июн 2017, 12:41
Решено: 1
Благодарил (а): 50 раз
Поблагодарили: 3 раза

Про обновления

Сообщение Unat » 10 июл 2017, 09:34

x230 писал(а): Это конечно не "агрессивный маркетинг" Филиппа Котлера, но, как проавильно выразился Chocobo:
Chocobo писал(а):
Источник цитатыизменилась политика обновлений
Зря она изменилась :agry: - я ж теперь ночами спать не буду!

Аватара пользователя

ikrost
Сообщения: 115
Зарегистрирован: 12 май 2017, 14:20
Решено: 1
Откуда: Тбилиси
Благодарил (а): 60 раз
Поблагодарили: 10 раз

Про обновления

Сообщение ikrost » 10 июл 2017, 11:26

Unat писал(а): Зря она изменилась - я ж теперь ночами спать не буду!
Экай вы нервный однако. Не понимаю что вам мешает НЕ ставить 3, 4 и 5-ые обновления? Ну или поставьте версию 17.3 и спокойный сон гарантирован :smile:

Аватара пользователя

Автор темы
Unat
Сообщения: 141
Зарегистрирован: 09 июн 2017, 12:41
Решено: 1
Благодарил (а): 50 раз
Поблагодарили: 3 раза

Про обновления

Сообщение Unat » 10 июл 2017, 20:01

Chocobo писал(а): Ставить или не ставить - выбор всегда за пользователем.
Лично вы бы это на моём месте поставили бы?

Аватара пользователя

Dja
Сообщения: 2758
Зарегистрирован: 27 авг 2016, 17:03
Решено: 11
Откуда: Воскресенск
Благодарил (а): 389 раз
Поблагодарили: 282 раза

Про обновления

Сообщение Dja » 11 июл 2017, 10:15

Unat,

Код: Выделить всё

sudo apt update && sudo apt upgrade -y
пользовался и буду пользоваться. Тем более, что когда к примеру графики нет, то никаких гуй-обвновляльщиков разумеется тоже. Я ни в коем случае не отзываю от пользования этой приблудой, но зачем пользоваться тем, что может тебе предоставить другие сведения в зависимости от изменений политик, когда есть консоль которая не соврет и там всё понятно. Я вот раньше пробовал (лет 10-15 назад) обновиться гуей и что-то пошло не так (потерял графику) - reinstall, что в минте тоже столкнулся с тем, что данный метод лучше, чем гуй. Гуй непонятный. Ты вроде поставил ядро, а в обновлялке отображается более старое ядро, нежели то, которое стоит у тебя. В чем логика... Опять же ядро смысла обновлять нет без необходимости.
Новичок? - ознакомься с правилами

В поисках истины :grabli:

Аватара пользователя

slant
Сообщения: 295
Зарегистрирован: 21 июн 2017, 15:09
Решено: 5
Поблагодарили: 107 раз

Про обновления

Сообщение slant » 11 июл 2017, 10:31

Логика в наличии старого ядра в том, что если у тебя с новым что-то пойдет не так - ты сможешь загрузится со старым. Обычно системы на базе менеджера APT не удаляют старые ядра самостоятельно. Только по прямому запросу пользователя. И в загрузчике автоматически не удаляются пункты загрузки со старыми ядрами, только добавляются пункты для новых и изменяется настройка загрузки по умолчанию на свежее ядро. Но можно грузится и со старых, выбрав соответствующий пункт.

Вообще, замену ядра не следует воспринимать как простой апдейт, даже замену минорной версии. Это всегда некоторая возможность, что что-то может пойти не так и система не загрузится, или какой-то драйвер отвалится. Потому и сохраняется возможность использовать предыдущие ядра.

У меня всегда в системе как минимум два ядра установлено: родное которое идет вместе с дистрибутивом и свежее. А сейчас вообще три - родное, свежее рекомендуемое, и свежее из ветки 4.10.

Вернуться в «Mate»