bumblebee: Failed to initiate mode change

Не знаете как установить драйвер? Возникли проблемы? Вам сюда!
Правила форума
Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа.
sheriff
Сообщения: 5
Зарегистрирован: 29 авг 2017, 06:02

bumblebee: Failed to initiate mode change

Сообщение sheriff » 29 авг 2017, 06:13

Помогите разобраться, который день бьюсь!
Не могу настроить гибридную графику!

► Показать

bumblebee.conf

► Показать


Xorg.conf.nvidia

► Показать


Xorg.8.log

► Показать

Заранее спасибо!!!

Аватара пользователя
Chocobo
Сообщения: 4643
Зарегистрирован: 27 авг 2016, 19:57
Решено: 113
Откуда: НН
Благодарил (а): 376 раз
Поблагодарили: 1244 раза

bumblebee: Failed to initiate mode change

Сообщение Chocobo » 29 авг 2017, 06:19

Bumblebee (Nvidia + Intel) в Linux Mint 18 - Здесь смотрел?
Касаемо указания версии драйвера в bumblebee.conf, блеклинстинга модулей и реконф пакету после установки.
В Sarah я ставился так
Изображение

sheriff
Сообщения: 5
Зарегистрирован: 29 авг 2017, 06:02

bumblebee: Failed to initiate mode change

Сообщение sheriff » 29 авг 2017, 07:07

Я поэтой инструкции и делал!! там возникали еще ошибки но их кое как устранил, а эту не могу, и драйвера разные пробовал!
у меня ядро 4.12.9. но вроде как ядро модули подхватывает нормально!!! проблема гдето в настройках. но у меня не хватает знаний чтоб понять самому!!
Linux Mint 18.2

Аватара пользователя
Chocobo
Сообщения: 4643
Зарегистрирован: 27 авг 2016, 19:57
Решено: 113
Откуда: НН
Благодарил (а): 376 раз
Поблагодарили: 1244 раза

bumblebee: Failed to initiate mode change

Сообщение Chocobo » 29 авг 2017, 08:40

sheriff,судя по логу иксов так и взлетает nvidia-340, а он должен быть в блеклисте уже, чтоб стартовать под интелом без явного указания optirun.
Изображение

Unborn
Сообщения: 640
Зарегистрирован: 03 сен 2016, 10:36
Решено: 14
Благодарил (а): 2 раза
Поблагодарили: 93 раза

bumblebee: Failed to initiate mode change

Сообщение Unborn » 29 авг 2017, 13:30

sheriff писал(а):Источник цитаты apci_osi=! acpi_osi=Windows2009 quiet rcutree.rcu_idle_gp_delay=1 splash vt.handoff=7

Вот это всё удаляй, если не понимаешь, что это за параметры.
apci_osi=! - без восклицательного знака, это - костыль для ноутов Асус. По большому счёту не нужен. Отдельная тема.
acpi_osi=Windows2009 - бестолковка полная. Нет такого параметра.
rcutree.rcu_idle_gp_delay=1 - не нужно с включенным Оптимус. По сути - костыль.
И сторонние графические репы не нужны. Мёдом там тебе не намазано, - у тебя карта далеко не новой модели, раз со Интелом 2-го поколения работает на пару.
Просто вместо нвидиа-прайм устанавливается шмель по инструкции. А дальше уже смотреть как работает, что не работает.

sheriff
Сообщения: 5
Зарегистрирован: 29 авг 2017, 06:02

bumblebee: Failed to initiate mode change

Сообщение sheriff » 29 авг 2017, 15:00

переустановил систему ядро не обновлял, поставил все по инструкции Bumblebee (Nvidia + Intel) в Linux Mint 18 драйвера 375 версии, теперь такая ошибка

► Показать


вывод optirun --status при запуски системы

► Показать


вывод optirun --status после выполнения optirun glxgears
► Показать

Unborn
Сообщения: 640
Зарегистрирован: 03 сен 2016, 10:36
Решено: 14
Благодарил (а): 2 раза
Поблагодарили: 93 раза

bumblebee: Failed to initiate mode change

Сообщение Unborn » 29 авг 2017, 17:00

sheriff, у тебя проприетарный драйвер загружается по умолчанию, а должен Интел и всегда Интел для использования Шмеля. У тебя в БИОС Оптимус или что?
Что-то кажется, что ты сначала из Менеджера драйверов устанавливаешь Нвидиа, а потом уже остальное.

sheriff
Сообщения: 5
Зарегистрирован: 29 авг 2017, 06:02

bumblebee: Failed to initiate mode change

Сообщение sheriff » 29 авг 2017, 18:44

в биосе стоит оптимус, я не из менеджера ставил а вот так

Код: Выделить всё

sudo apt-get install bumblebee nvidia-375 nvidia-settings bumblebee-nvidia primus virtualgl linux-headers-$(uname -r) -y


P.S. поставил в биосе только intel
это log Xorg8
► Показать


вот лог Xorg0
► Показать

Unborn
Сообщения: 640
Зарегистрирован: 03 сен 2016, 10:36
Решено: 14
Благодарил (а): 2 раза
Поблагодарили: 93 раза

bumblebee: Failed to initiate mode change

Сообщение Unborn » 30 авг 2017, 07:29

sheriff, вот ещё попробуй - http://help.ubuntu.ru/wiki/bumblebee
Должен быть включен Оптимус. Загрузка с nomodeset и установка всего это хозяйства.
В Убунтоподобных х.з., а в Арче даже с nouveau заводили шмеля.
А может в твоём ноуте Оптимус сводится к софтовому переключению карт, а не их совместной работе.

sheriff
Сообщения: 5
Зарегистрирован: 29 авг 2017, 06:02

bumblebee: Failed to initiate mode change

Сообщение sheriff » 30 авг 2017, 19:42

то что по ссылке эт я пробовоал!!! можешь подробнее рассказать как и что!!


Вернуться в «Видеокарты»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей