LM-17.3-Cinnamon + gdevilspie

Программы для конфигурации и управления операционной системой
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот
Аватара пользователя

Автор темы
x230
Сообщения: 1060
Зарегистрирован: 02 сен 2016, 19:07
Решено: 3
Откуда: Краснодарский край
Благодарил (а): 217 раз
Поблагодарили: 269 раз

LM-17.3-Cinnamon + gdevilspie

Сообщение x230 » 10 ноя 2016, 15:56

gdevilspie в LM-17.3-Cinnamon не работает.(в других дистрах LM пашет норм.)
Выдает ошибку:

Что бы это значило?
...
А надо! Очень надо! - Архиполезная штуковина этот (g)devilspie!

Решение Chocobo » 10 ноя 2016, 16:10
x230, Это внутренняя ошибка в коде python. Недостающий атрибут (хотя обращение в условии мочему-то как к модулю)...
Попробуй найти и установиь другую версию.

Ага, вот тут описывают этот баг, и есть пересобранная дебка, лишенная этой печали

Перейти к ответу ➙
Последний раз редактировалось пользователем 2 Dja; всего редактировалось раз: 16
моя платформа :
ОС: Linux Mint 18.3, x64 DE: Xfce 4.12.3 Ядро: 4.15.1 Browser: Pale Moon 27.*; Железо: Intel Core i3-3210; Mem 4GB; VGA - на борту.

Аватара пользователя

Chocobo
Сообщения: 8007
Зарегистрирован: 27 авг 2016, 19:57
Решено: 172
Откуда: НН
Благодарил (а): 537 раз
Поблагодарили: 2156 раз

Re: (g)devilspie + LM-17.3-Cinnamon

Сообщение Chocobo » 10 ноя 2016, 16:10

x230, Это внутренняя ошибка в коде python. Недостающий атрибут (хотя обращение в условии мочему-то как к модулю)...
Попробуй найти и установиь другую версию.

Ага, вот тут описывают этот баг, и есть пересобранная дебка, лишенная этой печали
Изображение
   
Изображение

Аватара пользователя

zuzabrik
Сообщения: 1026
Зарегистрирован: 29 авг 2016, 09:08
Решено: 15
Благодарил (а): 64 раза
Поблагодарили: 301 раз

Re: (g)devilspie + LM-17.3-Cinnamon

Сообщение zuzabrik » 10 ноя 2016, 16:10

Я думаю он уже все тебе рассказал, осталось посмотреть на нужные строки и понять чего не хватает.

А так на вскидку если гадать по фотографии... попробуй стереть в /usr/bin/gdevilsie в строке 575 содержимое вложенных скобок кроме того что в кавычках. То есть хдг.ДесктопЕнтри.хдг_конфиг_хоум + и глянуть что выйдет :)

ТОК НЕ ЗАБУДЬ СОХРАНИТЬ ОРИГИНАЛ ФАЙЛА :)
Имею желание иметь всех желающих, но не имею желающих.

Аватара пользователя

zuzabrik
Сообщения: 1026
Зарегистрирован: 29 авг 2016, 09:08
Решено: 15
Благодарил (а): 64 раза
Поблагодарили: 301 раз

Re: (g)devilspie + LM-17.3-Cinnamon

Сообщение zuzabrik » 10 ноя 2016, 16:14

UPD. Касательно того что выше писал. там путь "/autostart/devilspie.desktop" дополняется как я понимаю переменными которые должны тебя до этой папки autostart довести в хомяке. Попробуй там просто абсолютный путь от корня влупить, без ~/
Имею желание иметь всех желающих, но не имею желающих.

Аватара пользователя

Автор темы
x230
Сообщения: 1060
Зарегистрирован: 02 сен 2016, 19:07
Решено: 3
Откуда: Краснодарский край
Благодарил (а): 217 раз
Поблагодарили: 269 раз

Re: (g)devilspie + LM-17.3-Cinnamon

Сообщение x230 » 10 ноя 2016, 17:01

Chocobo писал(а): пересобранная дебка
Спасибо, добрый человек. Ход мысли правильный. Только не эта дебка, а вот эта.
gdevilspie ставил в синаптике, а забыл ( :dash2: ), что в архивах валялось кое-что. И от туда поставил версию 0.5-3.2.
zuzabrik писал(а):
И тебе спасибо, добрый человек. Только я не намерен погружаться так глубоко, бо остатки мозга поплавятся. :hoho:
..............

Короче.
Снес версию gdevilspie_0.5-3_all, накатил версию gdevilspie_0.5-3.2_all, - и все заработало! Благодарю, товарищи! :thumbs:
моя платформа :
ОС: Linux Mint 18.3, x64 DE: Xfce 4.12.3 Ядро: 4.15.1 Browser: Pale Moon 27.*; Железо: Intel Core i3-3210; Mem 4GB; VGA - на борту.

Вернуться в «Системные утилиты»