Установка amd-gpu-pro 18.50

Руководства, вопросы, обсуждения
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот

Автор темы
nonniks
Сообщения: 9
Зарегистрирован: 21 апр 2019, 20:02
Решено: 1

Установка amd-gpu-pro 18.50

Сообщение nonniks » 21 апр 2019, 20:03

Здравствуйте, стоит у меня Linux Mint 19.1. И он, вроде как, на базе Ubuntu. 1го апреля вышла новая версия дров видеокарты amd gpu, вот и решил обновить, ибо при просмотре vga контроллеров - пишет 256мб видеопамяти, хотя стоят у меня R5 m240-340 (не особо помню), и R7 m440, и суммарно выходит 2,5гб видеопамяти. Так вот, ставлю я свежую версию amd gpu, для Ubuntu 18.04.1, думая, что Linux Mint стоит на убунте, а мне выдает ошибку в терминале, - "не та ОС". Для какой ОС тогда качать эти дрова, если там, по определению из выбора ток RHEL/CentOS, SLED/SLES и Ubuntu? Или то, что оно пишет из моих 2,5 гб - 256, это норма, и ничего не нужно ставить? Просто играю в PAYDAY 2 в Steam, и при смене графики с ультры на низкие - имею 19-22 фпс, что на тех, что на тех, хотя видео всякие, воспроизводятся хорошо, и без проблем, вот по этой причине и решил разобраться, в чем же, все таки, проблема.
По возможности, прошу еще объяснить: amd gpu, и amd gpu pro, в чем разница, и что лучше?

Решение nonniks » 22 апр 2019, 08:15
Для тех у кого такая же проблема. Решение таково: Заходим в папку с драйвером, и открываем amdgpuproinstall текстовым редактором, находим слово ubuntu (у меня оно было частью кода). И меняем на linuxmint. После этого загрузка пошла. Спасибо пользователю darkfenix, что сопутствовал решению проблемы.

Перейти к ответу ➙

Аватара пользователя

darkfenix
Сообщения: 5419
Зарегистрирован: 27 июн 2017, 10:36
Решено: 62
Откуда: Нижний Тагил
Благодарил (а): 295 раз
Поблагодарили: 1009 раз

Установка amd-gpu-pro 18.50

Сообщение darkfenix » 22 апр 2019, 03:08

nonniks писал(а):
21 апр 2019, 20:03
По возможности, прошу еще объяснить: amd gpu, и amd gpu pro, в чем разница, и что лучше?
Первые свободные, вторые проприетарные. На вторых производительность карточки должна быть лучше.
nonniks писал(а):
21 апр 2019, 20:03
а мне выдает ошибку в терминале, - "не та ОС".
По аналогии с этим делай Intel® Graphics Update Tool
Изображение


Автор темы
nonniks
Сообщения: 9
Зарегистрирован: 21 апр 2019, 20:02
Решено: 1

Установка amd-gpu-pro 18.50

Сообщение nonniks » 22 апр 2019, 07:34

darkfenix, нашел я, что менять, для Ubuntu 18.04.1. Поменял вроде, как написано в той инструкции и мне выдает вот это:

Код: Выделить всё

** (xed:20906): WARNING **: 10:30:28.081: Set document metadata failed: Setting attribute metadata::xed-spell-language not supported

** (xed:20906): WARNING **: 10:30:28.081: Set document metadata failed: Setting attribute metadata::xed-encoding not supported
У вас нет необходимых прав для просмотра вложений в этом сообщении.


Автор темы
nonniks
Сообщения: 9
Зарегистрирован: 21 апр 2019, 20:02
Решено: 1

Установка amd-gpu-pro 18.50

Сообщение nonniks » 22 апр 2019, 07:36

я пробовал и запустить снова установку, но мне продолжает писать "Unsupported OS". Но открывая сам файл lsb-release, - изменения применены.


Автор темы
nonniks
Сообщения: 9
Зарегистрирован: 21 апр 2019, 20:02
Решено: 1

Установка amd-gpu-pro 18.50

Сообщение nonniks » 22 апр 2019, 08:15

Для тех у кого такая же проблема. Решение таково: Заходим в папку с драйвером, и открываем amdgpuproinstall текстовым редактором, находим слово ubuntu (у меня оно было частью кода). И меняем на linuxmint. После этого загрузка пошла. Спасибо пользователю darkfenix, что сопутствовал решению проблемы.

Вернуться в «Параметры и оптимизация»