Opera и пакеты с неудовлетворенными зависимостями

Интернет
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот

Автор темы
sgtpepermail
Сообщения: 17
Зарегистрирован: 23 ноя 2018, 11:32

Opera и пакеты с неудовлетворенными зависимостями

Сообщение sgtpepermail » 01 май 2019, 09:22

Салют. Стояла Опера, нужно было снести и заново поставить. Скачал с оф сайта deb пакет - он не устанавливался. Затем зашел в Менеджер программ, смотрю появилась там Опера. Пытаюсь оттуда установить - пишет:
Следующие пакеты имеют неудовлетворённые зависимости:

opera: Depends: libgcc1 (>= 1:4.1.1) но 1:8.3.0-6ubuntu1~18.04 должен быть установлен
Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.16) но он не будет установлен
Depends: libgstreamer0.10-0 (>= 0.10.15) но он не будет установлен
Depends: gstreamer0.10-plugins-good но он не будет установлен


Как быть, подскажите пожалуйста. Не силен, новичек.
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Аватара пользователя

Ара Магеддон
Сообщения: 118
Зарегистрирован: 07 дек 2018, 22:08
Решено: 5
Благодарил (а): 7 раз
Поблагодарили: 23 раза

Opera и пакеты с неудовлетворенными зависимостями

Сообщение Ара Магеддон » 01 май 2019, 09:53

В менеджере программ всё ещё Опера 12 болтается, которая уже музейный экпонат, а не браузер. Не нужно это ставить :)
Ставить нужно именно deb пакет с официального сайта. Кстати, какая версия Mint'а, какая разрядность системы (32 или 64 бит), как именно пробовали устанавливать, на что ругался установщик?

Попробуйте ещё команды sudo apt remove --purge opera и sudo apt autoremove перед установкой пакета.


Автор темы
sgtpepermail
Сообщения: 17
Зарегистрирован: 23 ноя 2018, 11:32

Opera и пакеты с неудовлетворенными зависимостями

Сообщение sgtpepermail » 01 май 2019, 10:38

Тысяча извинений
Инфа о системе
Ара Магеддон писал(а):
01 май 2019, 09:53
Попробуйте ещё команды sudo apt remove --purge opera и sudo apt autoremove перед установкой пакета.
Не помогло.

Скачал с оф сайта deb пакет 64 версии. Открываю, нажимаю установить - Окно установки пакета закрывается и ничего не происходит.

А вообще использую Оперу для VPN, но последние пару недель плохо он работает. Видимо закрыли в опере халявный VPN. Похоже придется Vpn покупать.

Аватара пользователя

etamax
Сообщения: 506
Зарегистрирован: 16 дек 2017, 18:59
Решено: 5
Благодарил (а): 1 раз
Поблагодарили: 37 раз

Opera и пакеты с неудовлетворенными зависимостями

Сообщение etamax » 01 май 2019, 10:39

Не надо наезжать на оперу12. ТС - давай подробности.


Автор темы
sgtpepermail
Сообщения: 17
Зарегистрирован: 23 ноя 2018, 11:32

Opera и пакеты с неудовлетворенными зависимостями

Сообщение sgtpepermail » 01 май 2019, 11:22

Вроде все подробности написал.

Аватара пользователя

etamax
Сообщения: 506
Зарегистрирован: 16 дек 2017, 18:59
Решено: 5
Благодарил (а): 1 раз
Поблагодарили: 37 раз

Opera и пакеты с неудовлетворенными зависимостями

Сообщение etamax » 01 май 2019, 11:38

sgtpepermail писал(а):
01 май 2019, 09:22
Салют. Стояла Опера, нужно было снести и заново поставить. Скачал с оф сайта deb пакет - он не устанавливался.
Если это подробности , то Я Ужас Линукс Минта.


Автор темы
sgtpepermail
Сообщения: 17
Зарегистрирован: 23 ноя 2018, 11:32

Opera и пакеты с неудовлетворенными зависимостями

Сообщение sgtpepermail » 01 май 2019, 11:48

sgtpepermail писал(а):
01 май 2019, 09:22
Салют. Стояла Опера, нужно было снести и заново поставить. Скачал с оф сайта deb пакет - он не устанавливался. Затем зашел в Менеджер программ, смотрю появилась там Опера. Пытаюсь оттуда установить - пишет:
Следующие пакеты имеют неудовлетворённые зависимости:

opera: Depends: libgcc1 (>= 1:4.1.1) но 1:8.3.0-6ubuntu1~18.04 должен быть установлен
Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.16) но он не будет установлен
Depends: libgstreamer0.10-0 (>= 0.10.15) но он не будет установлен
Depends: gstreamer0.10-plugins-good но он не будет установлен


Как быть, подскажите пожалуйста. Не силен, новичек.

Аватара пользователя

etamax
Сообщения: 506
Зарегистрирован: 16 дек 2017, 18:59
Решено: 5
Благодарил (а): 1 раз
Поблагодарили: 37 раз

Opera и пакеты с неудовлетворенными зависимостями

Сообщение etamax » 01 май 2019, 11:57

Как удалял? Нужно было - sudo apt purge opera* - звёздочка потому что названия не помню , кажись opera-stable
Потом вручную удалить из домашней папки - ~/.config/opera - Это настройки пользователя. Потом поставить заново. Как то так.


Автор темы
sgtpepermail
Сообщения: 17
Зарегистрирован: 23 ноя 2018, 11:32

Opera и пакеты с неудовлетворенными зависимостями

Сообщение sgtpepermail » 01 май 2019, 13:22

Удалял просто в минюшке правой кнопкой на опере кликнул и удалил.
Конфиг вроде чистый (если я там смотрел)
Похоже я хромом пользоваться буду)

Аватара пользователя

Ара Магеддон
Сообщения: 118
Зарегистрирован: 07 дек 2018, 22:08
Решено: 5
Благодарил (а): 7 раз
Поблагодарили: 23 раза

Opera и пакеты с неудовлетворенными зависимостями

Сообщение Ара Магеддон » 01 май 2019, 13:53

Точно, opera-stable. Запамятовал.

Ну, если репозиторий оперы остался (который при установке подключается), то с него же и установить: sudo apt install opera-stable


Автор темы
sgtpepermail
Сообщения: 17
Зарегистрирован: 23 ноя 2018, 11:32

Opera и пакеты с неудовлетворенными зависимостями

Сообщение sgtpepermail » 01 май 2019, 14:01

Ара Магеддон спасибо! Так установилось.

Вернуться в «Работа с сетью»