Проблемы с Wine Mono

Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Для начала воспользуйтесь поиском форума. 2. Укажите версию ОС вместе с разрядностью. Пример: LM 19.3 x64, LM Sarah x32 3. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 4. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 5. Суть. Желательно с выводом консоли, логами. 6. Скрин. Просьба указывать 2, 3 и 4 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот

Автор темы
DarkTatarin
Сообщения: 6
Зарегистрирован: 05 ноя 2020, 10:50
Благодарил (а): 5 раз

Проблемы с Wine Mono

Сообщение DarkTatarin » 05 ноя 2020, 11:13

Здравствуйте. У меня не работают некоторые программы. Вот запускаю Undertale или Among Us, они работают. А вот Celeste не работает
0009:err:mscoree:CLRRuntimeInfo_GetRuntimeHost Wine Mono is not installed
Я устанавливал wine-complete, запускал wine-mono-4.9.4.msi через winetricks (отклика в терминале не было), через "wine uninstaller" (тоже самое).
Попробовал запустить msi-файл через "wine64 uninstaller", выходит это:
0009:fixme:ntdll:FILE_GetNtStatus Converting errno 8 to STATUS_UNSUCCESSFUL
002d:fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
ОС: Linux Mint 20.0 x64 Xfce
Wine: 5.0

Решение WWolf » 05 ноя 2020, 11:58
DarkTatarin, ясно... установи тогда как задумано sudo apt install wine-installer

Перейти к ответу ➙

Аватара пользователя

WWolf
Сообщения: 2646
Зарегистрирован: 13 фев 2018, 21:51
Решено: 16
Откуда: Краснодар
Благодарил (а): 929 раз
Поблагодарили: 747 раз

Проблемы с Wine Mono

Сообщение WWolf » 05 ноя 2020, 11:17

DarkTatarin, моно само должно качаться при создании префикса...
посмотри на месте ли он ~/.wine/drive_c/windows/mono/


Автор темы
DarkTatarin
Сообщения: 6
Зарегистрирован: 05 ноя 2020, 10:50
Благодарил (а): 5 раз

Проблемы с Wine Mono

Сообщение DarkTatarin » 05 ноя 2020, 11:19

WWolf писал(а):
05 ноя 2020, 11:17
DarkTatarin, моно само должно качаться при создании префикса...
посмотри на месте ли он ~/.wine/drive_c/windows/mono/
bash: cd: mono: Нет такого файла или каталога
Значит, сносить и заново установить?

Аватара пользователя

WWolf
Сообщения: 2646
Зарегистрирован: 13 фев 2018, 21:51
Решено: 16
Откуда: Краснодар
Благодарил (а): 929 раз
Поблагодарили: 747 раз

Проблемы с Wine Mono

Сообщение WWolf » 05 ноя 2020, 11:22

DarkTatarin, ну либо снести префикс и всё по новой начать... или как тут описано https://wiki.winehq.org/Mono в секции Prefix Local Install


Автор темы
DarkTatarin
Сообщения: 6
Зарегистрирован: 05 ноя 2020, 10:50
Благодарил (а): 5 раз

Проблемы с Wine Mono

Сообщение DarkTatarin » 05 ноя 2020, 11:29

WWolf писал(а):
05 ноя 2020, 11:22
DarkTatarin, ... или как тут описано https://wiki.winehq.org/Mono в секции Prefix Local Install
[/ref]
Не помогло, вывода нет, игра не запускается. Тогда сношу и пойду по новой. Есть ли хорошие инструкции? А то я просто через "apt install wine" устанавливал. А то тут вижу, что префиксы появились

Аватара пользователя

WWolf
Сообщения: 2646
Зарегистрирован: 13 фев 2018, 21:51
Решено: 16
Откуда: Краснодар
Благодарил (а): 929 раз
Поблагодарили: 747 раз

Проблемы с Wine Mono

Сообщение WWolf » 05 ноя 2020, 11:31

DarkTatarin, удали ~/.wine и запусти в терминале winecfg... он сам должен будет создать префикс и скачать/установить моно... после того как появится окно настроек префикса, закрывай его и ставь что хотел...


Автор темы
DarkTatarin
Сообщения: 6
Зарегистрирован: 05 ноя 2020, 10:50
Благодарил (а): 5 раз

Проблемы с Wine Mono

Сообщение DarkTatarin » 05 ноя 2020, 11:38

WWolf, очень странно, Wine Mono нет. Вот, что пишет терминал, когда создавал ~/.wine:
0012:err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
0012:err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
0012:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
0012:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
0012:err:ole:get_local_server_stream Failed: 80004002
0014:err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
0014:err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
0014:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
0014:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
0014:err:ole:get_local_server_stream Failed: 80004002
Could not find Wine Gecko. HTML rendering will be disabled.
Could not find Wine Gecko. HTML rendering will be disabled.

Аватара пользователя

WWolf
Сообщения: 2646
Зарегистрирован: 13 фев 2018, 21:51
Решено: 16
Откуда: Краснодар
Благодарил (а): 929 раз
Поблагодарили: 747 раз

Проблемы с Wine Mono

Сообщение WWolf » 05 ноя 2020, 11:43

DarkTatarin, видать не всё поставил... как ставил?


Автор темы
DarkTatarin
Сообщения: 6
Зарегистрирован: 05 ноя 2020, 10:50
Благодарил (а): 5 раз

Проблемы с Wine Mono

Сообщение DarkTatarin » 05 ноя 2020, 11:47

WWolf, ну я посмотрел архитектуру и установил через "apt install wine64"

Аватара пользователя

WWolf
Сообщения: 2646
Зарегистрирован: 13 фев 2018, 21:51
Решено: 16
Откуда: Краснодар
Благодарил (а): 929 раз
Поблагодарили: 747 раз

Проблемы с Wine Mono

Сообщение WWolf » 05 ноя 2020, 11:58

DarkTatarin, ясно... установи тогда как задумано sudo apt install wine-installer


Автор темы
DarkTatarin
Сообщения: 6
Зарегистрирован: 05 ноя 2020, 10:50
Благодарил (а): 5 раз

Проблемы с Wine Mono

Сообщение DarkTatarin » 05 ноя 2020, 12:13

WWolf, премного благодарен. Конечно, после "wine-mono....msi" в терминале вышло следующее:
reading registry key for installroot
0032:err:mscoree:LoadLibraryShim error reading registry key for installroot
0032:err:mscoree:LoadLibraryShim error reading registry key for installroot
0032:err:mscoree:LoadLibraryShim error reading registry key for installroot
Но главное, что exe запускается :dance:

Вернуться в «Xfce»