Минт 20 не переключается на наушники( часть 2)

Нет звука? Вас не устраивает качество звучания? Вы попали по адресу.
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Для начала воспользуйтесь поиском форума. 2. Укажите версию ОС вместе с разрядностью. Пример: LM 19.3 x64, LM Sarah x32 3. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 4. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 5. Суть. Желательно с выводом консоли, логами. 6. Скрин. Просьба указывать 2, 3 и 4 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот

Автор темы
ilikethat
Сообщения: 259
Зарегистрирован: 13 дек 2019, 22:46
Решено: 7
Благодарил (а): 63 раза
Поблагодарили: 45 раз

Минт 20 не переключается на наушники( часть 2)

Сообщение ilikethat » 31 янв 2021, 09:28

Возникла та же проблема, что и товарища chiv в теме
Минт 20 не переключается на наушники
1)При подключении наушников НЕ появляется устройство "Наушники" в настройках звука.
Приходится убивать pulseaudio pulseaudio -k
2)Если вставить наушники и перезагрузится - все ОК. Пока не вытащишь jack.
3)Рецепт с переустановкой НЕ помог
sudo apt install --reinstall alsa-base pulseaudio
sudo alsa force-reload
System:    Kernel: 5.8.0-41-generic x86_64 bits: 64 compiler: N/A Desktop: Cinnamon 4.6.7 
           Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal 
Machine:   Type: Desktop Mobo: Micro-Star model: X470 GAMING PRO CARBON (MS-7B78) v: 1.0 serial: <filter> 
           UEFI [Legacy]: American Megatrends v: 2.60 date: 01/23/2019 
CPU:       Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+ rev: 2 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 118386 
           Speed: 2404 MHz min/max: 2200/3700 MHz Core speeds (MHz): 1: 2577 2: 3107 3: 2114 4: 2190 5: 2146 6: 2249 
           7: 2198 8: 2189 9: 1810 10: 1732 11: 1719 12: 1729 13: 1820 14: 1782 15: 1889 16: 1819 
Graphics:  Device-1: NVIDIA TU106 [GeForce RTX 2060 Rev. A] vendor: ASUSTeK driver: nvidia v: 460.32.03 
           bus ID: 1c:00.0 
           Display: x11 server: X.Org 1.20.9 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA 460.32.03 direct render: Yes 
Audio:     Device-1: NVIDIA TU106 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 1c:00.1 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus ID: 1e:00.3 
           Sound Server: ALSA v: k5.8.0-41-generic 
Network:   Device-1: Intel I211 Gigabit Network vendor: Micro-Star MSI driver: igb v: 5.6.0-k port: f000 
           bus ID: 18:00.0 
           IF: enp24s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 5.89 TiB used: 1.91 TiB (32.5%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 500GB size: 465.76 GiB 
Partition: ID-1: / size: 49.25 GiB used: 18.79 GiB (38.2%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /home size: 345.05 GiB used: 61.23 GiB (17.7%) fs: ext4 dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 42.9 C mobo: 33.0 C gpu: nvidia temp: 42 C 
           Fan Speeds (RPM): fan-1: 462 fan-2: 946 fan-3: 677 fan-4: 1176 fan-5: 0 fan-6: 0 gpu: nvidia fan: 0% 
           Voltages: 12v: N/A 5v: N/A 3.3v: 3.34 vbat: 3.28 
Info:      Processes: 390 Uptime: 4m Memory: 15.65 GiB used: 2.34 GiB (15.0%) Init: systemd runlevel: 5 Compilers: 
           gcc: 9.3.0 Shell: bash v: 5.0.17 inxi: 3.0.38 
Кто еще сталкивался? Как лечить?

Аватара пользователя

symon2014
Сообщения: 5135
Зарегистрирован: 16 дек 2017, 18:59
Решено: 29
Откуда: Феодосия
Благодарил (а): 31 раз
Поблагодарили: 639 раз

Минт 20 не переключается на наушники( часть 2)

Сообщение symon2014 » 31 янв 2021, 09:33

ilikethat писал(а):
31 янв 2021, 09:28
При подключении наушников НЕ появляется устройство "Наушники" в настройках звука.
Правильно , у меня тоже. НО , как только включить что нибудь со звуком , например ютуб , то устройство появляется и звук идёт через наушники.

Аватара пользователя

rogoznik
Сообщения: 8358
Зарегистрирован: 27 июн 2017, 10:36
Решено: 92
Откуда: Нижний Тагил
Благодарил (а): 508 раз
Поблагодарили: 1510 раз

Минт 20 не переключается на наушники( часть 2)

Сообщение rogoznik » 31 янв 2021, 10:12

Собственно у меня все так же как сказал symon2014.
Подключаю наушники в порт(на передней панели системника) - реакции от системы не вижу никакой, но звук переключается на них. И если выдернуть наушники из порта - звук вновь играет на колонках, подключенных в порт на задней стенке корпуса(это который на мтеринке распаян)
System:    Kernel: 5.4.0-65-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: KDE Plasma 5.20.5 
           Distro: KDE neon 20.04 5.20 base: Ubuntu 20.04 LTS Focal 
Machine:   Type: Desktop Mobo: Gigabyte model: B450 GAMING X v: x.x serial: <filter> UEFI: American Megatrends v: F51 
           date: 07/29/2020 
CPU:       Topology: 6-Core model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+ rev: 2 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86233 
           Speed: 2196 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 2195 2: 2195 3: 2195 4: 2192 5: 2195 6: 2191 7: 2195 
           8: 2195 9: 2195 10: 2195 11: 2195 12: 2195 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
           vendor: Micro-Star MSI driver: amdgpu v: kernel bus ID: 07:00.0 
           Display: x11 server: X.Org 1.20.9 driver: amdgpu FAILED: ati unloaded: fbdev,modesetting,vesa 
           resolution: 2560x1440~60Hz 
           OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.35.0 5.4.0-65-generic LLVM 11.0.0) v: 4.6 Mesa 20.2.6 
           direct render: Yes 
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus ID: 07:00.1 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus ID: 09:00.3 
           Device-3: Logitech G430 Surround Sound Gaming Headset type: USB driver: hid-generic,snd-usb-audio,usbhid 
           bus ID: 1-2:2 
           Sound Server: ALSA v: k5.4.0-65-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 v: kernel 
           port: f000 bus ID: 04:00.0 
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 2.97 TiB used: 1.08 TiB (36.5%) 
           ID-1: /dev/nvme0n1 vendor: Seagate model: XPG GAMMIX S5 size: 953.87 GiB 
           ID-2: /dev/sda vendor: Silicon Power model: SPCC Solid State Disk size: 223.57 GiB 
           ID-3: /dev/sdb vendor: Toshiba model: HDWD120 size: 1.82 TiB 
Partition: ID-1: / size: 100.00 GiB used: 8.21 GiB (8.2%) fs: btrfs dev: /dev/nvme0n1p3 
           ID-2: /home size: 831.30 GiB used: 131.45 GiB (15.8%) fs: ext4 dev: /dev/nvme0n1p4 
           ID-3: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 40.6 C mobo: N/A gpu: amdgpu temp: 40 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 969 
Info:      Processes: 331 Uptime: 2h 34m Memory: 15.65 GiB used: 3.24 GiB (20.7%) Init: systemd runlevel: 5 Compilers: 
           gcc: 9.3.0 Shell: zsh v: 5.8 inxi: 3.0.38
ИзображениеИзображение

Аватара пользователя

symon2014
Сообщения: 5135
Зарегистрирован: 16 дек 2017, 18:59
Решено: 29
Откуда: Феодосия
Благодарил (а): 31 раз
Поблагодарили: 639 раз

Минт 20 не переключается на наушники( часть 2)

Сообщение symon2014 » 31 янв 2021, 10:14

rogoznik писал(а):
31 янв 2021, 10:12
реакции от системы не вижу никакой
У меня в pavucontrol надпись Динамики меняется на Аналоговые наушники.

Аватара пользователя

rogoznik
Сообщения: 8358
Зарегистрирован: 27 июн 2017, 10:36
Решено: 92
Откуда: Нижний Тагил
Благодарил (а): 508 раз
Поблагодарили: 1510 раз

Минт 20 не переключается на наушники( часть 2)

Сообщение rogoznik » 31 янв 2021, 10:19

symon2014 писал(а):
31 янв 2021, 10:14
pavucontrol
Не ставил его. Однако не будешь же его все время открытым держать чтоб наблюдать за реакцией
ИзображениеИзображение

Аватара пользователя

symon2014
Сообщения: 5135
Зарегистрирован: 16 дек 2017, 18:59
Решено: 29
Откуда: Феодосия
Благодарил (а): 31 раз
Поблагодарили: 639 раз

Минт 20 не переключается на наушники( часть 2)

Сообщение symon2014 » 31 янв 2021, 10:21

rogoznik писал(а):
31 янв 2021, 10:19
Однако не будешь же его все время открытым держать чтоб наблюдать за реакцией
Даже не задавался таким вопросом , переключается и ладно. А посмотрел только из-за этой темы.


Автор темы
ilikethat
Сообщения: 259
Зарегистрирован: 13 дек 2019, 22:46
Решено: 7
Благодарил (а): 63 раза
Поблагодарили: 45 раз

Минт 20 не переключается на наушники( часть 2)

Сообщение ilikethat » 31 янв 2021, 13:11

symon2014, спасибо.
Действительно, наушники появляются только после начала воспроизвидения звука.
А у меня, звук на них не переключался, поскольку было перекрыто событие
/etc/acpi/events/jack-connected
убрал и стало все ок.

Вернуться в «Звуковые карты»