Обновление adobe flash player

Интернет
Правила форума
Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа.
Аватара пользователя
Rina O
Сообщения: 27
Зарегистрирован: 31 янв 2017, 17:36
Решено: 1
Благодарил (а): 3 раза

Обновление adobe flash player

Сообщение Rina O » 03 фев 2017, 14:59

Добрый день! Никак не хочет обновлятся flash player, пишет "канал qiana-partner не опознан". Linux mint 17, firefox. Обновление браузера не спасает.
--
Linux Mint 17.3 Chinnamon 64-bit

Аватара пользователя
Chocobo
Сообщения: 4564
Зарегистрирован: 27 авг 2016, 19:57
Решено: 108
Откуда: НН
Благодарил (а): 373 раза
Поблагодарили: 1223 раза

Обновление adobe flash player

Сообщение Chocobo » 03 фев 2017, 15:56

Rina O, где проявляется эта ошибка, в "Менеджере обновлений"?
Изображение

Аватара пользователя
Rina O
Сообщения: 27
Зарегистрирован: 31 янв 2017, 17:36
Решено: 1
Благодарил (а): 3 раза

Обновление adobe flash player

Сообщение Rina O » 03 фев 2017, 17:06

нет, в менеджере обновлений нет обновлений флеш плеера. Пытаюсь скачать через оф. сайт.
--
Linux Mint 17.3 Chinnamon 64-bit

Аватара пользователя
Chocobo
Сообщения: 4564
Зарегистрирован: 27 авг 2016, 19:57
Решено: 108
Откуда: НН
Благодарил (а): 373 раза
Поблагодарили: 1223 раза

Обновление adobe flash player

Сообщение Chocobo » 03 фев 2017, 17:22

Rina O, так, теперь понял о чем речь - мне вывалил то же самое (только у меня не qiana)
adobe.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Изображение

Аватара пользователя
Rina O
Сообщения: 27
Зарегистрирован: 31 янв 2017, 17:36
Решено: 1
Благодарил (а): 3 раза

Обновление adobe flash player

Сообщение Rina O » 03 фев 2017, 17:23

Да, оно
--
Linux Mint 17.3 Chinnamon 64-bit

Аватара пользователя
colonel
Сообщения: 295
Зарегистрирован: 18 дек 2016, 09:08
Решено: 10
Благодарил (а): 14 раз
Поблагодарили: 87 раз

Обновление adobe flash player

Сообщение colonel » 03 фев 2017, 17:33

только сегодня после того как появилась эта тема на 17.3 через синаптик установил\обновил до 24.0.0.194
adobe-flashplugin (Adobe Flash Player plugin) v 1:20170110.1-0ubuntu0.14.04.1 (в браузере показывает что у мну Flash Player for Linux Version 24.0.0.194 )
С оф.сайта, с этой странички https://get.adobe.com/flashplayer/ без проблем скачалась та же версия в архиве flash_player_npapi_linux.x86_64.tar.gz

причём здесь "канал qiana-partner не опознан" при скачивании плагина с офсайта для ручной установки я не понимаю.
в репах минт этого плагина нет , скорее всего он имеется в репах убунты .
Что подключено из убунтушных реп? В терминале вывод команды inxi -r что показывает?
"Не ты выбираешь Linux, а Linux выбирает тебя"
(с)Себастьян Перейра, торговец чёрным деревом

Аватара пользователя
Chocobo
Сообщения: 4564
Зарегистрирован: 27 авг 2016, 19:57
Решено: 108
Откуда: НН
Благодарил (а): 373 раза
Поблагодарили: 1223 раза

Обновление adobe flash player

Сообщение Chocobo » 03 фев 2017, 17:39

colonel, ошибка из браузера выскакивает при попытке APT-версии. при этом значение $distro-partner он берет из третьей строки /etc/lsb_release, где codename (на скрине у меня betsy2, хотя она заведомо просто betsy)
Пробовал играть с именами дистрибутивов (jessie, trusty, xenial) - результат один.

tar.gz качается без проблем, в readme расписано как установить руками, это да. Но вот тот метод что позиционируется как для Debian/Ubuntu - работать что-то отказывается :hm:
Изображение

Аватара пользователя
colonel
Сообщения: 295
Зарегистрирован: 18 дек 2016, 09:08
Решено: 10
Благодарил (а): 14 раз
Поблагодарили: 87 раз

Обновление adobe flash player

Сообщение colonel » 03 фев 2017, 17:49

Chocobo, тысчулет уже как вроде должно быть понятно что апт годится для бубунты , и фиговничает с минт (в тч. и из-за разницы в названиях дистрибутивов ...ещё со времён второгнома началось)
С оф.сайта - ручками и только ручками... как в общем в readme.txt расписано распаковываем скачанный архив и копируем содержимое куда следует

но у мну и в синаптике нашлось обновление (обновлятор mintupdate включаю редко)
"Не ты выбираешь Linux, а Linux выбирает тебя"
(с)Себастьян Перейра, торговец чёрным деревом

Аватара пользователя
Chocobo
Сообщения: 4564
Зарегистрирован: 27 авг 2016, 19:57
Решено: 108
Откуда: НН
Благодарил (а): 373 раза
Поблагодарили: 1223 раза

Обновление adobe flash player

Сообщение Chocobo » 03 фев 2017, 17:52

colonel, интересно выяснить что же он схавает для подстановки в apt: :smile:

убунту чтоль какую расчехлить :scratch:
Изображение

Аватара пользователя
colonel
Сообщения: 295
Зарегистрирован: 18 дек 2016, 09:08
Решено: 10
Благодарил (а): 14 раз
Поблагодарили: 87 раз

Обновление adobe flash player

Сообщение colonel » 03 фев 2017, 18:14

Chocobo, :dntnw:
а можно и деб найти - здесь к примеру https://pkgs.org/download/adobe-flashplugin
ну а вообще-то для убунтообразных - вот здесь http://archive.canonical.com/ubuntu/poo ... ashplugin/ этот плагин есть и через синаптик и через "обновлятор" должен обновляться , если конечно
deb http://archive.canonical.com/ubuntu/ trusty partner в репах записан
"Не ты выбираешь Linux, а Linux выбирает тебя"
(с)Себастьян Перейра, торговец чёрным деревом

Аватара пользователя
Rina O
Сообщения: 27
Зарегистрирован: 31 янв 2017, 17:36
Решено: 1
Благодарил (а): 3 раза

Обновление adobe flash player

Сообщение Rina O » 03 фев 2017, 19:16

Попробовала tar.gz, видно руки не из того места растут. Не выходит каменный цветок!
Скачала, распаковала, скопировала в папку /usr/lib/firefox (там нет отдельной папки для плагинов), в папку юзер тоже что надо скопировала. А толку ноль
--
Linux Mint 17.3 Chinnamon 64-bit

Аватара пользователя
colonel
Сообщения: 295
Зарегистрирован: 18 дек 2016, 09:08
Решено: 10
Благодарил (а): 14 раз
Поблагодарили: 87 раз

Обновление adobe flash player

Сообщение colonel » 04 фев 2017, 03:22

И гдеж там в readme.txt из скачанного tar.gz написано его надо скопировать в папку /usr/lib/firefox ?
Или что вы там в /usr/lib/firefox копировали?
readme.txt ► Показать


Сказано же -> скачать архив куданить в нужное вам локальное место, распаковать....
определить местоположение каталога для плагина, исходя из вашего дистрибутива Linux и Firefox версии
и скопировать libflashplayer ( т.е файлик libflashplayer.so из скачанного архива) в соответствующий каталог плагинов.
собственно пользоваться для этих операций терминалом и командами или сделать всё в обычном браузере запущенном с админскими правами -дело вкуса.

Rina O писал(а):Источник цитаты... usr/lib/firefox (там нет отдельной папки для плагинов )

если вдруг там не было папки /plugins , то возможно она имеется рядом в /usr/lib/firefox-addons/ или в /usr/lib/mozilla
но туда скорее всего не надо копировать , т.к. там в ... /plugins ссылки на libflashplayer.so в другой каталог где этот плагин и размещён
емнип, в минт17.* и 18.* для libflashplayer.so от адобе предусмотрен каталог /usr/lib/adobe-flashplugin, хотя может вдруг у вас ещё в каком другом месте - поиск в файловомманагере по системному разделу вам в помощь для поиска libflashplayer.so .

В конце концов в сообщении #10 указаны ещё два способа как установить этот плагин ( можно скачать .deb с сайта или из реп или подключить убунтушный реп каноникал и через обновлятор или синаптик) и имхо это будет лучше .... в деб кроме libflashplayer.so ещё кое чего ставится, типа libpepflashplayer.so
"Не ты выбираешь Linux, а Linux выбирает тебя"
(с)Себастьян Перейра, торговец чёрным деревом

Аватара пользователя
Rina O
Сообщения: 27
Зарегистрирован: 31 янв 2017, 17:36
Решено: 1
Благодарил (а): 3 раза

Обновление adobe flash player

Сообщение Rina O » 04 фев 2017, 07:44

colonel писал(а):Источник цитаты Copy the Flash Player Local Settings configurations files to the /usr directory. At the prompt type:
+ sudo cp -r usr/* /usr

Может я не так это расшифровала?
Нашла файлик в /usr/lib/mozilla, теперь все работает, спасибо!
--
Linux Mint 17.3 Chinnamon 64-bit

Аватара пользователя
colonel
Сообщения: 295
Зарегистрирован: 18 дек 2016, 09:08
Решено: 10
Благодарил (а): 14 раз
Поблагодарили: 87 раз

Обновление adobe flash player

Сообщение colonel » 04 фев 2017, 08:35

Rina O писал(а):Источник цитаты
Copy the Flash Player Local Settings configurations files to the /usr directory. At the prompt type:
+ sudo cp -r usr/* /usr
Может я не так это расшифровала? ...

нет , просто вы не прочитали или прочитали, но не выполнили от слова "совсем"
вот эти указания инструкции ► Показать
что означало
- включить терминал и перейти в каталог куда был скачан архив tar.gz
- рапаковав архив и увидеть libflashplayer.so и папку /usr
- в браузере определить раместо где у вас расположен плагин, исходя из вашего дистрибутива Linux и Firefox версии
и скопировать файлик libflashplayer.so в соответствующий каталог.

что относительно неправильно вами расшифрованного - " Copy the Flash Player Local Settings configurations files to the /usr directory. At the prompt type:
+ sudo cp -r usr/* /usr "
,
так здесь казано что в надо в терминале(находясь всё в том же каталоге с содержимым скачанного архива ) выполнить указанную команду - т.е. с правами от админа скопировать всё содержимое папки usr в каталог /usr что в корне вашей системы
"Не ты выбираешь Linux, а Linux выбирает тебя"
(с)Себастьян Перейра, торговец чёрным деревом

Аватара пользователя
Rina O
Сообщения: 27
Зарегистрирован: 31 янв 2017, 17:36
Решено: 1
Благодарил (а): 3 раза

Обновление adobe flash player

Сообщение Rina O » 04 фев 2017, 09:24

colonel писал(а):Источник цитаты так здесь казано что в надо в терминале(находясь всё в том же каталоге с содержимым скачанного архива ) выполнить указанную команду - т.е. с правами от админа скопировать всё содержимое папки usr в каталог /usr что в корне вашей системы

Так я и сделала, и остальные инструкции тоже проделала. Только сначала файлик .so не в ту папку сохранила. Ну да ладно, теперь-то все работает. Благодарю за помощь :vic:
--
Linux Mint 17.3 Chinnamon 64-bit


Вернуться в «Работа с сетью»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей