Обновления 3-го уровня в Линукс Минт.

Руководства, вопросы, обсуждения
Правила форума
Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа.

Автор темы
Sergei K.
Сообщения: 49
Зарегистрирован: 09 дек 2016, 21:59
Благодарил (а): 16 раз
Поблагодарили: 2 раза

Обновления 3-го уровня в Линукс Минт.

Сообщение Sergei K. » 15 мар 2017, 11:53

Добрый день. Был бы благодарен за разъяснения относительно установки / не установки обновлений 3-го уровня.
Прочитал, что новичкам в Линуксе рекомендуется устанавливать только обновления 1 и 2 уровня, то есть по принципу "Ничего не сломать". Так и делаю. Примерно с начала декабря 2016 у меня был установлен Linux Mint 18 Mate, неделю назад обновил до версии 18.1. Использую ноутбук под простые задачи:
  1. - электронная почта,
  2. - просмотр сайтов в Интернете,
  3. - Скайп
  4. - сохранение и просмотр фотографий,
  5. - иногда создание или сохранение обычных текстовых документов (LibreOffice по умолчанию), иногда в jpg и pdf, а также их сканирование и распечатка,
  6. - очень редко просмотр кино из Интернета.
У меня ноутбук Asus N550JK, процессор i7-4710HQ, ОЗУ 8 ГБ, видеокарта NVIDIA GeForce GTX 850м. Вроде всё работает нормально, но иногда сомнения появляются, правильно ли поступаю, что только 1 и 2 уровень устанавливаю. Ведь в 3-ем уровне много обновлений по безопасности. Может хотя бы их нужно ставить? Или и без этого все в полном порядке?
Последний раз редактировалось пользователем 1 Dja; всего редактировалось раз: 7
Причина: BB-codes

Аватара пользователя

di_mok
Сообщения: 2226
Зарегистрирован: 27 авг 2016, 16:06
Решено: 15
Откуда: Арзамас
Благодарил (а): 581 раз
Поблагодарили: 341 раз

Обновления 3-го уровня в Линукс Минт.

Сообщение di_mok » 15 мар 2017, 12:04

3й уровень входит в как-бе в дефолтную политику обновлений и считается безопасными. Я лично обновляю, ни чего не изломал.

Если провести аналогию с Ubuntu, так там вообще всё подряд прилетает. И вроде ещё ни кто не умер
Настоящая водка — это не пьянство, а ключ к своей совести, с нее-то и начинается настоящая мудрость. (c)


Автор темы
Sergei K.
Сообщения: 49
Зарегистрирован: 09 дек 2016, 21:59
Благодарил (а): 16 раз
Поблагодарили: 2 раза

Обновления 3-го уровня в Линукс Минт.

Сообщение Sergei K. » 15 мар 2017, 12:22

di_mok писал(а): 3й уровень входит в как-бе в дефолтную политику обновлений и считается безопасными. Я лично обновляю, ни чего не изломал.
Спасибо за ответ. Меня смущало то, что написано там примерно так: да, обновления 3-го уровня считаются безопасными, но создателями Линукса они не проверены.

Аватара пользователя

Chocobo
Сообщения: 5568
Зарегистрирован: 27 авг 2016, 19:57
Решено: 130
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1447 раз

Обновления 3-го уровня в Линукс Минт.

Сообщение Chocobo » 15 мар 2017, 12:23

Sergei K., не проверены мейнтейнерами минта, но идут уже проверенными от апстрима убунты.
Как-то вот так. В общем верить можно)


Автор темы
Sergei K.
Сообщения: 49
Зарегистрирован: 09 дек 2016, 21:59
Благодарил (а): 16 раз
Поблагодарили: 2 раза

Обновления 3-го уровня в Линукс Минт.

Сообщение Sergei K. » 15 мар 2017, 12:32

Chocobo писал(а): не проверены мейнтейнерами минта, но идут уже проверенными от апстрима убунты.
Как-то вот так. В общем верить можно)
Спасибо за ответ. di_mok то же самое сказал. Сейчас обновлюсь.

Аватара пользователя

Obamacyborg1975
Сообщения: 177
Зарегистрирован: 27 сен 2016, 05:19
Благодарил (а): 52 раза
Поблагодарили: 37 раз

Обновления 3-го уровня в Линукс Минт.

Сообщение Obamacyborg1975 » 15 мар 2017, 12:34

По дефолту, при обновлении, установлены галочки напротив 1-3 уровней. Проблем не должно возникнуть при их установке. Обновления уровней 4 и 5 могут быть проблематичные. Но, как известно, Linux Mint известен свой параноидальным поведением (что касается обновлений). Например, то, что у Linux Mint 4 и 5 уровней, в Ubuntu устанавливается "автоматом". В Linux Mint политика такова-каждый сам решает какая система ему нужна-стабильная, но с риском быть уязвимой (я про обновы безопасности), или пропаченная, с последними обновлениями, но с риском поймать багг. Так что, тут нету универсального решения. Лично я устанавливаю все обновы 1-3 уровней, забив на другие уровни.


Автор темы
Sergei K.
Сообщения: 49
Зарегистрирован: 09 дек 2016, 21:59
Благодарил (а): 16 раз
Поблагодарили: 2 раза

Обновления 3-го уровня в Линукс Минт.

Сообщение Sergei K. » 15 мар 2017, 12:55

Obamacyborg1975 писал(а): Лично я устанавливаю все обновы 1-3 уровней, забив на другие уровни.
Спасибо за ответ. Уже обновился, действительно всё нормально. Как и Минт, я считаю, что немного "здоровой паранойи" не помешает. Тем более, что в отличие от спецов я уже ничего не смогу исправить в случае поломки. Придется у кому-то обращаться.

Аватара пользователя

LinDeMin
Сообщения: 87
Зарегистрирован: 04 сен 2016, 17:37
Откуда: в этом я не оригинален
Благодарил (а): 1 раз
Поблагодарили: 17 раз

Обновления 3-го уровня в Линукс Минт.

Сообщение LinDeMin » 15 мар 2017, 12:59

Грубо говоря, так: 1-2, это системные обновления и обновления софта. А уровень три - это, как правило, "заплатки" на недосмотр программеров. Я не стал бы ими пренебрегать. И не пренебрегаю. :smile:
А "сломать" Минт... тут нужно ох каким силачом быть. Даже моя жена не в состоянии его доконать :-D
Suum cuique

Аватара пользователя

symon2014
Сообщения: 1578
Зарегистрирован: 29 авг 2016, 02:17
Решено: 19
Откуда: Феодосия
Благодарил (а): 47 раз
Поблагодарили: 427 раз

Обновления 3-го уровня в Линукс Минт.

Сообщение symon2014 » 15 мар 2017, 13:23

А я всегда с одобрением поглядываю на 5 уровень, ведь только оттуда приходят новые ядра.
Категорически не одобрям только "proposed". :smile:










к
:sry:
Debian (9.1) , LMDE2 , LM 18.2 Mate . Благодарности складываем сюда ---> R320161344462

Аватара пользователя

Nik-Neim
Сообщения: 335
Зарегистрирован: 04 дек 2016, 08:52
Решено: 1
Откуда: Где-то в Подмосковье
Благодарил (а): 283 раза
Поблагодарили: 118 раз

Обновления 3-го уровня в Линукс Минт.

Сообщение Nik-Neim » 15 мар 2017, 14:27

[quote="Sergei K."] Тем более, что в отличие от спецов я уже ничего не смогу исправить в случае поломки. Придется у кому-то обращаться.[/quote]
Можно и не обращаться ни к кому, предварительно установив программку типа Systemback, ну, или аналог.
Снимок экрана_2017-03-15_17-23-29.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.


Автор темы
Sergei K.
Сообщения: 49
Зарегистрирован: 09 дек 2016, 21:59
Благодарил (а): 16 раз
Поблагодарили: 2 раза

Обновления 3-го уровня в Линукс Минт.

Сообщение Sergei K. » 16 мар 2017, 21:57

Всем спасибо за советы.


Unborn
Сообщения: 795
Зарегистрирован: 03 сен 2016, 10:36
Решено: 15
Благодарил (а): 2 раза
Поблагодарили: 120 раз

Обновления 3-го уровня в Линукс Минт.

Сообщение Unborn » 18 мар 2017, 06:55

Sergei K. писал(а): У меня ноутбук Asus N550JK, прицессор i7-4710HQ, ОЗУ 8 ГБ, видеокарта NVIDIA GeForce GTX 850м.
На такой железке прямо не грех собрать ядро под неё.
symon2014 писал(а): А я всегда с одобрением поглядываю на 5 уровень, ведь только оттуда приходят новые ядра.
А на твоём металлоломе вообще не нужно ядро обновлять. Если от дури или по пьянкке.

Аватара пользователя

symon2014
Сообщения: 1578
Зарегистрирован: 29 авг 2016, 02:17
Решено: 19
Откуда: Феодосия
Благодарил (а): 47 раз
Поблагодарили: 427 раз

Обновления 3-го уровня в Линукс Минт.

Сообщение symon2014 » 18 мар 2017, 10:30

 ! Сообщение из: symon2014
Unborn, Во избежание комментариев не в тему Вам делается предупреждение . Пока устное.
:sry:
Debian (9.1) , LMDE2 , LM 18.2 Mate . Благодарности складываем сюда ---> R320161344462


Unborn
Сообщения: 795
Зарегистрирован: 03 сен 2016, 10:36
Решено: 15
Благодарил (а): 2 раза
Поблагодарили: 120 раз

Обновления 3-го уровня в Линукс Минт.

Сообщение Unborn » 18 мар 2017, 13:47

symon2014, Я, что то не не так сказал? Надо быть чудаком на на букву М, чтобы советовать людям залезть на пальму.
И, кстати, ты ты удалил свой глупый пост с дебианского форума?


dworg1
Сообщения: 7
Зарегистрирован: 22 фев 2017, 13:53
Поблагодарили: 1 раз

Обновления 3-го уровня в Линукс Минт.

Сообщение dworg1 » 18 мар 2017, 15:50

Sergei K. писал(а): Может хотя бы их нужно ставить? Или и без этого все в полном порядке?
Бэкапирую папку Home и ставлю все и всегда. Пока никаких проблем :)


Автор темы
Sergei K.
Сообщения: 49
Зарегистрирован: 09 дек 2016, 21:59
Благодарил (а): 16 раз
Поблагодарили: 2 раза

Обновления 3-го уровня в Линукс Минт.

Сообщение Sergei K. » 18 мар 2017, 15:59

symon2014 писал(а): А я всегда с одобрением поглядываю на 5 уровень, ведь только оттуда приходят новые ядра.
Как говорится, со всем желанием и "белой завистью", но такие варианты не для меня. Я ведь обычный пользователь компьютера.

В сети
Аватара пользователя

colonel
Сообщения: 441
Зарегистрирован: 18 дек 2016, 09:08
Решено: 10
Благодарил (а): 18 раз
Поблагодарили: 118 раз

Обновления 3-го уровня в Линукс Минт.

Сообщение colonel » 18 мар 2017, 16:01

А мне вот интересно как могут обновления безопасности быть опасными обновлениями :-D
или наоборот ли
как могут опасные обновления быть (или называться) обновлениями безопасности
updating.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Последний раз редактировалось пользователем 2 colonel; всего редактировалось раз: 18
"Не ты выбираешь Linux, а Linux выбирает тебя"
(с)Себастьян Перейра, торговец чёрным деревом


dworg1
Сообщения: 7
Зарегистрирован: 22 фев 2017, 13:53
Поблагодарили: 1 раз

Обновления 3-го уровня в Линукс Минт.

Сообщение dworg1 » 18 мар 2017, 16:02

Sergei K. писал(а):Как говорится, со всем желанием и "белой завистью", но такие варианты не для меня. Я ведь обычный пользователь компьютера.
Ну так патчи выпускаются для устранения проблем, а не их создания :)

Аватара пользователя

Chocobo
Сообщения: 5568
Зарегистрирован: 27 авг 2016, 19:57
Решено: 130
Откуда: НН
Благодарил (а): 411 раз
Поблагодарили: 1447 раз

Обновления 3-го уровня в Линукс Минт.

Сообщение Chocobo » 18 мар 2017, 16:25

dworg1, По этой причине обновления 5-го уровня актуальны тогда, когда проблемы присуствуют :blink:
Иначе присутствует возможность их огрести.

Было как-то, после подобного минорного обновления ядра dmesg пополнился ошибками от acpi, а система стала загружаться на треть дольше по времени - откат на предыдущую версию все нормализовал.


dworg1
Сообщения: 7
Зарегистрирован: 22 фев 2017, 13:53
Поблагодарили: 1 раз

Обновления 3-го уровня в Линукс Минт.

Сообщение dworg1 » 18 мар 2017, 18:19

Chocobo писал(а):По этой причине обновления 5-го уровня актуальны тогда, когда проблемы присуствуют :blink:
Иначе присутствует возможность их огрести.

Было как-то, после подобного минорного обновления ядра dmesg пополнился ошибками от acpi, а система стала загружаться на треть дольше по времени - откат на предыдущую версию все нормализовал.
Полностью согласен в случае рабочих машин.

Но поскольку возможность загрузки ядра предыдущих версий предусмотрена, то дома можно и обновить систему. Плюс, для большей осторожности такие обновления можно ставить с месяц после релиза, давая девелоперам время отозвать или исправить в случае проблем.

Вернуться в «Параметры и оптимизация»